Need help merging corrupt bios DUMP with working dump to reflash


New to the board but amazed with the knowledge on here!

Long story short, got an Alienware 15 r2 with motherboard AAP20 LA-B753P Rev 1.0 that was bricked during a failed BIOS update. Laptop currently wont turn on, only power light and keyboard lights up!

Have managed to pull off backup.bin with a 341 but need help in creating a new .bin to flash back onto the chip.

Flashrom is reporting the chip as Gigadevice flash chip "GD25Q64(B)"

Any help is greatly appreciated as the laptop was working fine before so really don’t won’t it to be scrapped and new MB is hard to come by!

Files attached

Many Thanks

Dell Alienware 17 R2 AAP20 LA-B753P Rev 1.0(A00) 2014-11-17 Bios + EC.rar (4.29 MB)

backup.rar (4.28 MB)

Not sure how i created the post as a guest but post is from me!

@wh33t - you have “Stock” I assume, 17 R2 BIOS there, but your board is 15 R2. I thought 17 R2 was only same as 15 R1, and 15 R2 was only same as 17 R3? Is this confusion maybe how/why you bricked your board?
Ahh! More confusion, on my end I have some folders with 17 R2-15 R2 Do you have a dump, or ANY backup of your BIOS in any way, before you bricked it? This way I can confirm which BIOS it should be.
I compared your dump with others I have, and it matched FID (Flash ID) of 17 R2 / 15 R1 AND 17 R2 / 15 R2 - So I guess this is just Dell’s mess and we have to deal with it

How was this bricked, just bad stock BIOS update, or did you modify the BIOS at all? I can fix for you, and unlock the menu’s

@Lost_N_BIOS Thanks so much for replying!

Unfortunately I don’t have a backup of the BIOS before it got bricked!

I was doing a BIOS flash using the dell app with the BIOS that dell website automatically selected when I put my service tag in but the laptop froze half way through, I left it for 12 hours just to be sure but nothing so I had to unplug and let the battery die to get the laptop to turn off!

I was trying to upgrade to A12 and I think i was coming from A10. No modding, just trying to update the stock BIOS as advised on Dell website!

Any help greatly appreciated as laptop is obviously a decent bit of kit and working fine other than this (Yes, “Don’t fix what isn’t broke” hahaha)

You’re welcome! OK, then we’ll have to proceed with BIOS as it’s found. Do you remember your asset tag, or LAN MAC ID? Send me both if you have, serial or service tag too.

PM sent, thanks

@wh33t - Fixed BIOS, unlocked FD, updated ME FW, updated CPU Microcodes (except 306D3), NVME Mod + BIOS Menus Unlocked
If this fails to boot, it may be because I copied over your NVRAM (if corrupted it could cause fail, or if too different from A09 it may mess up instead of brick as well)
If it’s a brick or BIOS messed up, let me know and I will remake with stock NVRAM only, or redo all this onto A09 instead first, then you can reflash to A10 via stock method, dump and send to me for NVRAM transplant, and then I will send new A10 and you can then program it in and all should be OK…703812876746378

You are a star! I will flash it later today and let you know the outcome!


@Lost_N_BIOS I flashed it successfully but unfortunately it still will not boot. Power button lights up for about 30 seconds and then turns off again. No display or anything but CPU is warming up


@Lost_N_BIOS Progress!! I reflashed again to be sure and this time we have life!! You are a star! Only problem I have right now is it won’t boot windows in UEFI boot mode and if I change to legacy it doesn’t recognise any OS on the drive either. Any idea what could cause this as HDD and OS was fine before?


All sorted! Just needed to run some boot fixing tools from usb and we are now all back up and running!! Thanks you so much again, you have saved me having an expensive door stopper!

@wh33t - Great to hear you have it all sorted out now! Sorry, I didn’t mention before, but you should have cleared CMOS before the write, and then load optimized defaults in the BIOS upon first boot, then save and reboot back to BIOS and make rest of your changes,

Glad you got it all going eventually! And yes, it’s good to see we saved your board from being a doorstop!

If you have not already loaded optimal defaults, I would do that now, then save and reboot back to BIOS and set everything again, this way you are not using fail safe as a starting point (many things in background will be set wrong if you do)

* Did you see all the new BIOS options??

Hi there
I am one of the user bricked my r2 in almost exactly the same situation, and as far as I searched, you are the only person mentioning a success!

Please help me!!!

Would you like to spare some time sharing your detail instructions here? Since I am not very familiar with all the BIOS modding terms, I may need some more detailed aids! Thanks!

@Lost_N_Bios i am facing similar situation were i tried to update from A00 to A12 but ended up with bricked laptop.

I have managed to get the dump file after the bios brick using CH341a. Could you please help me with this because this is only laptop I have i have spend 800$ on it

I managed to get bios file and ec file from different website and flashed it but still no sign of life. But fan spins when I connect USB and press end key with ac adapter connected ( Bios Bootblock)

I tried different bios + ec file from internet but doesn’t work. For some reason the dump file of bios and ec is gone from my secondary machine.

So I am back to square 1. If anyone could help me that would be wonderful.

Here is the link for the current Bios and EC I programmed to my chips.


I have an i7 4980HQ Processor with 4GB GTX 980m.

Service Tag - CSYQN32
Express Service - 27872790878

Mac address from wifi card - ACD1B8622E5B

Please help !!!

I am looking for the default factory bios for the LA-B753P 15 r1 /17 motherboard what options do i have.
my me region is broken and no gbe or pdr region also the icc overclock library is bad aswell

any way to get the bios back to where you have to put in the service tag? \