Need help on a stubborn Intel DX58SO2 desktop board

Hello Friends,
Maybe you are my Last hope.

I had a Xeon E5645 and wanted to set Up a cheap x58 pc.
Founded this DX58SO2 desktop Board in good conditions, but I am unable to make it work.

The watch dog led always blinks when I Switch on the plarform and Screen stays black, maybe for a past set Up.

I cannot reset bios, as it seems nearly impossible to do so.
I can re flash the bios from the recovery procedure, it completes e without problems (it is an automatic bios update procedure with an usb loaded with the bios)

I noticed that the cpu is not supported officially, I know that Xeons sie cores should work anyway (i7 980X is supported), but maybe with a properly modded bios with updated microcodes things could change.

Can someone help me? The bios is a Frankenstein one, modified Phoenix semi-uefi…

Thank you so much.

SOX5820J.86A.0920.BI.ZIP (2.74 MB)

To modify Intel BIOS you must dump with flash programmer (like CH341A) and then mod, then reprogram. If your BIOS is soldered to the board you also need SOIC8 test clip cable.
Once you dump BIOS, microcodes can be added, but that may or may not allow this to work, but that is the only way to mod the BIOS and get it back on there. You can mod the stock BIOS package, but you can’t flash it, so don’t waste your time, this is well known thing with Intel BIOS.
But, maybe you will get lucky, I’ve seen some say no problem, but never proved they found a way to flash… Recovery method might work, but I bet it breaks the signature and wont flash.

I went to mod the BIOS and see this already has 2x 206C2 microcodes in there, and one is 2013 too. So this CPU should be already supported, launched in 2010/2011.
I can put in 2015 or 2018 microcode for you if you want, but I assume you’ll need to dump BIOS before we can do it properly to where you can use the file.
Maybe you will get lucky with recovery method? Hopefully you have another known working CPU with this board, so you can verify if it gets flashed in, fails to flash, or bricks etc…372461151997682

Thank you so much. A compatibile xeon is on its way.
I will try your file and see.
Let’s hope for the best.

Meanwhile, if you know how to hard reset the bios of this mainboard, please let me know.

You’re welcome. W35xx should be 100% compatible since launch of i7-920 hopefully you picked one of those. Hard reset of BIOS, clear CMOS pins should be there somewhere, if not remove the CMOS battery, unplug the 8+24 pins, and then short the power on pins with a jumper for an hour or so, or while you sleep.

Yes, if you do not currently have a running CPU that you know works in this board as it is, there’s no way for you to know if you are actually doing any BIOS flashing during your recovery BIOS flash attempts, these boards do not work without compatible CPU in there so flashing may be happening at all until you have working CPU in there first

The problem is that there is no jumper for clear cmos. There is one that is supposed to let you directly enter bios at stock settings to change it. But it is not working at all. That is why I am at a loss.
I ordered a xeon 5540 for 8€.

Anyway bios recovery procedure does work because it is automatic but visible.
I can see on video the progress and it is completes itself.
The same jumper let you do this, with a usb plugged with bios file on it.

So I suspect that the xeon I have could be compatible (or I could not see anything), but settings in the bios are not properly reset, that is why the morherboard is locked by the watchdog, when it restarts in normal jumper position.

It is absurd, I know…


The recovery procedure was successfull and so your suggested hard reset, thank you!
I am still stuck anyway.
The 80H post code is stuck at 2d, no data on this, but I see the initialization leds are blocked to memory.
Maybe mine is not 100% compatible?
Maybe this mobo is extremely picky?
I have not experience with Intel boards.

E5540? If yes, that isn’t ideal and may not be compatible either since it’s a dual CPU processor too, you need some W5 or I7-920, to be 100% sure board is actually OK and that mod BIOS goes in
You’ll check current microcode being used, I’ll change whatever microcode for the CPU you’re using if it differs from 206C2. That CPU may need different updated ucode, it’s 106A5 microcode, which is also already in stock BIOS and updated to 2013 version too.

Are you sure your graphics card is working? Please test it on another system, and then if you can, find some other graphics to test on this system instead of current…
Because >> 2d VGA Bios loaded, initializing display output, display VGA BIOS details, Award BIOS details, CPU type, CPU speed etc (= POST on screen)
Are you sure it’s 2d not 2b? Either one = VGA (2b Invoke vga BIOS), but 2b also = >>

E8 → 01 → b2 → 00 looping
If the board powers un and keeps looping from E8 to 01 to b2 to 00 and back to E8 again, check if the memory is installed properly and try to boot with only 1 stick and try each slot individually. If one of the slots doesnt work, please power off the mainboard and psu and check if any of the pins inside the 1366 CPU socket is bent. If yes then send me a pm or contact the foxconn tech support. If the pins are alright and he memory is plugged in properly, make sure you didnt misconfigure the memory controller and set an unsupported multiplier or an unsupported combination of multipliers. Reset the bios and try again. If it still doesnt work your memory might be damaged or the SPD corrupt, or simply not supported. Please check the BloodRage memory compatibility list and send me a pm if your memory is not on the list and doesnt seem to work.

When the system powers on and the Debug LED shows the usual POST code sequence but hangs on 2b or you get a beep code as soon as the sequence reaches 2b, then the Mainboard cant detect your Videocard properly. Note that the POST code sequence might not halt at 2b but continue, so the final POST Code it displays could be FF, 00 or 7F which means the Maiboard booted, entered BIOS, or OC recovery kicked in and is waiting for Input to enter BIOS. Since the Videocard couldnt be detected properly you will only see a black Monitor and either 2b, FF, 00 or 7F. Check if there is something wrong with the Videocard, the PCIE slot or BUS, the Monitor or monitor cable. Turn the Monitor on and off, switch the Monitor cable from one D-SUB or DVI plug to the other in case your Videocard has two. If this doesnt help then reboot and load the optimized defaults. If that doesnt help either try another Videocard if possible, or try the Videocard in another system to make sure its working properly. Try another monitor or try the Monitor on another System.

When the system detects that a critical error happened during the last boot attempt or several boot attempts failed, so OC recovery kicked in. There should be a message displayed on the Display informing you that OC revocery kicked in and that its waiting for your input to enter BIOS. If you cant see this message cause your Display stays black, please check the description for POST Code 2b.

Your in the BIOS right now, if you cant see the BIOS cause your Display stays black, please check the description for POST Code 2b. If this is part of a loop please check the point “E8 → 01 → b2 → 00 looping” above.

Intel MRC Code
This block of code has to be implemented in every Intel based platform BIOS. It initializes and configures the processor and runs bus training and adusting routines. It adjusts clockskews, read/write leveling, signal termination resistors and several chipset timings dynamically depending on the trace length, signal quality, timing and memory installed in the motherboard. If the MRC code hangs or the board cant pas the MRC code and resets it usually points towards memory problems and unsupported multiplier settings or a unsupported combination of multipliers.

Intel is very strict about chip support - I wouldn’t be surprised if it’s not a microcode issue but just an artificial lock on which processors are compatible.

That may be, I’ve ran into it hard before on the Skulltrail board! ON that, I thought I found the list, but was unable to decipher which set of bytes was which supported CPU and how the string was made so I could put in another, but at least I think I found it

Hello all.
I saw xeon e5540 on the processor support list so it should be ok.
Vga is 100% functional, I used a different one, same outcome.
In any case, the recovery method do work, I see the screen with details on the completion of the procedure so even the e 5645 should be ok.
The code is "2d", no doubt.

I saw different topics on this mobo to be very picky with ram. Today I will try another stick (kingston 1333 2gb), but I do not have an exact match with compatible ram listed.

Here the detailed specs for memory (in Italian but I am sure you will understand)

512mb Singolo lato 1 Gbit 64M x 16/vuoto 4
1 GB Singolo lato 1 Gbit 128M x8/vuoto 8
1 GB Singolo lato 2 Gbit 128M x 16/vuoto 4
2gb Doppia faccia 1 Gbit 128M x 8/128M x 8 16
2gb Singolo lato 2 Gbit 128M x 16/vuoto 8
4gb Doppia faccia 2 Gbit 256M x 8/256M x 8 16
8gb Doppia faccia 4 Gbit 512M x 8/512M x 8 16

Basically double sided sticks x16 ram is not supported… Not many manufacturers specify those data

Good to know it’s on the supported list, I was wondering why you picked that one

VGA functional does not mean VGA is compatible with that board, unless you’ve ran it on there before and know it works OK. Not all GFX Cards work on all boards, that’s why I mentioned to try others, and due to the 80h code you mentioned too.
Yes, if you feel recovery is completing OK, that may be true, but without working CPU and then you check current microcode before a mod, the update BIOS with mod microcode, then recover flash it again, then check and see updated microcode or not, we wont know this method is re-writing the microcode module (It could be skipped over if it sees intact during flash recovery procedure)

Hope you can find some single side stick for test, one will be fine you don’t need a set.

Maybe I was not complete in the description of compatibility of memory.
It appears that the motherboard does not like modules double sided AND x16

it’s a matter of memory organization, very restricted.

I saw Crucial Ballistix Sport 1600 are ok even in 8gb modules (to reach 48gb).

In any case I want to test first and see if it is the issue or not.

Thank you for all your help.

Yes, I understood you I think, that’s why I said maybe you can find some single sided stick, that way you don’t have to worry about double sided density. Be careful picking, not all that appear compatible would always fit those restrictions.
For your example the Crucials, those sometimes are updated without a spec change known to end user, so when marked as compatible may have been single sides, but the set you get might not be (Could be double early on and only x8, or only x8 after x16 were made first, etc)
Then you might not get what you think you order (Hope you get what I mean) That would apply to any model/brand, and if you don’t have in your hand you might not be able to tell for sure until you get them delivered.
Maybe you can borrow a stick from friend or co-worker, that you wont loose $$ on and can check in person before you try, so you can look under heatsink with light and see if double or single sided.

As incredible as it seems, reverting to an older bios solved all problems. Now ALL STICKS OF RAM work without a glitch…
I am speechless.

That’s good! So, what about CPU’s, are those working now too?

I may be a bit late to the party (about 7 months indeed) but anyway specifying what bios version did the trick for you could be helpful for those who are still struggling with this motherboard (as I am doing right now :stuck_out_tongue: ) and give this thread a little more value for the future

Thank you in advance

Hi everyone, I am late this thread but I think the solution I have below will help anyone who is experiencing the same problem with their DX58SO2 Mobo.

Warning, the text is long so the TL:DR version is flash old BIOS, flash latest BIOS and you’re off and running. The long version…

For those who might find this useful - and do copy this to as many forums as you think will find it useful.

Intel motherboard DX58SO2 BIOS 80h ‘2b’ hanging problem - BIOS starts it’s MTRR write sequence (‘2A’) but never exits from it’s write and hangs at ‘2b’. This wouldn’t normally be a problem but none of the normal BIOS reset strategies work. These are:

A) using the Boot to BIOS button
B) moving the BIOS boot jumper to Pins 2 & 3 (by default it’s on pins 1 & 2 for normal operation)
C) removing the CMOS battery
D) removing the CMOS battery and shorting the pins for 24 hours
… or any other strategy that I had yet to come across.

Stalwarts will have reduced their system to a ‘Minimum viable build’ - that being one stick of ram, all cards removed except for a basic graphics card. No front panel connectors (use the Mobo buttons) and removal of all USB devices (except keyboard), removal of alld PCIe cards and all storage devices, including the boot drive - and disconnected all fans (except the CPU fan).

They will have swapped out the graphics card, moved the graphics card slot, swapped the stick of RAM, booted via USB thumb drive to FreeDOS (it still doesn’t). They will have swapped out the processor (Xeon X5660 in my case) and reseated the cooler and swapped out the PSU. This is all great fun and good experience.

At this point you could bin your board and live a better life. You may however like to try this first. Rolling back your BIOS, booting to your OS (Win10 pro in my case), and then reflashing the latest BIOS.

Flashing the BIOS of course requires the iflash version from intel as obviously you don’t have a working OS. The reinstatement of the latest BIOS you could do through the OS but why bother, see next.

You’ll need two USB thumb drives of 1GB or greater - empty. They can be USB3xx but you will be connecting them to the USB2 port on the DX58SO2 Mobo.

Thumb 1 has an old BIOS. In my case version 0776.
The backdated BIOS update that worked for me come from here:
(htp…w. stuff)
(use the mirror server - as of writing the main one is broken - 17/10/21)

Thumb 2 has the latest BIOS. In my case that’s 0920.
The latest (I can find) BIOS update comes from here:
(htp… stuff) followed by
(select the BIOS version that does NOT include the word ‘Express’)

As long as you’ve read this whole diatribe first, you’ll now know that you need to download the Thumb 2 files first. Copy the unzipped files to the Thumb 1 and the Thumb 2 USB drives. There will be three; the iflash2 exe file, the .bio image ( and the licence(?) .itk file (with matching name).

The old BIOS image in my case came as a renamed file with the filename in quotes. Copy this file to Thumb 1. Rename that file removing the quotes and make sure the file extension is set to dot BIO (.bio). Delete the original .bio image file (…0920). Rename the .itk file with the same name as the new (old) BIOS name. I don’t know if this is necessary, but I did it so I’ve documented it here. Did I test it, no.

You should now have three files on both Thumb 1 & 2 drives: the iflash2 exe file, the .bio file, and it’s .itk counterpart.

Now, approach the machine in distress and remove it’s power. Double check you’ve removed the SATA boot drive and you have the ‘Minimum viable system’ configuration. Remove the yellow BIOS jumper completely. Insert Thumb 1 into one of the rear USB2 ports (the backdated BIOS). Connect the power and fire it up. Wait, wait, wait. wait… the 80h display will show ‘BF’ for quite a while but then your screen will eventually flash up with the encouraging lines that the BIOS update is in progress. It will conclude successfully (in my case) after about 4 minutes.

Power off when instructed on the screen and replace the BIOS jumper back to pins 1 & 2 - as instructed on the screen. Remove the USB Thumb 1 drive and connect your SSD boot drive to one of the blue onboard SATA ports. Power up. Your machine should now boot normally albeit on an aged BIOS. Be happy, and then shut it down normally.

Remove the yellow BIOS jumper again. Remove the SATA drive again. Insert Thumb 2 into the same USB 2 port as the original Thumb 1 drive. Power up. Wait, wait &c. The BIOS flash will be successful (in my case). Shut down and restore the yellow jumper as the screen instructs. Connect the boot SATA drive and remove the USB Thumb 2 drive.

Power back up. Your BIOS POST should now resolve as normal and your system will boot to your OS, as normal. Be incredulous that Intel forgot to reset some important BIOS settings on a failed POST runtime.

Walk away. Be happy.

Hope this helps someone.