Need Help Unbricking My Alienware Aurora R5 Bios

Hello all!

A couple weeks ago now I decided to do a fresh install of windows which I have done plenty of times without any problems. This time however I made the mistake of using Dell’s updater program to update all the drivers for my Aurora R5. One of them which I did not realize was the BIOS which I wouldn’t normally flash. Unfortunately, half way through the flashing of the BIOS, my computer decided to reset. It has been in a constant state of black screen ever since.

I have spent the last couple of weeks scouring google and various sites for solutions.
I have followed dells bios recovery methods shown here: [URL=] with no success.
I’ve used the /writeromfile and /writehdrfile method and putting htem onto a formatted usb drive that other posts have mentioned to do with now luck.
I’ve tried many other methods with no luck.

I now have with me a CH341A mini programmer with the cable clip that I was going to try using to flash the bios. However the program requires a .bin file which i can not for the life of me obtain. This is where I need help. I’m not experienced at all using hex editors, I’ve tried a few things but am at a road block.

Does anyone know if it’s possible to get a bin file out of the .EXE file so I can try flashing the chip using the programmer?

I don’t know if any of this will help but for future reference if anyone has the same problem, I’m using an;
Alienware Aurora R5
the motheboard says it’s an IPSKL-SC model?

Any help would be super appreciated! I’m looking at a very big paperweight right now. Haha :frowning:

@Calhoone - .rom and .bin are same thing, however, usually Dell BIOS is not a complete BIOS file that you download. Since you have programmer though this does not matter, if .rom file from your download does not work you can erase and try next.
I checked 1.0.18 for you, and you should be OK, luckily for you this looks like semi-complete or complete .rom BIOS (Missing Intel ME and FD, but that could be the norm for this BIOS depending on chipset/BIOS)
but it should start the system once you write to the board, but read below and proceed only once you’re sure you’re ready.

First thing to do is get a valid, verified backup of the chips current contents. That way you can try to put back in your board details later once you get it running again, service tag, serial, LAN MAC ID.
Here is package of driver + several versions of CH341A software, I’ve had good luck with 1.30 on many BIOS roms. Sometimes you have to pick exact ROM ID, other times you have to pick not exact, all depends on the chip/software.
Keep at it (Read, verify) until you get memory/buffer match chip, then save, and open that file in Hex and make sure it looks like a BIOS and is not all FF (Or upload for someone to verify for you), so then you know it’s OK to write to BIOS.
I would not write to BIOS until you’ve had someone check the file if you are unsure how to do that.