Need help with ch341a and asprogrammer

Hi need to flash my bricked gigabyte Z77 ud5h bios chip using asprogrammer 1.41 I have everything connected and have identified the correct bios chip but get a message saying old sreg and it seems to kinda just get stuck not sure what to do any help would be handy thanks

Can anyone help please

Recovery by 2nd bios chip not possible?
Force recovery bios by power mode trick?
Older software than 1.41 same error?

@Jimmyjoe - yes, if you cannot invoke/force the backup to recover to main, you may need to use programmer.
What is your BIOS Chip ID? Read if off the chip, don’t tell me what any software has gave you as ID because this is not always correct.

Hi thanks for the reply, it’s the mx25l6406e just seems like I’m not able to pick up the chips or there’s a communication error between the programmer and windows 10

Easiest if you’d send a screenshot of the ASprogrammer window when error occurs/ sith error message. Checked settings?


Hi sorry for the delayed reply and it’s not that I get errors just it doesn’t seem to pick up chips on the motherboard, just gives out random numbers and letters for chip id, have tried with battery in out psu plugged in and out still can’t read the chip correctly

Just to add I have tried different versions of software, and have used the ch341a before to flash a socketed bios chip and have used the test clip also is it just not getting a good enough connection?

Try with 1.30 software from this package, be sure you install the “Driver first” driver, in case the one you have installed now is funky for some reason…213094641136166
Correct ID = >> 0xC2 0x20 0x17 (aka 0x2017 also)

If you want to try more with ASProgrammer, hit the “unprotect” icon (not drop out menu, just the button), do that first, then try to ID and read.
Make sure you are working on MAIN and not Backup. Battery should be always installed, but 24+8 pin PSU Cable may need to be removed, or installed, this varies