Need help with PCH Strap configuration change

Been going back and forth with some folks on this one on TweakTown and not making any headway, so hoping maybe one of you knows what to do here.

Working on the GA-X79S-UP5-WIFI in a (probably futile) attempt to undo the massive, massive amount of damage Gigabyte has done to the C606 through incompetence. In order to do this, I need to take the atrocious and criminally negligent F4 BIOS and make changes to various parts. The one that’s giving me fits is the stuff I have to do in the Intel Flash Image Tool. There is no other way to do it, because it’s PCH Soft Strap (with it’s attendant crappy documentation between C606 technical datasheets and FIT.)

The problem is when I attempt to change JUST the elements I need to change and disable everything I don’t - so no PDR, no GbE, no ME, no BIOS - JUST Descriptor Region - it throws error claiming the flash parts specified aren’t big enough to hold the image.
I THOUGHT it was a missing fparts.txt issue, but the VSCC Table lists 7 generic flash devices instead of by manufacturer PN (a la Supermicro and/or anyone with two brain cells to rub together.) So I’m honestly stumped as to what I’m doing wrong here. Even just opening and doing a rebuild with no changes throws the same error. And this is the first time I’ve run into it.

(I can type I swear!)

@ rootwyrm:
Welcome at Win-RAID Forum!

Since I have never tried to modify System BIOS modules, I am sorry not being able to help you.
Nevertheless I hope, that you will get support from somebody else.