[Need Help] XP x86 Install onto Intel Z77 Chipset System

Note: Open the attached .zip file. It’s got links with videos and photos describing my problem, so you can help me :slight_smile:

I have been trying to install Windows xp 32-bit SP3 for 4 days now and I just can’t do it.

I sourced compatible parts from the internet and bought a new power supply and case.

I always get the black screen with the _ underscore flashing on the top left. No prompts, no installation menu.

I have 2 iso copies. 1 is from archive.org, the one with most views. I know someone who is running their WindowsXP from that, so it’s legit.
2 is from a kind user on discord, they have an actual official CD, which they use for WindowsXP and it works for them. They provided me a digital iso and I also used that.

You have to trust me that the .iso is legit, that is for sure.

MY SYSTEM (all compatible):
-Motherboard (atx): ASUS p8z77-v Lx2 (LGA 1155)
-CPU: Intel Ivy Bridge 3770k with stock cooler fan
-GPU: Nvidia GTX 960 - Gigabyte GV-N960OC-2GD
-RAM: 4 x 4gb - G Skill Trident X (DDR3-2400MHz / PC3-19200). On default bios settings, it’s 1600MHz)
-Storage: Samsung 870 EVO SATA III SSD (250gb)
-Optical Drive: DRW-24D5MT (asus)
-Power Supply: EVGA GA 650W, Fully Modular, 80+ Gold rated

I know my system is compatible with Windows XP 32-bit. I also know that I might need SATA Controllers. But believe me, I have tried doing this in IDE mode, with legacy, with UEFI, with switching options between “UEFI” and “Other OS” in Boot section of BIOS and it never worked.

My BIOS is on the latest version… Version 2501 - from 2014/09/19

I have tried doing this many ways.
-I tried creating a bootable USB with Rufus and Easy2Boot with no luck.
-I also tried WinSetupFromUSB following a guide and it did not work for me as well.
-Then, I tried using my internal optical drive, I have tried many, many times to burn the WinXP iso with ImgBurn to CD & DVD, never worked. People on discord even showed me how to properly Write an Image to Disk on ImgBurn, no luck. I even tried burning the DVD at 8x speed.

So… Then, I created a bootable USB for Windows 10 using microsoft’s software from their website. I had BIOS settings set to default. It worked! It let me use Windows 10. Nothing went wrong with it. So, that would mean there is NO hardware failure. The hardware should be all good.

I am suspecting this must be a compatibility issue. But I checked and the people on discord helping me troubleshoot also checked.
This ASUS motherboard is compatible with Windows, as I have checked all my devices’ details before buying them.
The motherboard has drivers and software for Win XP 32-bit on the website, GTX960 is officially the last GPU to support WinXP. Sata III storage should work with WinXP, no problem. Ram is Ram, but it’s DDR3, I checked that. I also tried removing 3 ram sticks and leaving only 1. Same results.

The motherboard is recognising my Optical drive, USB and SSD in the BIOS, but it never boots to the installation media, be it USB or CD/DVD.
Maybe it’s missing SATA controllers. I tried slip streaming drivers in the iso and modified it with NLite for WinXP. Did not work. But then again, I actually included plenty of Intel drivers for AHCI. It was my first time doing it, maybe I did it wrong.

I think all my SATA ports have Intel drivers. Like, 4 are SATA III 3gb, and 2 are SATA III 6gb, I have tried plugging the SSD and the optical to all the ports, all give the same result.
I tried plugging in an External optical drive with USB 2.0… Didn’t work.
Using a USB 2.0 Bootable USB in USB 2.0 port did not work.

Also, I don’t understand tech that much. I understand it as much as I’m showing you. I’m trying. Maybe I did the driver slip streaming wrong, or something else needs to be done.

I offered computer shops money here and they all rejected me. :smiley:

Can anyone help me? I would appreciate your help. Thanks in advance!

Edit by Fernando: Thread title customized and shortened

LINKS.zip (652 Bytes)

Since u want XP x86, never UEFI in bios, now get ventoy on a legacy USB 2.0 and attach u 2 isos, if none doesnt boot u can blame the so called "trust me…"
U only need to provide the F6 SATA drivers for XP on Windows Setup, till there its a regular OS setup boot.
Disconnect additional hard drives during setup.

I will try ventoy. Will USB 2.0 be fine? I have that.

The isos opened on a VM

Thanks :slight_smile:

I just put 3 isos with ventoy on 2.0 USB and it did not boot at all. Just underscore _ showing up on a black screen.

The USB is showing up in BIOS, but it’s doing nothing when I try to boot from it.

After trying again now, it shows Ventoy menu with 3 isos and when I choose one, it says "Press any key to boot from CD._"
If I press a key here, the underscore _ just blinks. If I don’t press a key, it returns to Ventoy menu.

I had
-Sata config. as IDE
-CSM as Legacy
-Secure boot as Other OS (instead of uefi)

Ok, I think this is too complicated. I have even tried an iso that’s got all of the sata drivers and it didn’t work. Maybe my stuff is too new, I’ll just install windows7 on this machine and grab my pentium 4 and run XP on that. I was trying to achieve a high-end XP build. Thanks!



you might be burning your CD incorrectly - how are you burning to CD?

When I install XP I like to use Easy2boot running off a USB drive - you can just put your XP ISO in :_ISO\WINDOWS\XP
no more need to burn a CD


I haven’t tried that yet. I might try it another day. I give up for now :stuck_out_tongue:


ImgBurn (Write Image to Disc) and it worked on a VM and a pentium 4 I have :smiley:

I did put the iso in the easy2boot xp folder like you said. It’s not working with this setup. It’s alright, I’ll use XP on another machine.


I won’t mind helping you if you ever want to try again.

This is an old thread now, but I know there are folks out there building legacy PCs, so here goes…

I recently put together an XP Pro SP3 x86 system by employing a Z68 Sandy Bridge mobo and an Intel Core i3-2105 Sandy Bridge CPU. The OP’s system is a year newer than mine, but I, too, experienced the dreaded “flashing underscore” during the install process, which is what caught my attention here.

In my humble opinion, the warnings about your install CD are not necessarily addressing the issue here. In our case, the issue had to do with the SATA III primary storage SSD we had in our system. I’m certainly no expert, but this problem was resolved by switching the BIOS storage mode to AHCI and slipstreaming the appropriate AHCI drivers into the install CD.

Don’t get me wrong, employing a USB device to do the install is great advice, but that doesn’t mean that your install CD is necessarily defective. Our initial XP Pro SP3 install CD was used several times to load XP onto other HDDs, but getting these older mobos to work with SATA III SSDs can be a challenge.

I hope this helps others who want/need to build legacy PC systems.