Need modded, unlocked and updated ami bios

Hey,

After weeks of. Banging my head against the wall I have given up as I just can’t get things in order, the board is a Maximus X Hero WiFi ac and the latest bios is 1704. I was hoping an expert here could help by here rge physical file up to date with all the oroms, edit module, the various fixes from plutomac, apply any acpi updates, patches or modules etc. if you know what you’re doing this should be able tear through this one. The mother board is a 370, ami bios nd my cpu is a coffe lake 8086k. I will donate via PayPal fairly. I also would like everything unlocked too if possible.

I hope someone can because I put like a month into this and am just done.

Thank you,
J

EDIT by Fernando: The natively present annex “Donation will be provided for the work” has been removed from the thread title.

What is the goal again, it’s not very clear? I get update oroms, rest is not explained properly what you want. What is various fixed? Why would you need ACPI edits?
I assume update Intel ME and update CPU Microcodes? Unlock BIOS, what are you missing that you needed, did you look in AMIBCP vs your current visible settings?
You put a month into trying to mod the BIOS? If yes, please explain in detail what you tried to do, and what you couldn’t figure out.

Hi again,

I am running into trouble really figuring out how to fully unlock the bios, swapping out several of the modules (UBU can work for some but not all) - I want to replace the NVME driver with the version 4 one on the forums, update (as needed) the dxe modules, add in the AHCI 2.0 rom and I know there is talk about about the txe, me, bmc. I also do not know how the SMBIOS is updated or if that’s included. I also do not know how UEFI patch would apply but the board is a Z370 and I have seen so much conflicting stuff out there. I have been working at this now for awhile and I know that if I could put the pieces together it would all flow pretty quickly. However, I am not able to really determine it all. I am have spent a lot of time now and I am just done plus last time I almost bricked the computer. I am willing to pay as I said, for someones time, to snap it together. I just want to be fully up to date and get what I can out of the board. I know the latest EFI modules and ROM’s are on merlin’s site for the RST EFI and OROM, as well as the GOP driver. The CPU is an 8086k, which those microcode files, the latest as far as I know, are in the repository.

Anyway, this is the bios. https://dlcdnets.asus.com/pub/ASUS/mb/LG…C-ASUS-1704.zip

As for my work, I was able to at one point swap out the NVME driver sucessfully and update the rom/efi for the RST controller to 17, the GOP driver to the latest etc. I just am at a wall now in terms of moving beyond this point.

If NVME is in stock BIOS, do not change it out, leave as it, that is best NVME compatibility you can get done by manufacturer. AHCI 2.0? That is not for your type of board at all

I do not know “Merlin’s” Site, but all you mentioned is available here too, the latest RST roms, GOP/vBIOS modules etc.

From my standpoint, the only thing you should possibly update in this BIOS is RST EFI/orom if you want, possibly CPU microcodes, and Intel ME. Nothing else needs updated, nor should be really.
I am willing to help you on something if you are stuck, but it’s still not clear what else you need done, RST can be done by UBU after you place the files into the correct folders, CPU microcodes by UBU
GOP/vBIOS is not necessary at all unless maybe you use onboard graphics without a PCIE graphics card and have some issue that you think vBIOS update might solve.

Hi again,

I appreciate your frank and candid response. I would like to be able to unlock the bios at the end of the day. I can setup and mod the existing bios as per your guidelines, not a problem. I would, however, like to be able to modify options in the bios as well as have full access to what’s there. Right now the amibcp tools do not save whenever I make changes to a file. I do not know if I am doing something wrong or not, but there are settings I would like to change. If you are able to help me with that or unlocking it, I would appreciate it and would compensate you for your time. I will setup an updated bios shortly and post it here. I do not know what it takes to unlock the bios so that I can modify settings with the amibcp tool or am I even using the right too? I thank you in advance.

J

Hi again,

I have attached the latest firmware updated with the various efi, orom and microcodes. I could not update the Intel ME but I do know there is a new version out. I have posted the bios here: http://www.mediafire.com/file/1n18bsjywcwbjs1/M10H.CAP/file

Thank you in advance for any help or guidance.

Johnathon

I can update the ME for you, but lets do that last, and I cab possibly figure out what your doing wrong or correct with AMIBCP (Sometimes changes there have no effect, so it may be normal)

Please zip and attach your latest AMIBCP modified BIOS attempt so I can see how you are changing things. Sometimes, certain sections like “Chipset” may not be possible to enable, in those instances you can either change the default setting in the BIOS via IFR/Hex edit, or via grub using Setup_var
Rest of sections and settings can usually be enabled, often with AMIBCP alone, but not always especially if BIOS is very new (Like this one). Checking out above file now, please upload one of your latest AMIBCP attempts so I can see what you were doing, thanks

*edit - for the BIOS above, it’s messed up in several ways, you are missing probably critical padding files (Due to UEFITool 21.5 most likely, redo from stock BIOS and use 25.0 - if only used UBU, replace UEFIReplace with 25.0 version instead of 25.1)
Drop stock BIOS in UEFITool and you’ll see what I mean, “Non empty pad files will be destroyed” and NE version calls it this way “Non-UEFI Data found in pad file” Those files are located just above the VTF/SEC for the last two BIOS volumes.
And, the FIT table is OK if you only wanted one microcode, but it’s entry count is wrong. Also of note, in case it was not your intention, there is only a single microcode in there, if that is what you wanted OK. If that is how you want it, then FIT Table is OK, but could be corrected for entry count (to 02 instead of 08)

I would not flash the above BIOS, usually those padding files are critical and break the BIOS if missing

*Edit again, Ohh yes, I hate these BIOS in AMIBCP, at least this one’s blank names settings are in English inside there. You cannot modify this BIOS with AMIBCP, must be done via IFR/Hex.
What settings do you need enabled to be visible, please make a list by exact name and I can enable them for you. Yes, I know that will take you a long time, it will take me even longer enabling them one by one in hex, but it’s what you want so lets do it
Also, please include a zip of all the pages of your current BIOS. Mainly first show each section at the root level so I can see what sections are visible by default, then inside any subsections where you may want a setting or a subsection enabled.

—Deleted—

@nonid - please make your own thread, and include the system details, and link to stock BIOS download from manufacturer. Once you do that I will delete the above post, thanks

@johnathonm :
The natively present annex “Donation will be provided for the work” has been removed by me from the thread title.
Reasons:
1. We try to help everyone, no matter whether the user announces or gives a donation later on.
2. The Forum users should not get the impression, that the announcement of a donation may improve the intensity, the speed or the quality of the Forum support.

By the way: According to my own experience not even 50% of those, who had announced a donation, really have sent it after having gotten their successful support.