Need Suggestion about MSI Z77A-GD65 Gaming-BIOS Mod

I buy Intel Pro 7600p NVMe 512gb and use with MSI Z77A-GD65 Gaming Mother Board. I buy pcie to nvme adapter.
Yesterday, I tried to mod bios and flash it. After that main board was not boot, then I switched to another bios so that I can use and re flash the official bios.

I try to find “Free space” but I’m not found. So I insert “NvmExpressDxe_4.ffs” after the last of “DXE driver”. Unlucky the bios was bricked. Now I can recovery already.
Where I can insert “NvmExpressDxe_4.ffs”?


Which BIOS are you using? I will do the mod for you so hopefully it will be OK then

*Edit - @kong - here is latest BIOS (10.11), modified with NVME mod, flash using MSI Built in flasher within the BIOS itself and do not rename the file.
It has stock BIOS name, so remove any current stock BIOS on your USB drive so there’s no confusion over which BIOS is which.…579549035793249 << New Link (Non “Gaming” model)

Can I use this bios to flash?
Thank you very much @Lost_N_BIOS . I will try when I finish my work. After that I will inform you again :slight_smile:

Yes, you can use my BIOS above to flash! Sorry, I didn’t see your image or BIOS link when I replied. Under MFlash is where you put the NVME Module, like you see here


If that is where you put your NVME module before, then maybe newer 25.1 UEFITool causes error, I used 25.0

I flash already it can boot windows. Then I switch to flash another bios with intel me by using mflash, it freeze at 50% and cannot do nothing.

I think one reason is no Intel ME. T T

@kong - Intel ME is included in the BIOS? Do you mean you edited/updated ME, then it wont flash? If yes, then maybe bad modification/update on the ME Mod BIOS.
Do you need me to update ME for you, with the BIOS I posted above?

Stock BIOS (above) has ME -

@Lost_N_BIOS yes, please. Can you please use bios from my link at my post?

Why do that to stock BIOS with no NVME added, instead of BIOS at post #2 with NVME (Stock only + NVME)?
I can, but wonder why you ask for NVME Mod, then don’t want it in subsequent mod BIOS?

I’m not sure that msi z77a-gd65 and z77a-gd65 gaming is the same bios. My mother board is z77a-gd65 gaming (bios version is *.p20)

Ohh! I see now, you have Z77A-GD65 Gaming, sorry about that! Same board ID and major BIOS version, but different builds! So there is the differences! Latest BIOS is 25.2 (P2)

I will edit this BIOS with NVME and latest ME, is that what you need now that the confusion is over

*Edit - here is BIOS you asked for with NVME + Updated ME @kong sorry for the initial confusion on my part there!…892782294065965

With NvmExpressDxe_4.ffs i killed my Z77A-GD80
with the older NvmExpressDxe_2.ffs it was ok

@Fischer - did you verify, it was the NvmExpressDxe_4.ffs module and not your particular BIOS edit that day?
Badly modified BIOS does not kill motherboards, only possibly stops you from using the board until you reprogram the BIOS chip

I’ve tried this above bios and my drive isn’t detected. What should I do?

@Jonathan57344 - I just replied to your PM - You need to follow this guide #4 exactly, at the “This is what you should do” section - [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

@Lost_N_BIOS , is there any chance you might still have that modified (ME+NVMe) BIOS for Z77A-GD65 GAMING? Link no longer reachable…


Lost as been away since January, ill provide a link to his ME/NVMe mod, no responsibility on system failure.

Flash in UEFI only NOT in windows environment.

@MeatWar , thank you! I really do appreciate the help.

NVMe got in there quickly and with no issues. “PCI-e – M.2” adapter and everything working good, bootable, OS loading.
Intel ME didn’t want to get updated at all. Don’t know why. Tried DOS\UEFI, AFUDE238, MSI Forum Flashing Tool, M-Flash and even FWUpdLcl.exe from Intel ME System Tools v8 r3, but only direct flash via FPT resulted in successful ME version update (the only thing that currently it does not pass the tests of “MEManuf.exe” from ME System Tools set). But to hell with it :slight_smile: