New bios and backlight keyboard dont work Asus g751jy

Hi, i have a problem with KB backlight after programming my bios in service (not asus service). I was doing bios update and laptop shut Down when asus ez flash shows erase bios progress, my laptop turn into brick. Find out local service and they do new bios with chip proggraming. After that my backlight keyboard dont work:/ i reinstall ATK etc. And nothing work… here i read this problem can be fixed so i asking for any step by step guide to fix this problem. I dont have any original bios dump made by myself. 
My laptop is g751jy i7-4750hq 980m MB rev. 2.5. 

Sorry for my English.

@Menello123 - This is due to they used partial stock BIOS upgrade to fix your BIOS instead of a full BIOS dump, or improperly rebuild stock BIOS. BIOS repair services always do this crap, lazy or incompetent is the reasons, usually just lazy
Does your Ethernet work (not wireless) still, or is it messed up as well? This company didn’t make a backup and give you before they fixed?

Please download this AFUDOS, and make a backup and send to me so I can inspect
AFU3.exe backup.bin /O

Thx for answer! I dont get any bios dump file from company. Ethernet works, i see that everything works ok instead of Backlight keyboard and when i turn on pc i must wait ~10s then laptop start booting, before Bios repair it was instant. I send you my bios backup on PM.

Good ethernet works still at least! Sounds like ME FW might be messed up if it’s taking a long time to boot.

What BIOS backup did you send in PM? Ohh, I see, one I asked about above, not a previous/old one. I will see if I can find another dump and fix your backlight for you.

In meantime, please check and tell me your ME FW version so we can see if this is anything causing the slow startup -
Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
If you see or N/A, or no ME section in expanded motherboard area of HWINFO64, then ME FW is corrupted or messed up etc. Due to who you had fix this, please also download CPU-z, check in the motherboard tab, and make sure your current BIOS/model is the correct model

I send SCREEN from my hwinfo and cpu-Z, i cant find ME version tab in Hwinfo, or maybe i looking in wrong tab.

Thanks. At least they put the correct BIOS on, I suppose I should have known this or you would have said you couldn’t load/apply graphics drivers

ME FW is messed up or missing, this is why the long delay at bootup. Here’s where it should be showing, at end of motherboard section


This alone, may also be why your backlight is out.
To fix this, due to it being missing or corrupted, you have to either unlock FD via pinmod or purchase a hardware flash programmer and SOIC8 test clip with cable (price is less than $7 shipped for both those items at cheapest price/slowest shipping 3-5 weeks)

Lets see if we can fix the backlight now, then you can order and wait on flash programmer to fix the ME FW. Boot to DOS, with your BIOS backup you made previously
AFU3.exe backup.bin /N /GAN
After that, enter BIOS, load optimal defaults, save and exit/reboot back to BIOS and make any other changes you need. Then boot to windows, see if backlight is now working or not.

If not Reboot back to DOS >> AFU.exe backup.bin /K /GAN
After this, repeat dance above and then check if backlight working yet or not.

If not, reboot back to DOS >> AFU.exe backup.bin /K2 /GAN
Same dance. If by here, backlight is still not coming on, then it’s most likely due to ME FW being corrupted, only way for you to know for sure at this point is to fix the ME FW, then if issue persists I can make you BIOS with someone elses NVRAM area and we can repeat this process

The flashes above with K and K2, may mess up BIOS settings, or BIOS in general, if that happens simply reflash again without K once you are done testing >> AFU3.exe backup.bin /P /B /N /GAN

Another thing that could cause this, is the EC FW is missing or wrong, due to them erasing wrong chip first etc, this you can only check with flash programmer

I tried flash with /N /K and /K2 and nothing :frowning: So i must go for chip programmer. Something like this is OK?


Did you try as I mentioned, exactly? This mainly, by itself, with the tool I sent you >> AFU3.exe backup.bin /N /GAN

As for what you linked, I can’t be sure, there is no description, so I can’t tell what all you get with that listing.
You need CH341A Programmer + SOIC8 test clip with cable, if those two items at least come with it, then yes that will work.

Yes, i write this command in DOS prompt (made by rufus Free-Dos) bios was flashed again and nothing :frowning: maybe because i use my BIOS backup made after this problem but i dont have bios backup made before chip programming :frowning:

Something like this i think will be good right? LINK

Yes, it could be due to the source BIOS we had to use, that’s why I said you need programmer. Once you have that, I can have you backup your full BIOS, copy out details and then put them in someone elses BIOS that does have known tested and fixed backlight and then yours will work too.
And this way, fixing the ME FW will be much easier too. It could be just this causing the backlight to not work, rest could be in the properly, but only way to tell is fix the ME FW first, then check, then if it’s still out we’ll do as I mentioned above.

That is the same link you gave me at post #7, I already replied about that above. If that listing included CH341A Programmer + SOIC8 test clip with cable, if those two items at least come with it, then yes that will work
Ohh, I see now, finally both pages loaded description! Doesn’t help, I can’t understand that language and the images do not always show what you get.

Here is examples at ebay of the only two items you need, unless your BIOS is a 1.8V chip (if your BIOS chip is 1.8V then you also need 1.8V adapter).
To know about that before you order, you will need to remove bottom of case and find the chip and get the ID off it and then I can look it up for you. Best to check this now, so you can order all at once if you need this, some combo kits come with this adapter.