New PC Shutdown after EXCACT 30 minutes(even in BIOS) - Bios update?


Have just received this completly new I7-5650U Mini PC with an unknown/no brand motherboard (Bought on Aliexpress a week ago).

PC works perfectly except for 2 things:
-PC Shuts down(power off) after EXACTLY 30 minutes!?! - See this +

-I cannot wake the workstation from sleep with USB Keyboard/Mouse

The PC comes with an AMI BIOS version 5.6.5 and seeems FULLY unlocked - Have check every setting in the BIOS, but none the relates to causing this issue obviously (Intel Anti-theft is disabled + timer is disabled)

I do have one suspecion though - The PC normally ships with an 5557U processor - But it was sold out, so they send me a 5650U model instead(bad bargain!).

So what can I do from here - I’m no BIOS expert, but is though quite IT experienced - SO thinking it should be possible to flash the BIOS.

What do you suggest that I tryout to resolve the issues - Especially Problem 1?

-Return the PC
-Change specific settings in the BIOS(What?)
-Flash a custom rom or specific parts of the Bios - Microcode etc.

Have uploaded as much info as I possible can extract from the PC (There is no Website, documentation or CD/DVD with this computer!?! - PCB only states GBDW1 VER B.B) - afuwin.rom - Extracted ROM with AFUWIN.exe(AMI BIOS tool)
ReportTXT.txt - AIDA64 Report
UEFI BIOS Updater - Current Status.

Please help and many thanks in advance :slight_smile:


ReportTXT.txt (486 KB)

UEFI BIOS Updater2.jpg (2.21 MB)

This one?
You have fully unlocked flash descriptor on this PC, and they are generous enough to provide a BIOS binary for it. (Binaries are here, yours is in BIOS\5200E-5257E-BIOS-GBDW1108.RAR).
First, you can try to reflash the ME region by using the supplied FPT.exe from DOS, you need to copy all files from GBDW1108 folder in the RAR archive onto DOS-bootable USB drive, boot from it and execute fpt -me -f CGBDW1108.bin command, and then fpt -greset command.
If this won’t help, you need to add proper microcode files for 5650U in this BIOS or even try to flash another BIOS (BDW14302.bin from 5500-BIOS.rar archive), but let’s try first things first.

5200E-5257E-BIOS-GBDW1108.rar (3.38 MB)

5500-BIOS.rar (3.37 MB)

This is the excact model I bought(Ordered 5557U, but they send 5650U): Aliexpress Link

Thanks for quick feedback - Will make a bootable DOS USB drive now.

Any way of reverting to Stock BIOS by reflashing the extracted ROM? - Just considering my options here, if I need to return it to Seller/eglobal



You can make a full backup of your current firmware by issuing fpt -d backup.bin command before any flashing, but as far as I can see, you dumped BIOS has the same version as this update.

Thx - BIOS backed up and I have reflashed.

If I run UBU 1.45 I can see that there is updates to microcode - Think current is revision 1C and UBU can update it to 1Fh.

Could this potentially be a method for getting support for the 5650U processor or is the potential risk of getting bricked big?

Lets see if reflash works…will update thread in hopefully +30 minutes :slight_smile:


Still here 45 minutes later:-)

So seems like the reflash worked - Will give another couple of clean starts and report back with the final results.

Any suggestions regarding the lack of Wake on USB and BIOS? - When I send the PC to S3 it goes out instantly - Not even power lid is blinking(as standard S3 standby) - But when pressing the power button it wakes up instantly.

Thanks for your quick and efficient assistance so far.



There is always a risk of bricking, but you have a full SPI flash image now and can unbrick you board via SPI flash programmer (CH341A-based are dirt cheap now).
I don’t think an update of the microcode will bring you a newer CPU support, but you can add a microcode for 5650U, if there’s none there. We will look at this microcode situation and all of confirming it’s still shutdowns.

Don’t know about S3. Normally, it must be tweaked a bit to work properly, and it appears that they aren’t made any changes from reference BIOS. It will be too hard to debug without having an actual system, so my proposal is to live with it as it is.

Hi again.

After 3-4 runs of more than 30 minutes, I can confirm that re-flashing the BIOS rom(same version) solved my 30 minutes power issue. (thanks CodeRush)

Only thing left is Wake-on-USB, hence I need this to work for my HTPC project.

I can send the PC to S3(STR) - But I can ONLY wake it with the physical power button.

The weird thing is, the power led is not blinking!?!(as it would normally do in S3).

-I have ruled out any driver related or windows 10 related config - Even in Openelec I cannot wake it from sleep.
-Tried both wireless and physical connected USB mouse/keyboard - They have normally worked on other HTPCs I have built.
-Check BIOS for anything related to wake and USB - There is only Wake on RTC, LAN and even WLAN - But No Wake-On USB

-There is a PWRON1 section on the motherboard + a FP1 section 2x4 pins - Have PWRON1 anything to do with it? (See attached picture)
-Is it possible to have a physical limitation in the board that prohibits me from waking it with USB - Or is it entirely BIOS related?
-The BIOS is full of settings to change(But have hard time understanding the meaning of every setting) - Is there any special term/settings used for enabling USB wake?

Hope you can help me out here, thx


GBDW1 Motherboard.jpg

Any ideas what to do next for debugging where the issue lies or how to resolve it?

Have also contacted vendor/seller for a possible solution.


Here is a video showing the problem with Wake-on-usb from Sleep(S3):

Have also tested in OpenELEC - But here is the probolem the other way around!?!?

When using Suspend, the PC power off, but instantly awakens again - No matter what I do(use USB 2 vs 3, unplug) it keeps waking up.

This is so weird…next up Ubuntu…


Sleep issue.jpg

I have the same ‘wake up’ issue with Hystou.…9&product_id=88

There is no any option for wake on usb or wake on keyboard.

I’m going to contact the seller but now long public holidays have been started in China. So I have to wait till middle of February.

@Simulacra :
Welcome at Win-RAID Forum!

Good luck!
Dieter (alias Fernando)

The FP1 is Front Panel Connector…/000005643.html

Did your Mini PC boot up normally after power shut down?
I mean if you press Power buton again did the computer normally start ?
I’ve similar problem but after shut down my Barebone Mini PC (i3-5157U) don’t start (blue light flash once and nothing happend - if I press power button again it’s flash again and still nothing happend).
It boot up after several hours later but never after It shut down (not even If I unplug all cables for ex. 10-30 minutes).
I don’t know it’s motherboard problem or power adapter is faulty.
I’ve also bought my Mini PC in EGLOBAL in this link Aliexpress link

I’ve bricked my bios :frowning:

Can you post here a full backup of bios ? I’ll try to reflash it with my spi programmator


Hi Bugger.

Really sorry for the late reponse - Bugger, did you solve your issue?

Still have wake-on-usb problem, so now using AC Power tate to power on/off the PC - Have plugged TV on power save plug, so that when I power off TV, the PC AC power is cut off.

When powering on TV, AC is back and BIOS starts the PC.

Hystou+Reseller of Mini PC stopped replying to my emails/threads…


@msj33 :

If you want, that the Forum member Bugger Vance gets notified regarding your post, you should better use the "@Bugger Vance " option.

@msj33 , I have just bought the same minipc, and the usb wakeup issue was the first problem I faced also:)

luckily, there is a workaround, the pc will not wake up by mouse or keyboard from S3 sleep, but it will from S1. Granted it will consume a bit more power in S1 state, but i think is still a negligable cost and functionwise it works perfectly this way (I’m using legacy bios mode with Win10, did not try this with UEFI win10 install).
You need to set it up in Advanced\ACPI settings like this:
-Enable Hibernation: Enabled
-ACPI Sleep State: S1 (CPU Stop Clock)
-Lock Legacy resources: Disabled
-S3 Video Repost: Disabled
-ACPI Low Power S0 Idle: Disabled (interestingly if I set this to Enabled I lose all advanced power management options in windows)

I have a few unrelated problems with the minipc, if you have a solution for any of them, please don’t keep it to yourselves:)

1. I cannot install Windows in UEFI mode when the sata controller is set to RAID mode (when set to AHCI it is fine even in UEFI mode, but I use 2 msata ssd-s in RAID0 for boot so I need raid). The windows install sees the raid array but says that it cannot install to this drive. If the bios is set to legacy, win10 installs fine even to raid0. I have tried every possible bios combination for raid with UEFI but nothing worked so gave up.
This is not a big issue though as the pc is booting in just 4-5 seconds even in legacy mode and I use it as a htpc so i dont plan to reboot it too often, just put it in sleep anyways.

2. I had a few BSODs when I set KODI to use MADVR. I suspected overheating maybe, but the CPU and board temps were fine. So maybe it is a RAM issue, I need more investigating. Funny thing is that I have read BSOD issues with this PC from someone which was solved by lowering the RAM CL value in BIOS manually. He was also using two 8GB sticks and on purpuse I bought 2 different brand sticks with lower default CL rating to ensure not to be in the same situation:)
Since I reverted to the default codecs in KODI, I did not have a BSOD, not sure this will stay this way or even connected…

3. My Kingson Msata SSD-s are overheating (to around 70 Celsius) even after a short period of intensive disk use. Probably this causes my write speeds to temporaily drop to around 40MB\sec (from around 300-400MB\s according to CrystalDiskmark) which is very noticable even outside benchmarks. Interestingly my read speeds are only droping to ~400MB\s (from the original ~700MB\s in Raind 0) so read speeds are much less effected. I think this is not a raid controller issue as I experienced the same when I have set it up to use only one drive. Maybe this problem is caused by these kingston SSDs I have, but I’m not sure as i didn’t find anything similar on google. But the rated operating temperature of these ssds are 70 degrees according to the spec sheet so these high temps can’t be good I suspect. I have ordered some chipset heatsinks to try to reduce the temps and see if it will work… will report. unfortunatelly I don’t have other type of ssd-s to try to rule out a controller problem. Do you have similar issues?


2)The model you ordered can support wake up,but must press power buttom,then can wake up,that is our wake up means.but you mean want wake up when you click the keyboard and mouse,this can not support,we are sorry for this

Hi @CodeRush , I have similar problem with this board gbdw1, only the processor is i5 4258u. Tell me please, we’re can I get the flash file for these BIOS to flash it??? Or I can use the same 5500-BIOS.rar??? Thanks