no BIOS menu loading. Please help!!!

Hey guys, I have an ASUS Zenbook13 model: UX333FA that refuses to boot in BIOS menu. When I press F2 it just freezes on the ASUS logo.

Laptop came in as dead and was repaired. On booting, windows loading logo freezes after 3 spins and requires hard reset. On 2nd boot it goes into 'Startup repair". Trying to accessing UEFI settings from there just freezes on ASUS logo when it restarts.

There is no hardware issue and I believe the drive is in legacy mode since when I try with another drive installed as UEFI, windows loads fine and laptop works normally.

Tried reformatting the laptop (data not important) but secure boot is enabled and I get “secure boot violation. invalid signature detected” error. Hitting ‘OK’ just causes the laptop to freeze and requires hard reset.

Grateful if anyone can help. I can’t figure out why the BIOS menu doesn’t show. Please find attached original BIOS dump.

Here is a few things I tried with no luck (am a complete noob to this, feel free to tell me what I did made no sense):
1. Clean ME
2. Disable bootguard
3. Disable bootguard and OEM signing -> this one did not even post

Also requested help on another forum but BIOS files provided did not help. (

W25Q128JVXXQ_zenbook13_Ori.rar (5.15 MB)

Wot was repaired… anything related to SPI reflash/programmed? Answer the question

Put that working UEFI drive that worked ok follow this:…-windows-10-pcs

EDIT: A mod bios or not original for the system does that. Not pointing for ME FW image in bios corruption, for now.

I already tried this link but no luck. When I select "uefi…" setting and restart, it freezes on ASUS logo.

The attached BIOS is the original untouched BIOS as initially dumped from device.

Modded BIOS provided by other forum was:
1. My BIOS was merged with the UX333FA bios update and ME cleaned
2. Completely new BIOS from same model but with cleared ME and my DMI added.

So my EDIT to my post, gave u the answer even before u did right? Good luck.
U know know wots the issue…bad mod.

Answer being “A mod bios or not original for the system does that.”? Am assuming you meant a non-original BIOS can cause the freeze issue and/or No BIOS menu?
If so, yes but:
1. It does not appear that anyone else worked on this board before me, therefore am fairly certain the BIOS dump is the original one.
2. After trying the other provided BIOS files (which did not work), I reverted to the original one and everything was back to the way it initially was. So, I assume there hasn’t been other damages caused.

Not exactly sure what you meant by “Not pointing for ME FW image in bios corruption, for now”. Do you mean a corrupted ME? If so, I doubt this is the case since laptop is working fine with UEFI drive.

Do correct me if you meant something else.

That makes no sense since I am exactly where I started at. That is, with the original unmodified BIOS that came with the device. If any of the other modded BIOS I tried corrupted something, I would not expect the system to be working properly (albeit without the BIOS menu loading) as it was before modifying anything.