No communication me firmare and driver Asus P8Z77-V

Hi there, Ive tried for long and no way flashing new me firmware.

Began with errors 8193, 9458, 9459, mainly communication errors. Tested bios reflashing and clearing cmos but continues the same way

After some readings my conclusion was to use the guide of cleanup intel engine region but finished without being able to build the image, no messages error from fitc, just wont make the image. Should I continue trying get this cleanup? I saw in the spi some asus theft engine activated, changed with fitc but no luck building that xml. Intel (R) ME SMBus MCTP Address was 0x02.

Any help would be apreciated if anyone got to upgrade the p8z77-v mobo, ive been having problems with usbs for long and read this upgrade could fix it, but nothing, no way to get it.

Thanks in advance.

Edit: Forgot to mention that could finish merefl + poweroff, but still cant communicate to flash the new firmware.
Edit2: Could get the outaimage.bin finally, will keep trying this cleanup.
Edit 3: Changed Title

Well Ive finished the cleanup and got flashing the new image, now bios shows the new me firmware updated, but still cant communicate using meinfo, getting 9458 and 9459 errors. Do you know whats the problem when communicating using those others tools?

The simplest thing you can do is take the official BIOS/SPI image, extract the ME region via UEFITool and flash it directly via “fptw -rewrite -me -f me.bin”, provided you have an unlocked Flash Descriptor, which I assume you do, otherwise you wouldn’t be able to fix your system via the CleanUp Guide. You may also be able to reflash the entire SPI chip via the in-BIOS flasher. As for the errors, I don’t know them by hard, you need to mention the actual message too.

Hi, but flashing me region from official ROM will drive me to outdated me firmware, isn’t it? That bios shows me firm version 8.1.2.xxxx and I flashed 8.1.70.xxxx from sticky post getting the me region and modifying the spi.bin changing some values related to Asus antitheft that still was activated.

The problem seems the no communication between driver and firmware. The firm is the last from version 8 from stickied post and the driver is some version 11 windows 10 installed automatically.

Those errors mentioed above are Error 9450: Communication error between application and Intel® ME module (FW Update Client)
Error 9459: Internal error (Could not determine FW features information). Getting those kind of error with meinfo and similar.

Typing from mobile now, if you need any error message from tools I post it after when I come home.


Hi, it doesn’t matter if it’s outdated, first you need to fix the problem. So, flash the ME region via FPT as instructed above, do a “fptw -greset” and after the restart you should be able to communicate with the ME via MEInfo and MEManuf. Then you can worry about updating.

Hi, just extracted the me from official asus bios, and having advise with meanalyzer about size mismatch.

When I go to flash have :

C:\Users\rober\Desktop\IMEST\Flash Programming Tool\Windows64>fptw64 -rewrite -me -f me.bin

Intel (R) Flash Programming Tool. Version:
Copyright (c) 2007 - 2014, Intel Corporation. All rights reserved.

Platform: Intel(R) Z77 Express Chipset
Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —
W25Q64BV ID:0xEF4017 Size: 8192KB (65536Kb)

Warning: The file does not contain enough data to completely fill
the target write area! Continuing will truncate the Write
Length to the File Length!
File: "me.bin"
File Length: 1429504
Write Length: 1560576

Do you want to continue? Y/<N> or q to quit :

EDIT: no problem flashing with new size.

Very appreciated if I should flash even with this warning.


Hi, flashed stock bios me region and -greset and no changes, still no communication.

Intel(R) MEInfo Version:
Copyright(C) 2005 - 2012, Intel Corporation. All rights reserved.

Error 9458: Communication error between application and Intel(R) ME module (FW Update client)

Error 9459: Internal error (Could not determine FW features information)

Any idea?


Install MEI Driver, then ME Firmware.

Hi, mei driver was installed in all tries.

Do you suggest maybe some kind of uninstall, reinstall?

Hello, some update. I have meinfo working just installing the driver fresh and get:

Intel(R) MEInfo Version:
Copyright(C) 2005 - 2012, Intel Corporation. All rights reserved.

Intel(R) ME code versions:

BIOS Version: 2104
MEBx Version: Not available
Gbe Version: 1.3
VendorID: 8086
PCH Version: 4
FW Version:
UNS Version: Not Available
LMS Version:
MEI Driver Version:
Wireless Hardware Version: Not Available
Wireless Driver Version: Not Available

FW Capabilities: 0x01101C40

Intel(R) Capability Licensing Service - PRESENT/ENABLED
Protect Audio Video Path - PRESENT/ENABLED
Intel(R) Dynamic Application Loader - PRESENT/ENABLED

CPU Upgrade State: Not Upgradable
Cryptography Support: Disabled
Last ME reset reason: Global system reset
Local FWUpdate: Enabled
BIOS Config Lock: Enabled
GbE Config Lock: Enabled
Host Read Access to ME: Enabled
Host Write Access to ME: Enabled
SPI Flash ID #1: EF4017
SPI Flash ID VSCC #1: 20052005
SPI Flash BIOS VSCC: 20052005
BIOS boot State: Post Boot
OEM Id: 00000000-0000-0000-0000-000000000000
Capability Licensing Service: Enabled
Capability Licensing Service Status: Permit info not available
OEM Tag: 0x00000000
Localized Language: Unknown
Independent Firmware Recovery: Disabled

But after rebooting meinfo again giving communication errors:

Intel(R) MEInfo Version:
Copyright(C) 2005 - 2012, Intel Corporation. All rights reserved.

Error 9458: Communication error between application and Intel(R) ME module (FW Update client)

Error 9459: Internal error (Could not determine FW features information)

No clue whats happening here.

Well finally solved, was hwinfo interfering with mei communication.

Thanks for the help, great forum.

Ah, that makes sense. Since you followed the cleanup guide, the rest are OS related more often than not. It is known that monitoring tools lock the MEI and do not allow other tools (such as MEInfo & MEManuf) from communicating with the ME. If you had tested the DOS or EFI versions of the tools, that would have been apparent a lot faster.

Yes, I know, in fact was in DOS mode in some test but didnt execute any of these control tools, my fault.

At least all is working now and Ive learned on the way.

Thanks again for your work, regards.