No ME after updating

Hi all.

I have a Gigabyte GA-Q77M-D2H (rev. 1.0) motherboard with ME firmware version 8.1.2.1318.
Update to v8.1.65.1586 (5MB), and after that at least amt quit working.
Flashed original version and after that I have no ME and very strange behaviour. Every time I do a cold boot, it beeps constantly. If reboot, stops beeping and works (more or less).
I have tried flashing bios without success.

Bios says no ME is present

bios.jpg


There is no me device in hardware manager.
Can’t flash in windows nor in dos. In windows says "Error 8193: Intel (R) ME Interface : Cannot locate ME device driver"
In dos

dos.jpg



And MeInfo says Error 9458: Communication error between application and Intel(R) ME module (FW Update client)
Error 9459: Internal error (Could not determine FW features information)

What can I do?

Regards

This "beeping" reminds me of something CodeRush once said regarding Intel "Anti-Theft Technology" which is no longer operational (since 01/2015) and could cause such issue when a newer firmware which has it disabled is applied on top of the ancient you had before (8.0.0.1351 → 8.1.65.1586). Try this, from the latest ME8 System Tools use Flash Programming Tool with the command ftpw -greset . The system should reset. Is the problem solved afterwards?

If the above does not help, use Flash Programming Tool with the command fptw -d SPI.bin . Does it complete successfully or do you see Error 26? If it completes without error 26, attach the file spi.bin to check the ME region. Use .rar or .zip as extension and not .txt, .jpg or else because the file attachments on this forum are problematic.

Thank you for your help.


Reboot but the problem hasn’t resolved


It finished succesfully. Here is the file:

SPI.zip (4.52 MB)

Why did you “update” to firmware 8.0.10.1464? Where did you find the image to update? Even if you tried the latest BIOS from Gigabyte, it has ME 8.1.2.1318 inside. And even if you used the 8.1.65.1586 firmware from the ME thread, it wouldn’t result in 8.0.10 being at your computer currently. Maybe you took the me firmware from another system and used fptw -me command to flash it which is wrong? Since you are able to dump your whole SPI image, the problem can be fixed. But it’s important to know what went wrong first.

I updated because amt stopped working after update.
I used the me.bin you asked me for in the ME Analyzer thread, the one i extracted with FWUpdLcl64 -save ME.bin.
I did FWUpdLcl64 -f ME.bin.
After that, i reflash bios with latest bios from gigabyte (f2) from dos, couldn’t do from windows.
It didn’t work, so I flas bios with F1 version and later with f2 again.

F1 bios has ME version 8.0.0.1351

That still doesn’t explain how 8.0.10 appeared out of nowhere. BIOS F1 has 8.0.0 and F2 has 8.1.2. The me.bin I asked at the MEA thread was version 8.0.0 because I assume you were at F1 bios at the time. Also, using that me.bin with fwupdate means that you basically reflashed the exact same firmware you already had which is not possible without using -allowsv command as well. At some point a 8.0.10 was flashed, that’s for sure. I believe that you updated to 8.1.65 and then encountered this beeping. At this point a fptw -greset was needed but you ended up flashing something else which caused the other errors you are seeing. That 8.0.10 has to come from somewhere.

Now, to fix it. Download the attached file and use Flash Programming Tool with the command fptw64 -rewrite -me -f ME_F2.bin. When it’s completed successfully, use Flash Programming Tool again with the command fptw64 -greset and the system should reset. Be careful with FPT, don’t flash a different file and don’t forget any parameter by accident. Then test MEInfo and MEManuf. Is everything in order? You can then proceed to update to 8.1.65 firmware via FWUpdate with the command fwupdlcl64 -f ME8_5M_Production.bin -forcereset. If you do this properly there is no reason for the ME not to work.

ME_F2.rar (2.43 MB)

I flashed from 8.1.2 (f2) to 8.1.65. Amt didn’t work but no beeping when booting computer.
I could go i to mbex settings but with no effect.
As amt didn’ work, i tried to reset flashing with me.bin (8.1.2). It didn’ work so i tried to flash f2 but could’t do it from windows. I think then started the beeping. But I’ m not sure.
Then flashed f2 from dos. Later f1 and then f2 so I suppose 8.0.1 comes from there.

I’m going to follow your steps.

Well, I did it.

fptw64 -rewrite and fptw64 -greset went well.
MEInfo showed information, MeManuf couldn’t see its output, it rebooted.
I was getting mad with amt not working, just to realize mac address had changed. Change mac in dhcp and working.
fwupdlcl64 -f went well.

With system working, I put nvidia graphics card again and configure. Download drivers and after rebooting, pc rebooted continuosly. After some reboots, a message appeared in screen (FW Status Recovery error) and pc booted.
I see this message every time i boot.

Now, MEInfo says MBEx version is 8.0.0.0066

MEInfo.jpg


There is an option in bios I think can do that also. It is under PCH-FW Configuration, Firmware update configuration, ME FW Image reflash (enabled/disabled). I put it on enabled just in case it prevented from bios flashig on windows (not now, I did it before open thread). Maybe 8.0.0 came from there.

Just in case, here is the actual output od fptw64 -d

SPI2.zip (4.89 MB)



What can I do now? rewrite and greset with your file again?

Regards

The “ME FW Image reflash” option enables/disables either the flash descriptor or the ME itself which indeed is what allows you to reflash it easily. I’m not sure which of the two though. Can you try to set this option to Disabled and try again? At MEInfo I see the state is Pre-Boot which might be related to that option.

If that’s not helpful I think the problem is the options in MEBx. If you know how to set these options again and provision it then you might want to reset the MEBx settings and see if that fixes the issue. I am wondering if flashing the original ME from the latest Gigabyte BIOS (ME_F2.bin via fptw64 etc) will “solve” the problem.


It’s disabled


It was provisioned, i cuold view the http page http://ip:16992 and do login.
I´m going to flash ME_F2 and see what happens.

I flashed it again with ME_F2.bin and it works. I’ve configured AMT and it is working.
Here is MEInfo

MEInfo2.jpg


Now bios post state is post boot
MEBx version is 8.0.0.0066. Is it ok?

I will test the computer with this configuration to see if it works. Later will upgrade ME.

Thank you very much for your help.

I do have newer MEBx, version 8.0.0.0072. I know that at least up until 8.1.20, MEBx 0066 was used and after 8.1.52 we have 0072. I don’t know what MEBx the intermediate releases were using as I haven’t found the relevant packages. Maybe MEBx 0066 is not compatible with the newer ME firmware? Sorry, I don’t know these things because I never had a corporate 5MB system to test MEBx, provisioning etc. We can test if MEBx version is the problem though by updating the ME not to 8.1.65 but to the the last version I know that still used 0066. That version is newer that 8.1.2 so we can try it. Based on the stuff I have, firmware 8.1.20.1336 was still using 0066 MEBx. Try to flash that via FWUpdLcl64 -f ME8_5M_Production.bin command and reboot. If it works just fine (no errors at MEInfo, MEManuf), then we know the problem is the older MEBx version. I have attached ME8 5MB 8.1.20.1336 firmware. Note: I’d like to point out that your motherboard does not seem to have a way to recover from bricks (dual bios or similar) so keep that in mind.

8.1.20.1336_5MB_PRD_RGN.rar (3.42 MB)

I’m going to test if it works now. If it goes ok, I think i’m not going to flash it again, fear of a brick.
Anyway, I’m going to save the file you’ve attached, and in case i flash it, I will tell you the result.
By the way, why has changed mac address?

Maybe MEBx resets some settings (I believe the MAC is set though that, if I remember properly) when the ME is reflashed or changed. I wouldn’t know for certain as I don’t have 5MB experience. Or it could be related to FPT which has a -savemac or similar option to keep the MAC address but to my knowledge/documentation that’s only relevant for GbE reflashing and not ME. So that’s why I never mentioned it.

Hi,

I had a very similar issue to the above with a second hand eBay purchase of the same board. The above posts worked great to fix the issue and recently I also updated to ME 8.1.72.3002 /w MEBx 8.0.0.66 without issue I think.

One core fix post fixing ME was getting hold of the unreleased F3h BIOS (had same ME as F2) for DRAM+EFI fixes if anybody who has this board is interested.

When testing AMT KVM however, the connection now has a green tint, where before it did not on the original F2/F3 ME version. I had not tested AMT KVM for a few months so not actually sure if 8.1.72.3002 created this issue or not. As ME can be temperamental on this board, not really looking to degrade ME to test this one.

It does’t really matter what I had suggested two years ago, a lot have changed since then. Now, I would recommend for you to download the latest SPI/BIOS update from Gigabyte and follow the CleanUp Guide. Then flash the new SPI/BIOS image with the in-BIOS flasher. That way we know that the ME firmware region is healthy and properly configured. So the rest are BIOS-related, including MEBx and its own configuration settings.