Nvidia AHCI for XFX GeForce 8200 (MI-A78S-8209)

Hello there, I was referred to this site by tenforums, guys there were very helpful trying to solve my issue, btw! Anyway, I have a legacy mobo, which I’ve never updated, that has the AHCI option (the other 2 was SATA and RAID). I want to use the AHCI option since I just got a new SSD that was successfully cloned from my old HDD. My system multiboots to XP, Win 8.1 and Win 10. So far, only Win 8.1 is on AHCI mode and working very well. I don’t care about my XP since I don’t really use it, but it is my primary partition. Win 10, for some reason, refuses to boot in AHCI mode. We’ve tried almost everything over at tenforums, manually installing the drivers from the official NVIDIA site, trying out the registry trick and safe mode method, re-installing Win 10, loading the drivers during setup, etc.

One thing to note is when I re-install Win 10 on AHCI mode, it refuses to see my SSD. It’s only when I switch to SATA mode in my BIOS, that the win 10 setup/install can see my SSD so I was able to install it that way. I’m not sure why this works on my Win 8.1 on AHCI mode but not Win 10? Can you help? I also wanted to install Linux mint, which is why I needed it on AHCI mode (which was also unable to see the SSD).

Any help and/or if you can point me to the right direction, is much appreciated!! Thanks in advance!

@bostoncommon : Welcome to the Win-RAID Forum!
To be able to help you I need the HardwareIDs of the on-board NVIDIA nForce SATA resp. SATA AHCI Controller while running Win8.1 and Win10.
Please expand the "IDE ATA/ATAPI Controllers" or "Storage Controllers" section of the Device Manager, do a right-click onto the listed Controller and choose the options "Properties" > "Details" > "Property" > "HardwareIDs".
Furthermore I want to know, which specific driver (manufacturer and version) the SATA Controller is using.
Dieter (alias Fernando)

Hi Fernando, thanks so much for the warm welcome. Unfortunately I made the mistake of updating my BIOS, and I can no longer start my computer. I believe I’ve bricked my mobo, since it just goes on a restart loop and powers off within 2 seconds. I’ll post if I manage to get in, but looks like chances are slim. Thanks again!

Hey @Fernando , it’s a Christmas miracle, but I was able to fix my computer with the jumper pins!! Anyway, back to my original post. Here are the Hardware IDs (I picked everything under IDE ATA/ATAPI controllers, since I don’t know which one, and also included the Storage Controller one.

ATA Channel 0

ATA Channel 1

(Another ATA Channel 0 and 1, but they were the same hardware IDs)

Standard Dual Channel PCI IDE Controller

Standard Dual Channel PCI IDE Controller

Microsoft Storage Spaces Controller

Also, I’m not sure I understand, but I guess it’s using the Microsoft drivers from Windows 10. Not sure if it helps, but I’ve attached my system information screenshot. Thanks in advance!


@bostoncommon :
The HardwareIDs verify, that the on-board NVIDIA nForce SATA Controller is running in IDE mode and not in AHCI mode.
The only driver, which supports the "Standard Dual Channel PCI IDE Controller" is the OS-own MS IDE driver named PCIIDE.SYS.

Oh yes, I did not turn AHCI mode in my bios for win 10, since it did not work, so it’s in ide mode. But my win 8.1 can use AHCI mode if I switch it in the bios. Both systems are installed on the same computer. I can get the hardware id for the sata controller in win 8.1 - but I guess I wanted to find one that will work for win 10. Just wondering why AHCI works on my 8.1 but not on win 10, and they’re both installed on the same computer (multiboot). Was hoping your modded drivers would help for my win 10 so it can AHCI!


Here’s the one for Win 8.1, which I believe is using AHCI

Standard SATA AHCI Controller

@bostoncommon :
It is hard to believe, that the generic Win10/11 in-box MS AHCI driver doesn’t support your on-board nForce SATA AHCI Controller.
Please post a screenshot of the Win10 Device Manager after having expanded the “IDE ATA/ATAPI Controllers” and “Storage Controllers” sections.
Anyway I have modified and digitally signed the latest available 64bit NVIDIA nForce AHCI driver v11.2.20.9 dated 05/18/2012 to make it compatible with all Windows Operating Systems from Win8.1 up. The related driverpack is attached.
Please don’t forget to import the Win-RAID CA Certificate before you start with the installation and to report here about your test result.
Good luck!

64bit Win8-10 nForce SATA AHCI driver v11.2.20.9 mod+signed by Fernando.rar (343 KB)

Hey, thanks @Fernando ! Here’s my device manager’s screenshot:


I’ll try it tomorrow after work and report back. Thanks again!

@bostoncommon :
Thanks for the screenshot, but I wanted to see it while running the SATA Controller in AHCI mode (for example with Win8.1 as OS).

Oh, I’m sorry… for some reason, when running in AHCI mode, win 10 would not boot up at all (I get the boot inaccessible error). Only win 8.1 boots up in AHCI mode. I figured trying this route and installing one of your drivers will work for win 10. I’ll give it a go and import the cert first and manually install the modded driver.

I’ve successfully imported the Certificate. Then I tried to manually install the driver, unfortunately it wouldn’t let me due to a hash file error below:


Well, it was worth a try, but thanks anyway!

@bostoncommon :
You cannot install any AHCI driver while the on-board SATA Controller is running in IDE mode.
Furthermore my attached NVIDIA nForce AHCI driver only supports a Controller and not an ATA Channel.