Nvidia AHCI/RAiD drivers for Acer Aspire M1641

Hi guys, I’ve just joined this forum, so hopefully I’ve posted in the correct section?

I’ve been searching around trying to find AHCI/RAID drivers for an old Acer Aspire M1641 desktop, the board ID is MCP73VE.

At the moment I can only set the PC to IDE mode, so it’s running but a little slow. There is no AHCI option in the BIOS, only IDE/RAID modes. Can I run the OS in AHCI mode if RAID is the only option in the BIOS?

I’m running Windows 7 32-Bit as the Desktop only supports a maximum of 4GB anyway.

I can find the drivers for all other devices off the Acer website, but can’t seem to find those. And I can find RAID drivers for GeForce 7050/610i, but can’t see any mention of a 7050/620i.

Do you need any other info from me?

Any help would be appreciated. Many thanks.

@Sonik :
Welcome to the Win-RAID Forum!

Please post the HardwareIDs of your on-board NVIDIA nForce Serial ATA Controller (maybe listed as "Standard Dual Channel PCI IDE Controller" within the "IDE ATA/ATAPI Controllers" of the Device Manager). You get them by doing a right-click onto the Controller and choosing the options "Properties" > "Details" > "Property" > "HardwareIDs".

Regards
Dieter (alias Fernando)

Hi Fernando, sorry for the delay in getting back to you. I actually had the PC apart as I was replacing some parts in it, so it’s been out of action.

I’ve included a screenshot of the info you require. I hope this helps?

Screenshot_20190616-200211.jpg

Hi Guys, does anyone have anymore info on this? Or is it better to just stick with IDE mode for this PC?

It is pretty old and I don’t use it as my main system. It’s pretty handy using it in IDE mode sometimes, as I use it for running some utilities like WDIDLE3 for changing the HDD parking timer on some WD drives (I’ve never been able to get this to run successfully on newer motherboards).

It came pre-installed with Vista OEM and I’m pretty sure it was running in AHCI or RAID mode then, but after I wiped it and installed Windows 7, I’ve never been able to run it in anything other than IDE mode.

Thanks again for any help.

@Sonik :
There are a few nForce RAID drivers (e.g. v10.6.0.23 and v10.6.0.24), which do support the HardwareIDs of your on-board nForce Serial ATA Controller after the switch to "RAID", but I doubt, that you will realize any performance gain while runnng your system drive in RAID mode. Furthermore you will not be able to boot into Win7 in RAID mode without repairing the boot sector or doing a reinstall of the OS.
If I were you, I would stick with the IDE mode and use the Win7 in-box MS IDE driver.
Big advantage, if you use an SSD: TRIM will work with the MS IDE driver, but not with any nForce SATA IDE or RAID driver.

Hi Fernando! Great, thanks very much. I’ll take your advice and stick with the regular MS IDE driver then. I had no idea that TRIM wouldn’t work with the Nvidia drivers. It does have an older Samsung 840 EVO SSD installed, so it’s nice to have the TRIM functionality activated.

Thanks again! :slight_smile:

Sorry for bringing up an old thread. I had assumed my PC was running the standard IDE controller. But, I ran AS SSD Benchmark and it shows that my PC is still using the nvstor driver and not the IDE driver. I’ve tried to uninstall the Nvidia driver under Storage Controllers in device manager. But when I reboot the PC, the nvstor driver just gets reinstalled again.

My BIOS is also set to IDE mode, and under IDE/ATA Controllers in Device Manager it shows it is using the Standard IDE controller.

I also tried running trim check and it says TRIM is not working, I assume this must be because of the nvstor driver?

Does anyone know how to fully disable the nvstor driver and use only the IDE driver?

Many thanks.

@Sonik :
There is something wrong within your report.
Please post a screenshot of the Device Manager after having expanded the "IDE ATA/ATAPI Controllers" and "Storage Controllers" sections.

Hi Fernando, here are the screenshots you asked for:

Capture1.JPG

Capture2.JPG

@Sonik :
Thanks for the screenshot, which verifies, that there are 2 different Storage Controllers active within your current PC configuration:
1. An IDE Controller of an unknown manufacturer and
2. A NVIDIA nForce Serial and RAID Controller
The questions are now:
a) Which devices (HDD/SSD/CDROM) are connected to which SATA Controller from which manufacturer?
b) Why is the on-board NVIDIA nForce SATA Controller running in "RAID" mode?

Please give me the following information:
1. Which are the HardwareIDs of the listed IDE Controller named "Standard Dual Channel PCI IDE Controller"?
You can get them by doing a right-click onto the Controller and choosing the options "Properties" > "Details" > "Property" > "HardwareIDs".
2. Which options contains the "Advanced" section of your BIOS settings regarding SATA and how are your current settings?

Hi Fernando

The hardware IDs have been previously posted in post #3. (It’s an older thread so they may have been missed). Do you require any other hardware IDs?

The only options for RAID in the BIOS are under Advanced Chipset Features > nvidia RAID Setup:

SATA 1st Master Channel: Disabled
SATA 1st Slave Channel: Disabled
SATA 2nd Master Channel: Disabled
SATA 2nd Slave Channel: Disabled

@Sonik :
Thanks. The manufacturer of the "Standard Dual Channel PCI IDE Controller" is NVIDIA.
There must be an option within the BIOS to set the NVIDIA nForce SATA Controller to IDE or RAID mode.
Which setting do you see now? What happens, when you choose the option "IDE" and store this setting?

There’s an option that says SATA MODE and it’s set to RAID mode, but it’s greyed out and there is no way to change that, it isn’t even selectable. Is it possible ACER has disabled IDE mode on this board/BIOS? The PC is from 2008, so it would seem like a strange decision on an older board.

Weirdly though, if I need to run a utility which requires IDE mode they run fine. So I just thought the BIOS was in IDE mode.
I’ve run wdidle3 on Western Digital drives and it requires the SATA mode to be set to IDE, but that always runs without issues.

@Sonik :
Yes, it seems, that Acer has deleted within the mainboard BIOS the option to set the on-board nForce SATA Controller to "IDE" mode. If this should be the case, I cannot help you.
Question: What happens, when you hit CRTL+I simultaneously while booting? Do you get a splash screen with the NVIDIA nForce RAID Utility and the option to create a RAID array?

Thanks Fernando,
I was going to attach some pics of BIOS screens to see if there is anything can be done, and give you some more info. But, whenever I try to attach any photos from my PC they don’t show up in the preview. They’re all JPGS and all under 1MB, so not sure why they won’t attach.
Think I’m out of luck with the BIOS anyway, still puzzled as to how utilities needing IDE mode work fine?
The CTRL+I option only works if I set “Enabled” under the RAID SATA options for each channel. But then PC can’t boot into Windows, so I have to keep all those set to Disabled. I just assumed that would use the IDE driver and not the nVidia ones. I guess not!