NVIDIA: Optimized nForce Driverpacks for Win7-10

About my post #1332 dated October 29

@vincio_vt : Only the Company Intel (= mainboard manufacturer) or a user with a similar system can analyze the reason for your performance problems.

Unfortunately not. I had to install the driver by safe booting with disabled driver signature.
AFAIK Windows 11 and perhaps latest iterations of Windows 10 now accept known hardware manufacturer certificates only.
I have tried to install Intel AHCI software by the same method but it fails without any error and roll back the installation.

Do you know any mean to disable SATA power saving feature without having to use the app?

@tormento : Which are the HardwareIDs of the on-board Intel SATA Controller?

What has this question to do with the topic of this thread?

Here are the requested download links.
Any feedback from users, who have tried one of these mod+signed drivers, is much appreciated!


Thanks for this update, everything works with the P67 chipset (Asus P8P67 PRO), just like with the previous version :smiley:
Funny thing is that I don’t need these drivers anymore because after two years Intel just posted a solution to the infamous HDD click problem when you have a Samsung HDD and the 13.x-15.x drivers:

Now I can use the newest “normal” IRST drivers



It appears this doesn’t actually do anything with the x79 13.1.0.1058 driver, on startup the disks have the apm set back to 80h
Perhaps it does with RSTe 4.7.0.1098

Hi.
I have Intel 300-series chipset family and Win7 x64.

Device manager display me this HWID:
PCI\VEN_8086&DEV_9DD3&SUBSYS_36FF17AA&REV_30

The Default AHCI 1.0 Controller (Microsoft) is working now and I can’t install IRST.
Win7 x64 and Intel RST Driver v17 is incompatible?

Sorry for my bad english, i’m from Russia :slight_smile:

@biffick Welcome to the Win-RAID Forum!

All original v17 platform Intel RST drivers do support the HardwareIDs of your on-board Intel SATA AHCI Controller. So there was and is no need to use any modded driver.
If you were not able to get the Intel RST driver installed, you obviously have made something wrong.


Regards
Dieter (alias Fernando)

Edit: The v17 platform Intel RST drivers support only modern Windows Operating Systems from Win10 up, but not older ones.

I have Windows 7 installed. Maybe the driver is not installed for this reason?
The installation in the device manager (manual mode).

@biffick Yes, my bad. I missed your hint, that you are running the meanwhile outdated (and not not supported anymore) OS Windows 7.
You are right: The Intel RST drivers from v16 platform up generally do not support Windows 7 (no matter if you try to install an original or a moddded driver).
If you want to replace the Win7 in-the-box generic MS AHCI driver, I recommand to to take the mod+signed Intel RST driver 15.9.8.1050 dated 07/31/2019. It is the last one, which supports your OS Win7 and the HardwareIDs of your on-board Intel SATA AHCI Controller.
Don’t forget to import the Certificate (if not already done) before you start the installation.
Good luck!


Thanks! This driver version is really installed! You are the best :slight_smile:

Hello Win-Raid Forum!

I need some help with the driver integration in Windows 2000.
Ive managed to get XP 64 bit running on my Z87-G43 with Fernandos modded Drivers.

Now I want to dualboot Win2000 because iam really a sucker for it and i wanna use this as one-decade Retromachine and daily it as much as possible (lol)

I fail badly with "iaStor.sys is damaged" all the time (ive tried it 10 times with ProfessionalSP4, Advanced DatacenterSP0 and SP4 and each with different drivers from here, aswell as "unisata" wich ends in an "unisata is damaged"
I have used x32 drivers all the time. Ive tried different versions and also chose different drivers, i think its DEV_C02 or DEV_C03 but however i get the iaStor.sys

Anybody has a clue?

@Dr.VTEC Welcome to the Win-RAID Forum!
The OS Setup message, that a certain storage driver (here: iaStor.sys) is corrupt, is usually caused by a mismatch of the architecture (32/64bit) between the OS and the loaded/inserted driver.
When you want to install a 32bit OS, you have to make sure, that the loaded or inserted driver is a 32bit one as well, and vice versa you should check, whether you have loaded/inserted a 64bit driver, when you want to install a 64bit OS.
Good luck!
Dieter (alias Fernando)

Hi

I’ve tried 32bit 8.9.8.1005
as well as 32bit 11.2.09.1006

It always kills the “iaStor.sys” so i guess iam doing something wrong?
But i have no clue… I use nLite just as before with XP.

Maybe something goes wrong with my iarstor.sys or my windows image isnt compatible?

@Dr.VTEC
For users like you I have written >this< guide.
Please read the start post carefully and follow my advices.
Good luck!

Is it possible to update the package to v18.37.0.1002? Thanks!

@gpvecchi
Yes, it is possible and I have done it.
Please give us your feedback whether it worked for your system (which chipset?) or not.

Yesterday I have updated the start post again by adding the "Generic 64bit Intel RST AHCI+RAID driver v16.8.4.1011 for Win8-11 x64" dated 05/21/2021 and mod+signed by me on 03/02/2022.

Meanwhile I have tested both recently offered mod+signed Intel RST divers v16.8.4.1011 and v18.37.0.1002 with my Intel Z170 chipset system.
Here is the proof, that both drivers worked:
[[File:mod+signed generic Intel AHCI driver v16.8.4.1011.png|none|auto]][[File:mod+signed generic Intel AHCI driver v18.37.0.1002.png|none|auto]]

mod+signed generic Intel AHCI driver v16.8.4.1011.png

mod+signed generic Intel AHCI driver v18.37.0.1002.png

I confirm 18.37.0.1002 modded drivers installed fine on my Z170. Testing them, apparently nor vantages nor disvantages…

It will always kill iaStore.sys with multiple 32bit drivers you offered and different images of 2000.
Ive tried to load "as normal computer" instead of F6 but then it will give a BSOD with bootable device is unaccecable, ive also burned it to CD → same

In general my process of driver integreation is correct, it works on XP ! There has to be an incompatibility while modding 2000… but i have no clue what it is
Ive also used BlackWingCats SATA driver wich interestingly stucks in "setup is starting windows 2000"

Could someone share a 2000 image with working 8 series driver so i can see if my hardware or image kills it? Would be great…

@Dr.VTEC If none of my offered drivers worked for your system, I cannot help you.
Maybe you will find >here< a usable W2k Intel AHCI driver.