NVIDIA: Optimized nForce Driverpacks for Win7-10

@Fernando Thank you so much. I put all drivers i found on internet to xp installation, and drivers signed by you worked.

@Fernando
I am getting crazy to have Universal 64bit Intel RSTe AHCI+RAID drivers v15.9.8.1050 mod+signed by Fernando installed on a Windows 11 x64 system.
I had no problem when I migrated from Windows 10 to 11 and it kept the drivers then, one day, I had the bad idea to remove them.
Now that I want to reinstall them, I have followed the import certificate + have disk procedure but the drivers seems not to be signed from the selection panel and I can’t force to install them.
Any idea?

@tormento :

You should never try to uninstall a storage driver. Please read >this< post.

I uninstalled your modded driver and Windows 11 correctly reverted to the generic Microsoft AHCI driver. I want to install yours back but it keeps on telling me the driver is unsigned and there are problem installing it too and I should contact the manifacturer.

@tormento :
As you surely know all my offered mod+signed drivers have a valid digital signature, but maybe the OS Win11 has forgotten (due to your uninstall action), that the Win-RAID CA signature is trustworthy.
My advice: Re-import the Certificate and re-try the driver installation.

As I wrote on my first post, I imported certificate already. Perhaps either the certificate is not accepted by Windows 11 for some reason or some other mod to the inf are needed.

Do you know somebody who has used your modded drivers under Windows 11?

@tormento :

Yes, me.
I just have tested it with my Intel Z170 chipset system running Win11 version 21H2 (Build 22000.376).
Here is the proof (left pic: driver before the update, right pic: driver after the update):

Generic Win11 in-box MS AHCI driver.png

[[File:mod+signed Intel AHCI driver v15.9.8.1050.png|none|auto]]

Question: Are you sure, that the Certificate has been successfully imported? Did you get a message about it from the OS? Maybe the path to the folder was too long (Solution: Copy the folder named "Certificate" into the root of drive C or D and repeat the import).

mod+signed Intel AHCI driver v15.9.8.1050.png

The certificate is installed but I can’t install drivers.

Certificate Import Success.png

Driver without digital signature.png



Edit by Fernando: Inserted pictures resized and reinserted by using the Forum software (can be enlarged by clicking onto the pictures)

Not even by forcing the installation (pressing the "Have Disk" button and navigating to the file named iaAHCIC.inf)?

Any news?

@vincio_vt :

From whom about what?

About my post #1332 dated October 29

@vincio_vt : Only the Company Intel (= mainboard manufacturer) or a user with a similar system can analyze the reason for your performance problems.

Unfortunately not. I had to install the driver by safe booting with disabled driver signature.
AFAIK Windows 11 and perhaps latest iterations of Windows 10 now accept known hardware manufacturer certificates only.
I have tried to install Intel AHCI software by the same method but it fails without any error and roll back the installation.

Do you know any mean to disable SATA power saving feature without having to use the app?

@tormento : Which are the HardwareIDs of the on-board Intel SATA Controller?

What has this question to do with the topic of this thread?

Here are the requested download links.
Any feedback from users, who have tried one of these mod+signed drivers, is much appreciated!


Thanks for this update, everything works with the P67 chipset (Asus P8P67 PRO), just like with the previous version :smiley:
Funny thing is that I don’t need these drivers anymore because after two years Intel just posted a solution to the infamous HDD click problem when you have a Samsung HDD and the 13.x-15.x drivers:

Now I can use the newest “normal” IRST drivers



It appears this doesn’t actually do anything with the x79 13.1.0.1058 driver, on startup the disks have the apm set back to 80h
Perhaps it does with RSTe 4.7.0.1098

Hi.
I have Intel 300-series chipset family and Win7 x64.

Device manager display me this HWID:
PCI\VEN_8086&DEV_9DD3&SUBSYS_36FF17AA&REV_30

The Default AHCI 1.0 Controller (Microsoft) is working now and I can’t install IRST.
Win7 x64 and Intel RST Driver v17 is incompatible?

Sorry for my bad english, i’m from Russia :slight_smile:

@biffick Welcome to the Win-RAID Forum!

All original v17 platform Intel RST drivers do support the HardwareIDs of your on-board Intel SATA AHCI Controller. So there was and is no need to use any modded driver.
If you were not able to get the Intel RST driver installed, you obviously have made something wrong.


Regards
Dieter (alias Fernando)

Edit: The v17 platform Intel RST drivers support only modern Windows Operating Systems from Win10 up, but not older ones.

I have Windows 7 installed. Maybe the driver is not installed for this reason?
The installation in the device manager (manual mode).

@biffick Yes, my bad. I missed your hint, that you are running the meanwhile outdated (and not not supported anymore) OS Windows 7.
You are right: The Intel RST drivers from v16 platform up generally do not support Windows 7 (no matter if you try to install an original or a moddded driver).
If you want to replace the Win7 in-the-box generic MS AHCI driver, I recommand to to take the mod+signed Intel RST driver 15.9.8.1050 dated 07/31/2019. It is the last one, which supports your OS Win7 and the HardwareIDs of your on-board Intel SATA AHCI Controller.
Don’t forget to import the Certificate (if not already done) before you start the installation.
Good luck!