NVME boot in non-uefi BIOS

Hello

I bought the Samsung NVME M2 950 EVO but I can’t intall windows on it.
I install the SSD with an adapter PCI 2.0 card SILVERSTONE ECM20
Windows boot from usbdrive, the SSD is seeing by the installer, but I can’t choose this drive
Error in french : “vérifier que le controleur de disque est activé” (“check that the disk controller is enabled”)

Fernando says in [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS :
Note: Some NVMe SSDs like Samsung’s 950 Pro SSD are natively bootable in LEGACY mode (CSM and loading of Option ROMs has to be enabled within the BIOS), because their Controller chip contains its own NVMe supporting Option ROM module.

In my case I think option ROM is enabled, but I can’t find CSM in the BIOS utility setup.
I have an old HPZ800 from 2011 or 2012.

I spend a lot of time reading about nvme and old computer, that’s why I bought this NVME M2 Samsung 950.
I thought it was easier than that, could anyone please help me ?

Thanks

@ifunghi :
Welcome to the Win-RAID Forum!

Such NVMe SSD model has never been built by Samsung. Please check the exact model name.
Only the Samsung 950 Pro SSD contains an Option ROM and is bootable without the need of an UEFI BIOS.

Regards
Dieter (alias Fernando)

My mystake : i bought the Samsung V-NAND SSD 950 PRO M.2 NVM Express
Sorry

@ifunghi :
Provided, that your mainboard supports booting off a PCIe connected SSD at all, you should be able to install Win10 onto the NVMe SSD and to boot off it.
Which OS are you going to install?

It could appear strange install this drive on PCI 2.0 but i think it could be useful for me

Filessize I often use are few giga (big images, 3d models, renderings)
Uploading this days to SSD, i would take avantage of this kind of drives instead of sata 2.0 of my HPZ800

It’s not a joke, i took the good one 950 PRO !!

Going to install w10

There is a way to check that ?

I thought doing it by experiment :
-First install w10 on the SSD
-Then check if my mainboard can boot of PCIe
Finally I couldn’t pass the step installing w10

My issue, for now, is I can’t install windows on the samsung ssd 950 PRO M2 :
-I launch the computer
-Windows boot from usbdrive
-the SSD is seeing by the installer
- Problem: I can’t choose this drive
Error in french : (“check that the disk controller is enabled”) "windows ne peut être installer sur ce disque. Le matériel de cet ordinateur peut ne pas prendre en charge le démarrage sur ce disque. Vérifier que le contrôleur de ce disque est activé dans le menu du BIOS de l’ordinateur"

Since few days I tried to « retrograding » of storage controller driver ( 9.6.0.1014 instead of 11.5.4.1001).
According to that, I have tried to install the good one storage controller driver with two different way :
-I install the driver booting on windows with my old HDD, my curent System .
-I also installed the driver during the beginning of windows installation, booting on usbdrive.
On both way same error as before, nothing changes for me (i can’t choose this drive to install windows)

I also tried to download the samsung NVME driver ans install it during windows setup. That doesn’t work.

The drive is formatted in MBR.

Is anyone have some other ideas ?

Nobody have an idea ?

Are trying to launch UEFI/EFI version of Windows installer on Legacy style drive ?
Just FYI : That error shows up, when trying to install Windows in non-bootable environment (Legacy BIOS + EFI Install or UEFI (EFI) boot mode + Legacy installator).

Disconnect stanadard SSD for first part of the installation.
I guess you are trying to install Win7 ?

I don’t know if I’m trying to launch UEFI/EFI version of Windows installer on Legacy style drive.
In fact I didn’t know that there are UEFI or LEGACY version of Windows installer… I will check that.

I couldn’t understand how disconnecting the drive could help to resolve the problem I have choosen the drive to install windows.
However I will try to disconnect the drive in the firts steps and insert it when appear the moment I will have to choose a partition to install windows.

I’m trying with windows 10, I don’t have windows 7

I check my version of windows installer and i can’t figure out if It’s a uefi/efi version

During windows setup, I tried to connect the drive the moment i have to choose the partition but that doesn’t work. The installer doesn’t see at all the drive by this way. I also try to load the driver but no changes, no drive seen

This is a BIOS thing, not windows installer. Your BIOS is not UEFI Type

UEFI booting means Win8 or Win10 selected in BIOS, along with UEFI/ Secure Boot mode and UEFI Type BIOS, instead of legacy/CSM enabled mode in legacy BIOS (Your BIOS). GPT partition usually used with UEFI mode, MBR with legacy.

Have you read this guide? [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS
Specifically note the links in text for older non-UEFI systems



Are you using the latest BIOS for your system, 3.61a from 2018?
https://ftp.hp.com/pub/softpaq/sp84001-84500/sp84159.exe



I know my answer is few months ahead, but the topic might be still up-to date, either for him or s.o. else.

I have a Schenker MYSN (new name “bestware”) S506 Laptop (Clevo N24/N25JU mainboard with skylake chipset)

It allows installing Windows and booting it from an nVME PCIe M.2 SSD, even without Option ROM (e.g. Samsung SM951-NVME without Option ROM), even in Legacy-Mode, and even booting from nVME with MBR formating :)) hehe.
So its firmware doesn’t require UEFI-mode for nVME installing Windows and booting, when the SSD is partitioned in MBR type, so GPT partition layout not required (in legacy mode) to boot via NVME.

If s.o. a developer or mod could need a useful module, here is the link to its BIOS (AMI Aptio V firmware)
I don’t have much knowledge how to do it, in case s.o. might be interested to extract a useful module here’s the link.
https://www.mysn.de/driver/2_SCHENKER/SC…_und_S506/BIOS/
https://www.mysn.de/driver/2_SCHENKER/SC…OS_1.05.14a.zip

Another laptop from a relative Acer E5-775G-37ZB (also Skylake chipset, probably Insyde-firmware) also allows booting from Samsung SM951-NVME M.2 nVME PCIe SSD without option ROM,
but here its firmware only allows to do that in UEFI mode, and because Windows seems to require UEFI-mode combined with GPT partioning style,
with this firmware which does not provide any nVME drivers/option ROM modules in legacy BIOS-mode during the initialization post process, so the SSD has to be formatted with GPT type and firmware switched to UEFI-mode, then installing Windows and booting it works (in that other case than mine above)


@ ifunghi
You said you couldn’t find legacy BIOS mode option in your firmware, your computer was from 2011/2012, it’s probably using UEFI, that you were trying to install and boot WIndows 10 on a MBR-type partitioned M.2 nVME SSD (with option ROM).
In your case with your type of firmware, there might be the possibility you’d have to partition your SSD with GPT format, to allow to install windows and to boot it.

See two different cases with different firmwares (from two different laptop models), see here in this post further above
where nVME booting (even without Option ROM) with MBR in legacy mode works, but with another laptop model (which has other firmware), nVME booting only functions with GPT+UEFI mode.


Does the “Samsung V-NAND SSD 950 PRO M.2 NVM Express”'s option-ROM also provide nVME bootability in legacy-mode, or is it restricted to UEFI? (so if, then GPT+UEFI needed for Windows or GPT+hybrid-MBR), due to Windows limitation

If last version 3.61a from 2018 for his computer is not helping, thy GPT partitioning might ba last option, e.g. with “gdisk” partitioner in a Knoppix Live Linux system, or with diskpart in WIndows PE setup in a cmd ( SHIFT + F10 )

I’m not sure, but afaik the windows installer just allowed to install Windows on nVME drive, when the SSD was (pre)-partioned e.g. with GPT-table, (but not necessary to partition any partitions in behind it, before the Windows installer would do it).
So afaik, but I’m not 100% sure, but as far as I can remember, even I had an (fully empty) M.2 nVME SSD before the Win-installation-process, withoaut even any probably hindering MBR (when it’s computer is UEFI mode), the installer still complained to not to start the installation.

Afaik creating an empty GPT-partition-table before the installation process did the trick, and (and only with one SSD/HDD storage device attached during installation process, (except the Win installer USB flash drive or course), due to Windows limitation!)