NVME SSD not listed nor recognized


I bought first an SSD with SATA interface since according to some staff from Asus it is compatible with my GL752VW. When I bought it and opened my laptop, it is literally written M.2
I bought then an SSD (Crucial CT1000P1SSD8). I made sure it’s compatible (in their website they say that it is : https://www.crucial.com/usa/en/compatibl…52vw#SSDFilters)
Now I put it in my PC and then nothing. It’s not recognized anywhere (Bios, device manager, while trying a new windows install).
I checked if the SSD is inserted correctly, updated the BIOS (latest version is 303).

On the official manual they say “The M.2 2280 slot supports either PCIe (NVMe) SSD or SATA SSD”. So since I can’t put the SATA SSD in the motherboard, the NVME should be compatible.
I tried some advices by disabling CSM and Secure boot. I also tried enabling and every possible combination.

My Bios is not UEFI, is this the issue ? It’s weird since Asus and Crucial say it should work.

I’m out of ideas, do you have any suggestion please.

Thanks in advance for your kind help.

@Rurush :
Welcome to the Win-RAID Forum!
Since your problem has nothing to do with the Sub-Forum "BIOS Modding", I have moved it into the "Solid State Drives" Sub-Forum.

Only the manual of your notebook or the ASUS Technical Support can tell you, whether the related M.2 port of your specific notebook supports the NVMe protocol or not. If not, you cannot get any NVMe SSD working with the on-board M.2 port.
By the way: Since your ASUS ROG GL752VW has an Intel 100-Series chipset, its BIOS is an UEFI one.

Good luck!
Dieter (alias Fernando)

Thanks for your answer Dieter.

Actually the manual says that it is compatible, but it’s still not recognized : https://asus-rog-gl752vw.rogdoc.com/en/c…ng-an-m-2-card/
Thanks for the info, I tought since the interface of the Bios is old it’s not UEFI.

I contacted Crucial support and told me to unplug and plug again the SSD for 20 minutes and leave the BIOS open then unplug and plug again to see if it’s recognized. I’ll try that since I have no ideas left to test.

@Rurush :
Your linked AsusRog page says: “The M.2 2280 slot supports either PCIe (NVMe) SSD or SATA SSD.” That means, that it doesn’t support them both and you cannot be sure, that the M.2 slot of your specific notebook really supports the NVMe protocol.

Thanks for your time.

Is it possible even when I opened my laptop to put the card it’s literally a slot that is for this kind of SSD ? https://i.imgur.com/JePCuBS.png
The slot available contains only 1 slit and two. So I can’t put this kind of SSD on my laptop https://i.imgur.com/JzNM0xq.png

Unless I’m wrong somewhere.

@Rurush :
I am not able to answer your questions.
You have 2 options to find it out:
a) Borrow an M.2 SSD, which supports the SATA AHCI protocol, and connect it to the on-board M.2 port. If it should work, you can be sure, that an NVMe SSD will not work at the same location.
b) Ask the ASUS ROG Technical Support.

Some systems take both.

Hi there, the thing is that Asus doesn’t even reply to this kind of topics with clear answer.
From what I know there are basically 2 types of M.2 either Sata or NVME and according to the slot it’s NVME since it has only one cut.
Now I did notice something on an amazon listing as shown here

I’m very confused about all of this. At this point I’m just waiting to buy a new laptop and I’ll just avoid Asus. But I also want to understand why it’s not working while the SSD is working perfectly.

Also, can a Sata SSD (with 2 cuts) work on NVME slot if one of the cuts is aligned with the slot ?