NVMe SSDs detected by BIOS, Linux... but not Windows 10

Hello all,

I’m building a new configuration with the Gigabyte Aorus TRX40 Xtreme (latest BIOS version) motherboard. I have tested different NVMe SSDs M.2 / U.2 (through adapter for U.2). I can see them in the BIOS and in Ubuntu… but not in Windows 10 (LTSC 2019). They don’t even appear in the Device Manger. I’ve tried different options in the BIOS without any success.

Any help appreciated.

Thank you.

For me there are only 2 possible explanations:
a) The SSD isn’t correctly connected to the mainboard.
b) The PCIe lanes of the SSD connection are blocked by another device.
Please post a screenshot of the Device Manager after having expanded the “Disks” section.

Thanks for your reply. The SSD is correctly connected to the mainboard since I can boot on Linux, format it, copy, erase, etc.

Here is the screenshot of the Device Manager. You’ll only see the SATA drives anyway, no the NVMe:

Is it a single NVMe disk or is it a RAID?
Did you configure NVME Raid mode in bios?
What’s shown in the ‘storage controllers’ section of device manager?

No RAID, single NVMe. If i enable RAID for NVMe in the BIOS, there’s still no detection.

Here is the Device Manager again:

I can even mount it on an old Windows 7 machine. That’s crazy… I keep searching without any clue.

Either it’s dependant on your hardware/ motherboard or your Windows LTSC version (It’s 1809 I guess?). One way would be to try to boot from an Windows 10 1909 CD/ USB- stick. If this version shows you the NVMe SSD…

What’s the output of “sc query stornvme”?
Do you have stornvme.inf in %windows%\inf?
Do you have stornvme.sys in %windows%\sstem32\drivers?

Interesting!

The service is stopped. Strange… And the INF exists in these paths:
C:\Windows\System32\DriverStore\FileRepository\stornvme.inf_amd64_4091a2d5e7b639a1
C:\Windows\System32\DriverStore\fr-FR
C:\Windows\System32\DriverStore\FileRepository\stornvme.inf_amd64_4e56d37488727768

I tried to launch it with "sc start stornvme". Result: "Refused access".

EDIT1: I could run the service using the admin mode. Now, I have "State : 4 running". But still nothing in the Device Manager :\
EDIT2: I can find C:\Windows\System32\drivers\stornvme.sys

In the registry:



EDIT3 : I changed “Start”=dword:00000000" to “Start”=dword:00000001". No change.

EDIT4: I downloaded and installed this driver: https://www.samsung.com/semiconductor/mi…download/tools/ … now one of the two SSD is recognized (the 970 EVO). But still not the PM1733. Can’t find any driver for that one.

There’s not too much logic in this. Only thing I can think og is that another (possibly RAID) driver recognized abd ‘occupied’ the discs…Is there an AMD Raid utility that could show connected but unconfigured disks?

Normally Windows should show devices it doesn’t know the driver for. But it doesn’t show anything, what would mean that another device/ another driver uses this device. The Samsung driver possibly get’s loaded first? Could you stop this AMD RAID bottom device? (Don’'t if it’s your boot device!)

lfb6, you are a genious!!! I had to delete the AMD RAID driver. And then, the SSD has been discovered by Windows.

Thank you so much! I’ve spent like 10 hours at searching.