[OFFER] ASRock Z97E-ITX/ac MOD

Hi, this is my ASRock Z97E-ITX/ac BIOS mod, it was made using the lastest 2.20 version downloaded from the ASRock Site.

I have this board and have problems trying to boot from this SSD TOSHIBA RC100 NVMe SSD.
AFAIK this is the only SSD in this form factor (M.2 2242) with NVMe PCI 3.0 x2 interface.
I tried other SSD disks with M.2 SATA interface and they worked fine without any mod, but this one was not able to be detected by the UEFI firmware even with the Win10 already installed in UEFI mode taken apart from other computer in which it worked fine.

So, I decided to investigate and came to this forum. I modded my BIOS according to these guides and everything worked fine with the RC100

UEFI Modules where updated using UBU_v1_70_rc10_2 following this guide, the Intel CPU Microcode were updated using the MMTool method.
[Tool Guide+News] “UEFI BIOS Updater” (UBU)

NVMe support was added using this guide using the the NvmExpressDxe_4.ffs module following this guide
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

And the ME firmware was updated following this guide
[Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization

So this is the log

1 - Disk Controller
EFI IRST RAID for SATA - 13.5.0.2164
OROM IRST RAID for SATA - 13.5.0.2164
2 - Video OnBoard
EFI GOP Driver HSW-BDW - 5.5.1034
OROM VBIOS HSW-BDW - 1038
3 - Network
EFI Intel PRO/1000 UNDI - 6.6.04
OROM Intel Boot Agent GE - 1.5.62
4 - ME Firmware - 9.1.37.1002


CPU MicroCode
±----------------------------------------------------------------+
¦ Intel ¦
¦-----------------------------------------------------------------¦
¦#¦CPUID¦Platform ID¦Revision¦ Date ¦Type¦ Size ¦ Offset ¦Last¦
¦-±----±----------±-------±---------±—±-----±-------±—¦
¦1¦40671¦ 22 (1,5) ¦ 1E ¦2018-04-03¦PRD ¦0x3400¦0x737438¦Yes ¦
¦-±----±----------±-------±---------±—±-----±-------±—¦
¦2¦306C3¦ 32 (1,4,5)¦ 25 ¦2018-04-02¦PRD ¦0x5C00¦0x73A838¦Yes ¦
¦-±----±----------±-------±---------±—±-----±-------±—¦
¦3¦306C2¦ 32 (1,4,5)¦FFFF0006¦2012-10-17¦PRE ¦0x5800¦0x740438¦Yes ¦
¦-±----±----------±-------±---------±—±-----±-------±—¦
¦4¦306C1¦ 32 (1,4,5)¦FFFF0014¦2012-07-25¦PRE ¦0x6000¦0x745C38¦Yes ¦
±----------------------------------------------------------------+

Z9ITXA.rar (5.38 MB)

Thank you.
Would you consider modding BIOS 2.20A (with TPM support) as well:
http://forum.asrock.com/forum_posts.asp?TID=6627

@pnkiller78

@nilezon - if you only need NVME module mod, I can do for you if pnkiller78 doesn’t reply.
Or you can do yourself, it’s very easy and we have good guide to do the mod here - [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS



Thank you. I actually already did add NVME my self, but I have not yet tried flashing it.
I could probably update the other modules as well, but I figured maybe @pnkiller78 already has the environment set up, with the drivers, microcode etc downloaded and ready to inject/replace quite easily.

A bit off topic: the 2.20A bios with TPM support boots extremely slow (60+ secs of black screen before first bios message). Does anyone know if this can be fixed without ASRock’s help?

Do you use the TPM? If not, disable it, that may speed up the startup delay. I will check BIOS for you tonight, and see if maybe there is some other delay set as well.
Is Intel ME Firmware OK/healthy currently? Can you see ME FW version in the BIOS, or with HWInfo64 in the large window, on left side, expand motherboard then go into ME and check ME FW Version.
In either of those places, does it show valid ME version or only N/A or 0.0.0.0?



I was hoping to use TPM, yes. I just installed a brand new TPM module.
I will check ME firmware status/version and report back. I’m not at home atm.

It’s OK, I was only considering maybe that was part of the delay at startup. I have not used TPM, so was unsure if maybe it could be causing this. You could test by disable real quick, reboot and see if same or not.
If ME is corrupted that could cause delays, and boot failure too.

I see. Well, ME seemed to be working (reported a version number inside BIOS).
I decided to use the PC without TPM for now. Maybe ASRock will release a TPM enabled BIOS without the start up bug some time.

Did it start faster now with TPM disabled? If yes, was the TPM configured and working when it was slowing the startup down? If yes, maybe that is normal to see with TPM use, it does have to decrypt things and that takes time.

Now I’m using a bios (2.20, from this thread) without the TPM functionality. It is starting fast.
It seems, from the ASRock forum thread (http://forum.asrock.com/forum_posts.asp?TID=6627), as the 2.10 BIOS with TPM started fast, but the 2.20A BIOS with TPM is slow.
Probably something wrong with the 2.20 version only.
I was trying to find the 2.10 bios with TPM support, but the link is dead.

Well you can always use that 2.10 w/ TPM while you wait for next update too, if you need the TPM functionality. I agree, sounds like something they broke in 2.20A since 2.10 is fine with TPM
Send a PM to Emily for 2.10E link again, she is nice, she’ll post new link for you once she has time to read your message.

Are 2.10e and 2.20a available somewhere?

Links on asrock forums are expired/not available

Thanks


Edit: found this on asrock forums, hope it helps for future (or at least until available)