[OFFER] Asus Crosshair V Formula 1703 mod BIOS

I would hate to have a SSD and not even be able to boot on it so… I will try to mod the BIOS so it can support it as soon as i get the time to do it. Probably in the comming week-end or the next…

I updated both BIOS version on the first post to support bootable SSD over PCIE. I use the BIOS myself and it is working fine but because i don’t have a SSD over PCIE, i can’t test if that new functionnality is working as expected. Please report back the results after you try it.

Just flashed the Bios and everything is working great. Used the version with Cool & Quite Issues, because I dont use that anyway. Booting works fine, finally can use my SSD without using USB Boot first. I also tried to increase my OC and it seems that the new Bios is Stable at higher clock then before(Still testing). Had the 1703 from 2012 (non modded) before. Thanks alot.

BIOS updated to v5.


[Changed] OROM LAN Intel Boot Agent GE v1.5.83 -----> v1.5.84

I just found this post with your modded ROM’s. Im amazed anyone is still working on them but i am totally excited. I installed your rom and it has helped over the 1203 that i originallly had. My only request is if you can add a lower minimum and maximum degree on the optional CPU fan settings. it wont go any lower than 25c or 60c on the max and min sides. My issue is i purchased a server fan for occasions that i want to bench the computer but the internal temperature never reaches 60c even though the CPU does.

I also would like the PCIE support to install an NVRAM SSD. I was going to do that this christmas but i guess ill hold off if it doesnt work at the moment.



Unfortunately, i don’t know how to change the internal code for those temperature settings in the BIOS. Also, i don’t know if this apply to your situation but those optional fan settings are controlled by the readings of optional thermal sensor cables, one 2 pin sensor cable for each optional fan settings. If you don’t have those sensor cables installed, then any temp settings that you set there are not used at all because they don’t read the CPU temp or anything at all, they use only the temp of the thermal sensor cable associated with it if the cable is installed and the temp at the exact spot where you installed the sensor of the cable. Up to 3 optional 2 pin thermal sensor cables can be installed on the Crosshair Formula and they didn’t come with the motherboard, they are optional and must be bought separately. If you need more infos on this, look at the #6 of the diagram in the motherboard manual.

As for SSD over PCIe support, it should work without any problem with my BIOS because i already added the 2 rom modules to support it (See first post: [Added]). If you take a look from post #19 to #23, you can see that it was tested and successfully used to boot directly from a SSD over PCIe.

Great Info, i have the box in the attic, i will pull it and install the sensors. As for the PCIE SSE, thats awesome! I will buy a drive on the next discount i find and install it.

so the computer runs great with your bios but for some reason it has been failing to post. I lowered my overclock to stock settings and it will still fail to post. If i force it into safe mode it runs just fine (in safe mode post ) but if i make any changes to the processor it has a chance of not posting. Depending on the aggressive nature of the overclock depends on how hard it is to post. Once its up…it doesnt crash, it passes prim95 for over an hour. Im not sure whats wrong. It is an older power supply that might be the issue but i thought i would ask here first. Also, i attemted to go back to the original 1703 and it said the file is incorrect. A little help? :slight_smile:

Thought i would add my details i am runnin amd phenom II x 4 965 at 280FSB x 14.5 = 4.073Ghz, memory running at 1866 (this motherboard max) and HT / NB 2000mhz (i have been able to run it at 2200 2500 and even 2800 and it runs)


I don’t have a phenomII x4 to overclock so i can’t say if anything is wrong with your numbers or not, but i will assume those are normal for overclocking that. Even then, i can say you are righ about the memory at 1866mhz and can confirm to you that i run my memory at that same number without any problems.

With that said, you didn’t said what is your power supply but i suspect it may be the power supply that is at fault because i don’t have any problems with my Bios and other users seems to be fine with it too.

Maybe one of your settings in the bios is causing this instability at startup. I guess it is not impossible. Review them all carefully one by one. If it is not the cause then you probably come back to your power supply…

I usually recommend at least a 1200 watts power supply for a modern PC. The reason is that a power supply always works at its best at half power. So a 1200 watts would have more stable current at an average usage of 600 watts. It is also always more efficient at half power too, so it consume and cost less to operate in the long run. The quality of the power supply also matter because the cheap ones provides a current that fluctuates too much and is not stable at all by modern standards. That last fact can pass undetected for a long time on a PC on normal operations (and can kill the PC in the long run) but when overclocking comes into play, this default often come to haunt a PC very fast. It comes even faster into view when a power supply reach its upper end of its capacity instead of half of it like it is supposed to be.

My advices: First, the quantity: Verify to be sure your PC is using around half of its power supply capacity in watts. 2/3 can pass but 3/4 is usually way too much depending on the levels of high peaks in watts you do with your PC. And second, the quality: Make a research on the net about your power supply to be sure it has good capacitors in it and that it has a good regulation system to control and correct the current fluctuations. If not, the current your PC receive may not be of a good enough quality or stability to overclock too much. Also, even if it had respectable capacitors in it, if the power supply is too old, the capacitors may be getting old too and not be able to run as efficiently as they used to be. The same apply to the regulator system. A last comment on this is that some old power supply had no real current regulator mechanism in them, this means that any electricity fluctuation comming from the electricity company was almost completely passed on directly into the PC… It is harder to get a high stable overclock in those conditions.

As a last resort, you can also try to test your power supply with the free “OCCT” software that you can download at “ocbase dot com” but I AM WARNING YOU: This program can usually test the max of a power supply, or at least the max your PC can draw from it if it is less than the power supply capacity, and this test is very well known to be able to kill PERMANENTLY any power supply of a bad quality or even a good one with a default in it. DON’T DO THIS TEST IF you still need to keep your power supply and/or can’t replace it right away. Even if a power supply survive this test, it doesn’t automatically mean that the power supply is perfect. If i remember right, you can look for unusual spikes in the current graphics produced by the software to pin point clues that the current is not stable.

Hope this can help you.

Your response is well documented, i applaud you. For starters, i am running a 600w psu. It is quite an old Antec psu. I dropped the memory down to 1666 and it posts more often, 50/50 chance it will post after leaving it off overnight (i just reset and it will post). I calculated the wattage of my connected items to be as follows:
Phenom II x4 965 120w
Asus Nvidia 1060 120w
SSD Maybe 4w?
Gskill 8g (4x2) Dunno?
Crosshair Not sure what a motherboard uses in wattage

so on a safe side 300? i have a few fans lets say 350 on a 600? Im going to talk to my neighbor, hes an electrician and see if he has one of those power measuring devices.

edit: the beep codes actually equate to the video card not posting. If that helps. Otherwise ill post when i measure load when it turns on and so forth.

Thanks again.

Hello all,
Thanks for the wonderfull work you did on this mod bios, i got a huge boost on Windows boot time with my SSD Samsung 850 EVO. i am still wondering how Asus couldn’t have seen this. Now the weird part is that my Crosshair V Formula boots faster than my Crosshair V Formula-Z which is also running the mod bios from this forum (but this is another story).
Anyway, i am coming back to you because i do have a small problem with the latest mod bios with the AGESA version I wanted to use that version because i prefer to keep cool&quiet activated for some obvious reason of power saving when the computer is in idle mode. With that bios version, no way to change any of the settings around voltage and frequencies. I used to overclock my AMD FX 8320 to 4.7Ghz (the same frequency as my FX 9590 running on the Crosshair V Formula-Z the other computer), but with that mod bios, no chance to get any changes at all, everything is always running in stock mode, even the memory frequency is completely unchanged no matter which settings you choose. The only frequency which is still working is the FSB, voltage doesn’t apply at all.
Could you have a look why is this happening ? I was about to use the batch file to upload the AGESA into the bios running the version which is applying correctly frequencies and voltage to get back the cool&quiet feature, but not sure if this is safe, never did any mod bios before ?
Thanks for the help.


Sorry for the late response. I got some reports lately of this and i decided to revert it back to the original v1.5.0.0 which seems to be the only version where everything is working as it should. I updated the first post with the details and the new download link.

BIOS updated to v6.


[Changed] - AMD AGESA OrochiPI v1.5.0.0 -----> AMD AGESA OrochiPI v1.5.0.7 (or v1.5.0.2)

@Phoenix48 Hello, thanks for your amazing job that u did with the bios mod. I need some help, i got a Phenom X6 1100t running with a Asus Crosshair V Formula, with the v6 ruinning with the Agesa v1.5.0.0 basically dont change the clocks on it. I dont know if it is any known issue, or something related only with the Phenom and Athlon. On 1703 the OC was pretty good, stable at 4.2ghz + 3000mhz on the NB, but really slow boot speed. Rn im in with the reverse problem.


I’ve unfortunately had no luck getting my cpu or memory clocks to apply with the current bios mod (v6), although voltages seem to be applying. CnQ is working again though! I’m not sure if anyone else is having the same issues.

I’ve had to revert back to v5 without CnQ working, but I’d really love to have that feature. At any rate, thanks for all of the work you’ve done on this mod!


I see @Graphitero seems to be having the same issue as well.

I can apply overclocking using AI Suite II, but it doesn’t stick after a reboot, and I of course can’t change some important settings through that, either.


After many tests and being out of solutions and clues other that it must be related somehow to the AGESA version, i decided to rebuilt the Bios mod from scratch to see if it makes any difference because i was not able understand why simply replacing a newer version of the AGESA by the old original one would cause this, or, to say it differently, would not correct the problem. So i suspected that somehow, that i can’t comprehend even now, that a newer version of the AGESA must somehow modify some other part of the Bios permanently so reverting back to an older version like the original one would not correct the problem. The only way to test my theory was to rebuild it from scratch from the original Bios with the old AGESA version ( and, that way, be sure that it never had any newer version in it.

The result is that the CPU overclock is now working (i tested it myself successfully).

BIOS updated to v7.


[Fixed] - CPU overclock not working due to some unknown remaining persistent modifications in the Bios from newer AGESA version.

I’ve been running the custom bios for quite a bit at this point and I have to say it works wonders for the most part.

I run the
"CrosshairV-Formula-ASUS-1703.ROM with AMD AGESA OrochiPI v1.5.0.7 mod v5 (2017-06-11)"

and tried the

"CrosshairV-Formula-ASUS-1703.ROM with AMD AGESA OrochiPI v1.5.0.0 mod v6 (2017-12-10)"

before you updated it to the v7 version. Just wanted to add to the v6 discussion real quick because I had to revert to the v5 due to crashing (would crash about 3 minutes into a game of league of legends, randomly crash a few hours after general run time). Just want to add with the v5 version I’m currently running, it spits out a random system memory value to Radeon settings. I tested this when I tried the v6 bios and it showed the correct amount. I run 16GB of DDR3 and when I’m running the v5 bios it shows some ridiculous number like “2422641 GB”. It’s random as well and no where close to any of the other memory types I have running on my machine. My storage space is close to 1.5TB, Ram is 16GB and GPU is 8GB.

Anyhow just figured I’d put that here to let you know about it. Thanks for all the work on it by the way, it has increased performance on my machine quite a bit and given me time before I need to actually upgrade to my next platform.

I updated my bios but now i dont know if it is only with me but corsair link doesnt work at this moded bios, someone could help me with that?

Hi Phoenix.

Can you please advise on how I can flash back the original firmware for Asmedia? The updater fails to flash it back. The backup pulled 3 FW files.

I’m seeing some issues and would like to test.

It created DE0_0253.BIN, DE1_0253.BIN and DE2_0253.BIN

Thank you.

was able to flash back. chopped off from 64kb.

noticed some things:
-I cant seem to invoke F12 to select a boot device on the fly.

Can you please confirm this on your side?



Contrary to almost all other motherboard that uses F12, the Crosshair Formula use F8 to select an other disk. There was no mod on that, it was like that even in the original bios. And yes i can confirm that F8 works.