[OFFER] ASUS CrossHair V Formula Z MOD bios 2201



It’s confirmed, this Bios works with other brands of M.2 SSDs. I’d recommend to use this Bios instead the others, and this MOBO will recognize every M.2 drive you install in it, if not, let me know and I’d fix your boot problem with the specific drive.

Thank you!!

Very nice speed consistency!

Ptriot Hellfire Speed Consistency.PNG



Good bechmarks Sentinel, this Patriot drive is on par with Samsung drives ( around 1430 MB/s writte, 1520 MB/s read). I would like Yeemaster3 to put his Intel drive benchmarks too, so we’ll have a better performance chart between Samsung, Patriot, and Intel drives using this MOBO.

Thank you!!

Well, here am i…I just got my new 960 Pro and tested with an Angelbird Wings PX1 adapter on my CHVF-Z with modded bios #2 from 1st port.

Everything went ok with my UEFI Win10 installation, very fast boot, although 4K numbers are not as expected. As a secondary drive with my previous Win7 installation from a 840 Pro, i got 54-170MB/s R/W , while as an OS drive i got 36-110MB/s R/W :

960 Pro 512GB on 990FX ASUS Crosshair FV-Z Phenom 1090T 4G - Angelbird Wings PX1 - crop.png



I don’t know what is to blame, on my laptop which is also PCI-e v2.0, i get 4K numbers close to 50-160MB/s with my 950 Pro as an OS drive (Win7 UEFI)


I may try later for a Win7 UEFI installation on the 960 Pro, to see what is going on.


Thank you Stickmode for your excellent work!

Finally Felix, welcome to this forum. I was waiting for you, because you were the first to start asking for this M.2 feature on this MOBO two years ago in the ASUS forums, and now you GOT it. I created this Bios to extend the life of this cycle-end board until the AMD RYZEN platform comes, adding features like this and if the user wants add a USB 3.1 add-on PCIe like the ASROCK USB 3.1 A+C card, to enjoy next generation tech only available on INTEL mobos. The Samsung 960 PRO and 960 EVO are the fastest on the line, off course due PCIe 2.0 limitations on this Mobo, they can’t reach their full potential. I’d recommend installing the Bios in post #17, the Samsung NVMe drivers, and disable Write-Caching only for benchmarks, also follow the guide: NVMe performance on INTEL platforms that applies to AMD too here: [Discussion] Performance of the Samsung M.2 SSDs (AHCI/NVMe) in this forum.

Greetings!!



Thank you for your time and effort on this BIOS. As for the BIOS in post #17, i will try in the weekend.

As for write caching disabled, do you mean setting #1 or #2 in the following picture ?


Write Caching.png




EDIT :

I tried to boost performance by running a Spi32M on a single core, while running AS-SSD (old tactics for investigating ssd performance on laptops ), when i came upon an idea…

The difference of OS and non-OS performance is also that the AS-SSD is ran in different OS’s…so i thought “why don’t i try one thread only?”…and…Ta-Daaaaa!!! :



Affinity 1 - Buffer Flushing Off.png




And after enabling "Write-Cache Buffer windows flushing off", it got a bit better with 4K-QD1 writes :


Affinity 1 - Buffer Flushing On.png




That’s much better for an OS drive and such an old AMD system.


That’s all for now.


I will also try with a Windows 7 UEFI installation on the 960 Pro, along with the modBIOS from Post #17.

Good test Felix, I wish you find the best performance of your 960 pro, this will benefit everyone that wants to take the max advantage this MOBO offers with M.2 drives. I’d recommend to install the Samsung NVME drives during the WIN7 installation, so the OS recognizes your drive without issues. I have a pair of 480 SSDs, and I’ll try to install them in RAID0 configuration with the NVME 951 drive as a boot drive to improve the performance of my system, in the future I’ll offer a RAID guide of this config, and tell you how it goes.

Good luck!!




As i was afraid…the culprit was Windows 10…i cloned my Windows 7 UEFI x64 installation from my laptop’s 950 Pro (it’s an intel laptop…lol) and i got the correct numbers…

It seems that in Windows 10 the combo 990FX-Phenom II 1090T that i have is not used properly, who knows, maybe inefficient drivers.

The same erratic behavior is also seen while benching my 850 EVO or 840 Pro. Doesn’t matter which driver, 4K-QD1 is almost 40% down (28-33/73-84 when in Win7 is 40-43/108-114 MB/s R/W).

It is not just a benchmark thing, it affects the feeling of usage, using the pc seems sluggish, not snappy as it is in Windows 7.

I also used the BIOS from post #17, but results remained the same.


I hope my findings are useful to someone.


Will edit tomorrow this post to add a proper 960 Pro AS-SSD screenshot as an OS drive Win7 UEFI x64 in my Crosshair Z (maybe tweak this to 4400-4500MHz to see it maxed out)


Again, thank you Stickmode, your effort making this BIOS is much appreciated! And also thank you Fernando for creating this valuable forum that hosts so much information and bright minds !


EDIT: So here it is

960 Pro 512GB on 990FX ASUS Crosshair FV-Z Phenom 1090T 4.2G - Angelbird Wings PX1 - Win7x64UEFIClone.png



As you can see, the Win10 numbers were way below the capabilities…

Hello everyone! First off, I would like to say thanks for taking your time and effort to mod the bios for the C5FZ motherboard to allow for M.2 NVMe SSDs.

I purchased a 512GB Western Digital Black M.2 drive, a PCI-E to NVMe adapter, and a riser cable so I could continue to use my video cards in crossfire while still using the lowest PCI-E slot on the board (PCI-E 4x I believe) without changing the 2nd video card to 8x. I connected everything, flashed the latest bios on the 2nd page of this thread (reply #17) using Flashback, and I still cannot seem to get the drive to appear.

I originally wanted to use it as a drive to store games only, and use my SATA SSD to boot windows. However, when I realised that I could not find the drive in Windows, even using Disk Management, I tried disabling SATA and installing Windows 10 onto the drive directly, and I followed Stickmode’s directions provided. The only thing I did differently is, I did not use RUFUS to create the windows 10 USB drive (I used the Windows 10 tool to do it - I don’t have a Windows 10 iso file to use with RUFUS). I was still able to boot to USB with UEFI ONLY mode set for everything. When I get the option to choose which drive to install onto there are none in the list. I have seen the drive in the bios as PATA SS, but when I disable SATA to install from the USB drive I no longer see it. I was just wondering if this bios works for WD drives as well, or if I am missing something/doing something wrong…

Any help would be greatly appreciated!!

Thanks again :slight_smile:

,Dean 07

Scratch that. Turns out my riser cable is DOA, or when i put my video card in place it broke a solder joint. I placed the drive into my PCI-E 8x slot, and it works just fine :). I am even able to use it as a game drive as i had intended!! Thanks again for the modded bios. I am very happy with the drive. and my 2nd video card still performs just the same from what I can tell while playing ESO. :slight_smile:

Crystaldisk WD.png

Hmmm the samsung evo 960 pro 1tb does not work unfortunately: /Have all steps obeyed but it is not displayed in the bios. In windows it is there …Please help
Gesendet von meinem Windows 10 Phone

@jowk :
Welcome at Win-RAID Forum!
A drive is only shown in Windows, if the BIOS has detected the drive. So the fact, that the NVMe SSD is present while running Windows, is the proof, that it has been correctly detected by the BIOS (although the drive is not listed there).

This happens with all older systems, whose BIOS does not natively fully support NVMe, but this has no negative impact on the function and performance of the NVMe SSD.
There is no doubt: Your Samsung 960 EVO works!

Regards
Dieter (alias Fernando)

So I am already sitting all night and the 960 unfortunately is not yet booted.Why is the 960 evo pro in the mod bios not displayed?

Your problem has nothing to do with the topic of this thread, but much to do with >this< one.
If you have any further questions regarding how to get your Samsung 960 NVMe SSD booting, you should post them into >this< thread.
The first step is to open the modded BIOS, which you got from Stickmode, and to check by using the UEFITool, which NVMe module has been inserted by the thread starter Stickmode. Is it named “NvmeExpressDxE” or “NvmExpressDxE” (without “e” after “Nvm”)? It should be the latter, because the other one is older and may not fully support your Smsung 960 NVMe SSD.
If it is named “NvmExpressDxE”, your further procedure is much easier: Look into the start post of the linked thread and continue with point 6 of the section “This is what you should do”.
If it should be “NvmeExpressDxE”, I recommend to remove the already inserted NVMe module and to replace it by the newer one by following my guide from scratch.

Because the NVMe support has not been natively implemented into the stock BIOS by your mainboard manufacturer.
By the way: A Samsung 960 evo pro SSD doesn’t exist. It is either a 960 EVO or a 960 PRO.

Thanks very helpfull!

I found a big flaw in the BIOS of my CROSSHAIR V FORMULA and, because the FORMULA Z is almost the same, i got curious and looked into your BIOS to see if the flaw was also there. And yes, it is also there.

ASUS didn’t put the AMD AHCI ROM v3.3.2.0 for DEV_4391 (or any other version) that is supposed to be there. The module is simply missing. Only the RAID modules are there (DEV_4392 and DEV_4393). It is probably always running on legacy driver. As a result, anyone using their system in AHCI mode have their SATA controller not working properly without knowing it. Some people even reported a noticeable startup time into Windows that can be improved by up to 13 seconds faster when the missing module is added.

So i added the missing AHCI module with the other RAID modules in the CSMCORE and took the opportunity to also upgrade the following while i was working on it:

OROM Intel Boot Agent GE - 1.5.81 -----> OROM LAN Intel BootAgent GE 1.5.83

EFI Intel PRO/1000 UNDI - 7.3.20 -----> EFI LAN Intel PRO/1000 UNDI v7.4.25

You can test it by downloading it here

Hope this is usefull.

ASUS is so god damn xxxx shitty when i comes to their BIOSes. I really hate them for this situation.

EDIT by Fernando: The f-word has been deleted. I don’t want to see such words within my Forum.

This was a lifesaver. I followed the USB FAT32 instructions and didn’t even know about the flashback feature of my motherboard. First tests were not any faster than my OCZ Vertex4. Second tests were faster, but still not as fast as I thought they would be. Moving from a 468GB boot disk to a 1T faster Boot disk is worth it by itself, having the Samsung card that I can just pop out and put into the next motherboard I buy is also a great reason.

Here are my current numbers.

https://drive.google.com/a/bolcer.org/fi…ew?usp=drivesdk

@gbolcer :
Welcome at Win-RAID Forum and thanks for your feedback!
Regards
Dieter (alias Fernando)



Thanks Phoenix48,with your help this MOBO starts faster!!. I’ll offer an update soon with the latest AMD microcodes and modules.


Greetings!!