[OFFER] Asus ROG Zenith Extreme BIOS/UEFI_v2601 mod ROM see post #98

Here is the updated mods to the ASUS ROG Zenith Extreme v2001 BIOS/UEFI as follows:

Detect mode:


EFI ROM updates:


Microcode updates:

Via UBU Tool as set out in the following page:

[Tool Guide+News] "UEFI BIOS Updater" (UBU)

To update follow the method set out in the ANNEX section

[Guide] How to flash a modded AMI UEFI BIOS

Enjoy a solid Threadripper build

NOTE: Latest update BIOS UEFI version 2201 found in post # 50 of this thread


ZE_MOD.rar (5.08 MB)

strong text

Anyone tried this out?


Yes, myself the original poster of said BIOS/UEFI…

As you can see from the HWINFO screenshot, it boots no problem into Windoze 10…



Hello there. On my Zenith motherboard (1920x cpu), I use a Samsung 970 Pro disk (with Kyro M.2 adapter, and on the x4 slot). Likewise, I have 2 Crucial P1 1TB nvme disks that I want to use with the Kyro m.2 adapter. However, the system does not recognize the Kyro M.2 adapter in pcie x16 slots numbered 2, 3 and 4. So I can’t see the discs. I wonder if we can solve this problem with this bios we mentioned? Thanks.


I’ve RAID0 with 2 x Samsung 970 Pro 1TB drives; but I used the DIMM.2 extension card with 2 x M key slots.

With the above setup the RAID0 setup was a breeze and the drive was even recognized every time I did an experimental bios flash after entering my preferred settings.

I’ve also got the ASUS Hyper M.2 X16 PCIe 3.0 X4 Expansion Card V2 Supports 4 NVMe, but I haven’t populated with a full complement of M.2 drives yet.

Naturally the above M.2 expansion card and DIMM.2 carrier have both been validated for the motherboard.

On the other hand I remember reading the manual that PCIe slot 4 has a setting in the bios to convert U.2 to M.2 via an adapter. So you may have to read up on the precise bios/uefi settings for PCIe slot 4.

Right now I’m redoing the water cooling loop on this beast and of course my packages were all delayed in the latest weather calamity in the US. So I will have some downtime waiting for all my gear to get back up and running.

The DIMM.2 extension card comes with the motherboard while the ASUS Hyper M.2 X16 PCIe 3.0 X4 Expansion Card V2 is a separate purchase. I’d give the DIMM.2 card a try and see if that alleviates your immediate problem.



Hello again. I tried to mean that I don’t want to use the DIMM.2 board that comes with the motherboard. Yes, we can setup easily with this card.

However; the subject I am looking for an answer to; Aquacomputer production is related to why KRYOM.2 nvme adapter does not work on secondary, tertiary pcie x16 or x8 slot on x399 platform and whether this problem can be solved with the bios given here.

You may not have the answer to this question, but I hope to find the solution somewhere :slight_smile: Thanks…


Given that your Samsung 970 Pro works with the Aquacomputer Kyro M.2 NVMe adapter, we should then safely assume that neither the Samsung SSD nor the Kyro M.2 adapter are your problem areas.

I took the time to look up your Crucial P1 NVMe SSDs and indeed you may have an issue there, as below: ie lack of a proper Implemented NGUID and EUI64 NVMe Identifiers would certainly give rise to the behaviour you are experiencing.

It appears that your particular SSD has a firmware update dated: Crucial P1 SSD support February 01, 2020

Optimized behavior in Link Power Management.
Improved background garbage collection methodology
Improved thermal management
Implemented NGUID and EUI64 NVMe Identifiers.

Methodology on updating firmware is here:



It may well be that the NVMe identifier you have currently needs updating…which may well be the issue you are experiencing.

Try that first and see if it resolves your particular issue.




The correct settings for M.2 adapters in the PCIe slots can be found on page 3-16 of your manual:

"Use PCIe RAID mode when installing Hyper M.2 x 16 card or other M.2 adapters. Installing other devices when using PCIe RAID Mode may cause your PC to fail to boot up"

Thus PCIe RAID Mode is only to be exclusively used with M.2 adapters.

Did you change the relevant PCIe slot settings to PCIe RAID Mode as you iterated through each slot testing the Kyro M.2 adapter and reboot each time?

If not that may be the issue you are describing…

Hi again. Thank you very much for your relevance.

First of all, I can’t see the February 2020 update on the website. I can see on the web page; P3CR013, which is already installed.
Regarding Raid; my problem is not not being able to raid, when I insert the disks into the second, third and fourth pcie x16 slots with the kryom.2 adapter, the system does not see the disks. :slight_smile:

Edit : Soon I will try to plug the adapter into one of the pcie x16 slots and run it again by showing it as x4 on the bios.


The setting = PCIe RAID Mode is a requirement in the BIOS/UEFI to achieve M.2 NVMe functionality whether you use the drives in a RAID setting or not.

If you don’t set the PCIe slot in which you’ve placed the M.2 adapter to PCIe RAID Mode in the BIOS/UEFI you will NEVER see the drives.

ie the setting is a precondition for ALL M.2 adapters…



It can happen. If we install both disks and configure them as raid, we can get results as you said. But; I will only be able to do this after 2 days.

* I plug the P1 disk into the x4 slot with Kryom.2 adapter , its working . Pcie x16 slots can only be configured as x16 or raid. This may be one of the answers to our question. Because; I will use the discs as a raid anyway.

Thanks again for your attention. After 2 days, I will try to raid the disks. Then I will write the developments.

Hello again @hancor .

I could not solve the problem I mentioned above. Because; The steps in the “how to” section you link to are too many and my English is not enough, I didn’t want to tamper with anything without being sure.
I would appreciate it if you could explain with a few articles (and understandable sentences of course) how to install the mentioned bios software. It’s okay if you don’t have time. Thanks.


First question: What is your current bios version?

Any chance of being skilled enough to unlock / implement Resizeable bar? Asus seems to not be interested in supporting x399 anymore, unlike MSI an asrock



Support for additional titles will launch alongside our VBIOS and Game Ready Driver update for the rest of the GeForce RTX 30 Series family late March.

We’ll see about Resizable Bar support sometime late March…
As it is my EKWB (waterblock) for the EVGA RTX 3090 FTW3 Ultra is due to be shipped sometime around March 19th.
In the meantime, some other parts finally made it through the latest US snowstorm.

Having said that with 24GB of GDDR6X memory I don’t even know whether the feature will be needed, as some game titles are already smooth as glass.

It appears EVGA and NVidia are onboard for resizable bar and it depends on what CPU hooks are required.

Having said that, my plan is to update bios with latest CPU microcodes in UEFI so we’ll see how far that goes…

Best response to date would be to wait and watch as the VBIOS and NVIDIA driver updates roll out in the latter part of the month.

In the meantime, I’ll be flushing the water cooling loop…so I kind of limping along until the rest of the parts show up.

Edit: Further it looks like the 400/500 series AMD motherboards are first to use resizable bar. The distinction here is that the garden variety consumer boards have about 16 PCIe 4.0 lanes while the X399 workstation type motherboards have upwards of 64 PCIe 3.0 lanes. As per AMD:


There are 64 lanes of PCI Express® Gen 3 connectivity in the AMD Ryzen™ Threadripper™ CPU. 4x lanes are reserved for communication with the AMD X399 chipset. Up to seven PCIe® devices may be connected to the system (not to exceed 60 lanes); additional concurrent devices may be supported with a PCIe® clkgen on the port or device.

It would appear Resizable Bar is more directed at the gamer centric boards rather than the full blown workstation boards which already have plenty of PCIe connectivity lanes.


2001 now.

wrong message , sorry.

Friend of mine has the asrock x399 taichi with the beta bios that enables resizeable bar, and has a 6800 xt , and can confirm that it does in fact offer an improvements in some games, he has been seeing 3-10% improvement from not having resizeable bar. So asrock enabled it no problem, jus wonder what is needed to bake it into our bios…


Okay I put in a formal request to ASUS to enable the AMD feature Smart Access Memory (SAM) for the X399 and TRX40 chipset lineup.
They gave me a case number and will get back to me in a number of days or so.

I used a link to the MSI X399 Taichi beta bios (ie competitors are already enabling support) and the NVidia announcement:


and my argument was basically that this is an industry wide effort with AMD’s Smart Access Memory, and Intel chiming in:


and given the X399 and TRX40 chipset are premium chipsets this shouldn’t be too big an ask.

We’ll see where it goes…

Edit: Ok, got word today my request for BIOS/UEFI on the AMD version of Smart Access Memory feature got escalated to the level 2 technical support folks at Asus.