[OFFER] Asus ROG Zenith Extreme BIOS/UEFI_v2601 mod ROM see post #98

Hey Hans, thx for getting back.

I plan on staying Win10 but that shouldnt have a bearing on my BIOS settings, as for RAM I am running 2 sets of CMT32GX4M4C3200C16, one set is version 3.51 which was stable up past 3400Mhz but after adding the 2nd set, v4.52, is when i started having RAM\OC problems, i may have to just really dial it in is all after finishing my loop (temp loop atm til Distro Plate gets in) hoping reseating CPU helps like ive read some have had, i also have 10 120mm fans in my o11dXL (6 blowing on board) but still plan on grabbing that additional chip cooler you suggested, ty. I may update my CPU to the 2950x as they are pretty “cheap” nowadays but im not trying to go any further than that, anymore and i might as well just update the enite PC, which i dont want to do or need honestly.

As far as the modded BIOS you created this correct? I havent read the entire thread, but seems to be a good thing for the Zenith Extreme, as far as the Asus stock Win11 BIOS update you think that would help at all with my config or should i just go straight to your modded BIOS? im looking for stability with my OC’n, which wont be crazy and more for fun cuz honestly i doubt ill ever utilize “all this” as I only game on it anyway, lol. As of right now everything on my system has been great up until i added the additional 4 sticks to populate all 8 DIMMs, so that would be the main reason for updating the bios. Also to make sure, its been so long since doing any of this bro, my current Win10 install should be good to go after updating and configruing RAID0 settings right? Important specs as follows:

Zenith Extreme
8x8gb Corsair Dominator Plat.
2xSN850 @ RAID0 on DIMM.2

I know some of this may seem newb af, my bad man, just been a few years and need to “get back into it” lol.


Okay I think I see your problem…mixing memory module sets ie seating v3.51 and v4.52 in the same motherboard even though they may be the same manufacturer, is always a big no, no…for earlier AMD CPUs. You want above all to run MATCHED memory sets when populating all 8 slots.

You’ll note that I bought IDENTICAL memory kits…

As a test I would run each of the sets as 4 modules independently, to verify you don’t have any bad ram memory sticks. Also run memtest to verify you don’t have any suspect ram modules.

Then OC memory modules to see how each set behaves independently.

There are likely subtle internal timings that make them not want to play nice with each other.

Also, when you expand from 32GB to 64GB of ram your timings will naturally slow because you are populating all 8 slots.

For instance, if I take out 4 of my matched ram modules I can easily achieve 3200MT/s CL 14 timings by simply inputting the DOCP profile, expanding to 64GB of ram and it tops out at 3200MT/s CL 16 timings, but the DOCP profile won’t load and you are onto manual timings and voltages.

eg CL 16-15-15-15-36 tRC 75 and voltage on DRAM set to 1.40-1.41 for my ram modules.

You can also try toggling Gear Down Enabled/Disabled and Command Rate 1T or 2T to find the most stable configuration.

The modded file at post #50 is the most up to date BIOS/UEFI and is easy to flash, if you FOLLOW THE DIRECTIONS TO THE LETTER!

I had a RAID0 set up for the OS, and after flash it recognized the RAID array once I re-entered the correct settings. But I would still make a back up, unless you like risking to learn the hard way. :slight_smile:

Hey Hans, i was wondering if the different versions had some play on the situation, seems it is …doh’! So debating on the faster 32gb vs the slower 64gb for gaming/browsing purposes, but i never actually even come close to utilizing all of the 32gb, but cant stand the look of empty sockets so gona run some tests to see if i gain/lose anything between the configs til i can get matched sets, which is low priority cuz its like buying a 3rd set of 32gb for “no reson” …lol.

also thx for the headsup on the BIOS, and ya i already learned the hardway, lol, I always run a backup of everything now. Still debating on the modded BIOS but it sounds like its all Pros and zero cons, im hoping itll fix a problem im having with fluctuating vcore that i just noticed as well, ranging from .45-1.85v …when i have 1920x CPU underclocked 3.8ghz @ 1.375v (still building up my custom loop, waiting on last piece, the distro plate) few screens to show an hour of idle history via Hardware Monitor …literally popped it up, walked away, came back an hour or so later and saw it hit 1.85v+ at one point and almost shit a brick …any idea why it would do that when i have vcore set manually, auto oc settings to off, and all my “tweakers paradise” settings (i think its those, Ill include screen of that as well, and i dont run AI-Suite auto, only manual when i need to check or test, all settings are BIOS level) to max\extreme\manual to keep voltage\performance as steady\stable as possible cuz my thermals are so good? (and will get even better one new loop parts installed) Also a lil weird how I set BIOS vcore to 1.375v which hardware monitor recognises for the most part as 1.373vish but AI-suite sees it as 1.368v. I know these are minor differences but trying to get a stable\steady reading that is the same across all my apps, etc AND eliminate the OC instability (which is most prolly the memory rev differences) AND eliminate this vCore jumping around, crazy how its doing that when i thought i had the proper settings set to keep it as steady as possible. this 1920x can easily hit 4.3Ghz when i pushed it, im hoping with memory relaxing to 2T, etc i can at least get 3.2ghz out of it, but dont know if the tradeoff is worth it, good thing this is what i like to find out and test, just been a few years since ive been deep into it, so apologizes again if im rambling or misstating anything, lol. Also got in that heatsink yesterday you recommended, installing it when i update my loop with 2nd rad and distro plate. but ya hopefully you can discern the important info i blathered out …lol, thx again bro, just want to make sure the modded BIOS is the way i want to go, ive had good luck in the past with all modded bios ive used on previous boards ive used so :slight_smile: also I dont know if i asked but does this thread state what exactly was changed\modded to help with keeping this board up to date for Win10x64?

again Ty for any\all info bro, really appreciate the insight, cant believe its been so long since ive dug in to my PC, switched gears\hobby for last year or so and learned Class D, A\B, car amplifier\Subwoofer repair\modding\etc, another hobby of mine. Actually just joined Official Team Orion if you know anything about car audio :slight_smile: but ya, ok enough of the 3am rambling …lol, thx Hans :slight_smile:


you can see the current and max vCore changes are just way crazy, especially being set to what i thought was “super stable steady Non-oc manual” lol, like wtf Asus …or is it me?

I have other pics but you get the idea. Any insight much appreciated. I dont plan on upgrading\changing much as this cost me tons when i got it and still has alot of life in it for my uses, maybe a 2950x and a 6700xt\6800xt (I game at 1440p) soon but other then that im good with what i have, hence hunting down a better, more stable and updated BIOS :slight_smile:

Let’s update to the BIOS/UEFI on post #50 and see how that goes?
Pay particular attention to the flash procedure in the Annex linked above in the first post…! :innocent:

To update follow the method set out in the ANNEX section

[Guide] How to flash a modded AMI UEFI BIOS

expand the “Details” section to view the entire step by step procedure.

Merry Christmas

1 Like

Ty ^^

Ill report back after updating!

Merry Xmas as well!

@jcolter @osonos @Tekjive @Skully @KraZy_SkitZy @Pylit @dessoy @MeatWar @mojpismonosa

UPDATES to latest Zenith Extreme BIOS/UEFI v2401
Okay so here is the update with all the same EFI_ROM changes and updated microcode as of April 18, 2023.

Once again the ANNEX method should be used in this instance, which you can find here:


ZE_mod.zip (5.8 MB)

@hancor how does your latest v2401 compare to 2601 released in Aug on the Asus site? ROG ZENITH EXTREME | Motherboards | ROG United States

I ran UBU on both your 2401 and asus 2601 and all version displayed were the same. Not super familiar with UBU so I am not sure if this means they are basically the same.

Asus 2601
2023-09-27 09_46_36-Administrator_  UEFI BIOS Updater v1.79.17 - ROG-ZENITH-EXTREME-ASUS-2601.CAP

Your modded 2401


@jcolter @osonos @Tekjive @Skully @KraZy_SkitZy @Pylit @dessoy @MeatWar @mojpismonosa

Yes I have an update as I did the mod ZE.ROM as of Sept 27 2023 which is attached below.
Updated Python to v3.11.5, latest MC extractor v1.94.2, and CPU microcodes r276
Further LAN EFI & ROM modules to latest v9.5.05 & 1.5.90 respectively.
All via UBU :wink:
Ran the mod for the last 4 days and it is very stable, which is now matched up with Asus RTX 4090 OC.

Updated microcode:

Updated EFI_ROM modules:

As before you need to use the ANNEX method!

Enjoy! :partying_face:

ZE.rar (5.2 MB)


@hancor so if I understand correctly you took the Asus 2601 and did all the updates you mentioned above, right?

That would be correct.

@Hancor cool thanks!. Any chance you are running windows 11 22h2? I tried upgrading from 21H2 and it failed. Said could be bios version or other driver issues when I googled. Crashed on 1st boot of the upgrade and it auto rolled itself back after a couple reboots. Thinking maybe since I am still on bios 2201 that might be the reason.


EDIT: “I’ll just have to throw a spare drive in and try a clean install…”
I was about to edit the post saying that you should try to update the system, disconnecting all other supposed attached disks, if present…
Your doing a in place upgrade and that op, much depends on the current health/integrity of the host OS.
And i do suggest you do the oficial Asus updates to latest bios before applying the 2601 and not on top of the 2201, i think hancor will agree with this as my opinion.


I’m running Win11 Version 21H2 currently, it was just when I went to upgrade to 22H2 it failed the upgrade. I’ll just have to throw a spare drive in and try a clean install, just need to find some time :slight_smile:

I upgraded fine at the time. But because AMD was having TPM problems for a time I had bought the TPM 2.0 module and installed that on the motherboard. This obviated the software workaround as one had a discrete hardware solution.


1 Like

Hi Hans, thanks for all your posts here on the X399 mobo. I currently have BIOS 2001 and the reason I haven’t upgraded is because it was edited to allow macOS to boot. Did you happen to hackintosh your Zenith Extreme? I’m currently running macOS Big Sur on it, but I’m looking to upgrade everything.

I’m wondering if you have the original, updated 2001 BIOS still as I would like to compare the hex code to my 2001 version to see what the difference is for upgrading to the latest.

I just updated the firmware to your v2601 and I still have macOS booting. I need to update the EFI as an early version of macOS Big Sur running, 11.2. Big Sur is on 11.7, but I want to update to the latest version of macOS that will work with an AMD chipset. Attached it the EFI.
EFI.zip (3.9 MB)

I have some fires to put out right at the moment.
But I’ll have a look a little later this week.
I’ve been plonking about with Debian 12.5 lately

@DCswitch @Meatwar Below updates the EFI RAID & EFI Network, microcodes unchanged.

Microcode update:

ROM EFI updates:

Updated with the latest UBU @Michael_Code using Python version 3.11.8 with minor update to OROM

Cheers :beers:
Hans :partying_face:

Correction: It doesn’t like the EFI AMD RAIDXpert2-Fxx -9.3.2-00130 so back to 9.3.0-00266