[OFFER] ASUS Z87-K_BIOS_UEFI_v1402_complete mod

Do you have any error while you are using your SSD.
I flashed the headless and get dead mouse/keyboard several times aday in both ubuntu and windows.

I get it the headless flash successful.
I can boot from the drive.

However, I got problem with both Windows and Ubuntu. I got my mouse and keyboard dead pretty frequently, then I have to turn the power off. It is not a blue death screen. the keyboard and mouse just stop working.

Edited: I have this works now. Find the following comments for detail.
Confirmed: it booted and works now.

U can have an HW issue with USB ports power/controller… dont believe this as anything to do with bios, since ur experiencing the same symptom in both OS.
Does it stop working in UEFI bios environment? Other ports? Do u see the devices getting disconnected in windows device manager?

@wmldwilly @laiviet2811 @jiraiya78 @Scardigne @izajasz @MeatWar @cheerat

Okay, updated microcode to v28 and EFI ROM updates to UEFI/BIOS found on post #1 and #17 for your pleasure and enjoyment.

latest edit Oct 10, 2020

It seems like a hardware problem.

I had my Nvidia 1080 Ti plugged to the PCI-E 2.0 x4 (which connect through southbridge) and the PCIe NVMe connected through PCI-E 3.0 x16. This seems to bother the southbridge.

I switch these two cards and have them worked well now.

Many thanks.


Typically the graphics card always populates the first PCIe x16 slot for maximum throughput; which is also the default setting; unless you are using the graphics portion of your CPU. Of course not the case here when you have an NVidia 1080Ti…
NVMe typically only needs PCIe x4 slot to work correctly but in your case it is only PCIe 2.0 which is a limitation of the board.

Glad you sorted it all out


I just need that GPU for displaying and debugging some deep learning code before deploying them to the cluster for long training. I have no interest with gaming.
That’s why I choose to maximize the speed of the harddrive (as PCIe 2.0 x4 throttle my samsung NVME to ~1.5GB/s). when I tested with PCIe x16 slot (it use x4 only) I got ~ 2.5GB/s.

Anw, 1.5GB/s is still fast enough as long as it does not stop working randomly.

Really appreciate your effort.


1.5 GB/s is still plenty fast compared to even a SATA SSD which tops out at 600MB/s.
By that metric you are still 2.5X faster…

Even if you dropped in an RTX 3090 graphics card for more AI learning fun the PCIe slot wouldn’t be saturated as it barely swamps out PCIe 2.0.

See this video for a comparison of the RTX 3090 in PCIe 2.0, 3.0, 4.0

Why PCIe 4.0 Doesn’t matter for Gamers… Yet

The headroom on the PCIe 2.0 x16 slot is enough to accommodate the 4K bandwidth at even 144Hz depending on your monitor.

In any case enjoy!


@hancor thanks for updating the bios for this board in Oct2020! Really appreciate it! Works well with my WD SN750 NVMe drive & Big Sur build!

Hi All, Ive followed the amazing step by step guide to generate a Mod Bios on my ASUS Z87-K_UEFI_1402 to allow me to have full NVMe support so I can use the PCIe slot to load windows 10 as an upgrade. (#1 | [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS)

I have named the mod exactly as the downloaded latest ASUS Bios, ie (Z87-K-ASUS-1402.CAP) And then attempted to use the advanced tool in the bios to load this modded bios. I get the “security verification failed”. Ive enjoyed the learning curve thus far and am highly appreciative of the guidance, but I’ve hit a wall here can anyone help me in this regard.

The tools I used to make the mod were the UIEFITool_v0.28.0 and the inserted DXE was the NvmExpressDxe_Small. I used the Hex Editor Neo finally, verified the alteration and then saved using the same name with .CAP
I did not use the FD44Editot_0.9.2_win as I was going to use the tool facility in the existing Bios to flash the USB. Did I miss a step here ?

In any event, Ive hit a wall, and Ive got 6 machines that I have to load windows 10 onto the PCIe slots … else Ill have to return the NVMe M.2 cards and use the old 2.5 inch sata options. Any help would be appreciated. I can send across the Modded Bios as well ?



You can download from post #17 of this thread and then follow the guide in the link below:


More reading, but sound information.


@hancor Thank you very much, Ill keep you posted

@hancor Many tanks. Ive downloaded your Z87HL.rom and also have two options generated by the tools in the post (#1 | [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS)
Ive followed the steps in the link and have read #17.
Ive tried to flash your Z87HL.ROM. I have used the afudos.exe Z87KHL.ROM /P /B /N /X COMMAND in FreeDOS. As in the post the command was afudos mod.rom /GAN ? and having looked at the documentation for the afudos I couldn’t find what this command meant ?
In any event. In the attempted flash, the flowing was the result
Reading flash … done
-ME Data Size checking . ok
-FFS checksums … ok
1e - Error: Secure Flash function is not supported on this file

I tried using the eazy flash option in the bios, and it said the file file format was wrong as it needed to be .CAP … I altered it on the USB, and tried top see if this worked. I had the same error.
I also tried the above with the two different options made with different tools in the guidance notes and had similar errors.

The latest Driver downloaded from asus is Z87-KASUS-1402.CAP and it is 8194kb. When I mod this it ends up being the same size which is good. Your file is 8192kb. … Im not sure what to do next. I can send you both of the mod files to review the mods ? Is this possible ? Sorry for the long winded message … Off to bed now Long Day
Id be grateful of any other options I could attempt ? Kind Regards

oK Ive managed to use your mod file Z87KHL.rom and to use the afudos.exe Z87KHL.rom /GAN and then the results are :-
Reading Flash … done
-Me data size checking . ok
Erasing all block … done
Updating All Block … done
Verifying All block … done
Not sure whet to do now … how do I flash the bios and update it from here ?

Please advise sorry for all the silly questions this is all new to me. Best


type exit hit enter
remove the USB drive
hit del on reboot
enter bios
load setup defaults
enter your favorite settings
for NVMe booting set CSM to DISABLED
set OS to OTHER
reload WINDOZE
and yer good to go


@hancor Thanks for guidance this morning.
I’ve followed your steps above, ie exit, remove usb, hit the Del and entered the bios screen, the name of the bios is still the same as it was prior to this flash ? ie Z87-K BIOS VERSION :1402 is this correct ?
load setup defaults (f5) and set csm to disabled
And Im now loading w10 onto the PCIe slot which is AWSOME !

So impressed with this forum and the support many thanks Hancor yr a genius

How do I donate is this at the Top ?

Best Regards


Yes the bios is numerically the same version 1402 but of course it is modded; otherwise you wouldn’t be booting from the NVMe drive.

If you download the program HWINFO it will tell you the microcode version to verify it is updated.


All donations to the site or myself personally are encouraged and gratefully accepted. (sent PM)



Appreciated how do I donate to you ?


Will do not sure how to pay via email but Ill work it out and advise happy to as you have saved me a load of hassle and its nice to end off two days of late night work with a success and some learning ! thanks