[OFFER] ASUS Z87-K_BIOS_UEFI_v1402_complete mod

EFI GOP Driver Haswell 5.0.1036 ----> 5.5.1034
EFI Realtek UNDI 2.020 ----> 2.054
OROM Realtek ----> 2.67
CPU 306C3 microcode 19 ----> 28 (latest Spectre/Meltdown microcode) Thx Sonix!

NVMe functionality via ------> NVMe mod to run UEFI NVMe SSDs using module NvmExpressDxe_4.ffs dated 04/18/2018 inserted after CSMCORE for this Aptio IV UEFI/BIOS

Made with UEFI Tool v0.28 and UBU_v1_79_8



Enjoy your NVMe capable drive! [ latest edit October 10, 2020 with microcode v28 and EFI/ROM updates ]

Backup your drives and old bios BEFORE flashing…

Microcode updated to v 27; which mitigates Microarchitectural Data Sampling (or MDS) side-channel vulnerabilities in Intel CPUs in addition to Spectre/Meltdown vulnerabilties.

Z87KHL.rar (4.51 MB)

Hi hancor,
I’m new user here. Have been looking for working Z87-k nvme mod.
Thanks for taking your time modding the bios for Z87-k. I hope many other works on their pc but I have ‘security verification failed’ message popup.
What could be the reason?

I tried remove the header capsule using method describe in Fernando thread below but now the message become ‘reading failed’ instead. The step is for ASrock board but i thought it would works being the same Aptio bios Z87 chip.
[Guide] How to flash a modded AMI UEFI BIOS

I’m going to try method in below pro.phantom thread and update later on suspicious of the error due to different bios size after i remove the header.

EDIT by Fernando: All 3 posts merged into 1 (to save space)

@jiraiya78 :
Welcome to the Win-RAID Forum!
If you want, that a specific Forum member (here: the thread opener named hancor) gets notified about your post, you should type a "@" in front of his nickname (here: @hancor ).
Good luck!
Dieter (alias Fernando)

Thanks @Fernando for the edit.

Finally it’s works!

I used the method to bypass security using FreeDOS and Afudos tool to flash the modified and headless z87k.rom.

My intel 960p shown as PATA SS so from your other thread someone ask the same 960 model and you replied yes right :slight_smile:

Many thanks for @hancor and @Fernando for the original tips leading here!

For those looking for steps to flash BIOS bypassing security verification, refer to following thread

ps: is it allowed posting link to other forum :eek:

originally, i tried to flash using hancor z87k.cap file but the file is 2kb bigger than my original bios.
due to afudos file size check in the first step to flash the bios, it failed the check.
my 2nd tried using modified hancor z87k.cap become z87k-headless.rom using AMIBCP tool works.
I think its my luck also that the modified headless rom become exactly my original bios size (the header is 2kb).

download for the headless rom

Yes, unless the linked website/thread/post or its content is illegal.

@jiraiya78 Looks like I was late for the "digital party"…delighted that worked out for you!




@hancor I was wondering if you could please help me understand an issue here?

Originally the discussion started here https://www.overclock.net/forum/5-intel-…oftware-28.html
and ran into an issue with a bios modification for the z87-k microcode 22h

if I increase/change the clock speed from (Auto) to (manual) and increase from default clocks even 100Mhz higher than default (Auto) values the microcode patch changes to 12h in the bios cpu information, and if I leave the cpu clockspeed set to (Auto) then the microcode patch is listed at 22h in bios and I have no idea why its doing this? I was wondering if anyone with further understanding would help me?

Reason I’m after 22h microcode for asus z87-k bios is because apparently it has the best OC potential before 23h spectre/meltdown patches.

See my post #24 here: [OFFER] ASUS Z87-DELUXE updated BIOS v2103 NVMe mod (2)

I’ve found that the initial Spectre/Meltdown microcode v24 (preliminary mitigation) & v25 (final mitigation) did indeed have a performance hit.

When I updated to the latest v27 microcode (MDS mitigation) on the Intel i7-4770K the performance penalty was minimized to less than 1%, on my Z87-Deluxe rig which incorporates the Spectre/Meltdown mitigations.

I’ve been running two cores at 4600Mhz and two cores at 4700Mhz stable (100Mhz BCLK) without issue now on Windows 10 Preview build 18932. For a time I had an EVGA 2080 Ti FTW3 in the box running 150 - 300 fps @1080p, buttery smooth without hiccups depending on the complexity of the scene being rendered. The graphics card is eventually moving over to the Threadripper 2950X CPU build in the next week or two.

Quite frankly, I’d rather run the v27 MDS mitigating microcode, than streak ‘digitally naked’ through the internet, while someone hacks your system on v22 microcode using Spectre, Meltdown or Micro Data Sampling exploits.

Your mileage may vary.


Hi @hancor . Is it possible to flash newer MEI FW onto this BIOS ? IF not, what does it take to make it compatible, for instance, with 9.1 or 9.5 FW ?

Yes it is possible to flash, but you may also BRICK YOUR BOARD, or face a host of other problems that you may wish to avoid as outlined below…

As plutomaniac has adequately warned in the thread:

Intel Management Engine: Drivers, Firmware & System Tools

Warning for 8-series systems: The 8-series desktop systems initially come with v9.0 firmware. The latter is upgradeable to v9.1 firmware only if the OEM has updated the BIOS to be compatible as well. If your BIOS is up to date and the firmware is still v9.0 then avoid updating to v9.1 but only to latter v9.0 releases. The system will not brick but, if the BIOS is not ready, you may face BCLK, fan control and other issues after which going back to v9.0 firmware is often difficult. However, if your current 8-series system has firmware v9.1 (after a BIOS update) then you can update to the latest v9.1 firmware as provided below.

My own Z87 Deluxe board only comes with version 9.0 firmware…so you would swimming in the deep end of the pool amongst the ‘computer sharks’


Ok, my Z87-K uses 9.0. Is it possible to mod the BIOS You made to be compatible with 9.1 or 9.5 ?

Hi again @hancor . Thank You for this modded BIOS. I just bought an PCIE to M.2 adapter and hooked up PCIE NVME drive and it works like a charm ! :wink:

@hancor Is there any new microcode available for z87 and 4th series CPUs? I ve read that there are more holes in those CPUs but I’m curious if maybe intel release new microcode to mitigate (RIDL, Zombieload and 1 more which name I cannot recall now but its quite new ). Thanks :wink:

Haven’t seen anything vis a vis microcode updates for these and UBU_v1.76.0.1 has no news on this front either.


@hancor I’m hoping perhaps you might be able to nudge me in the right direction…

To the best of my memory, I modded my Z87-K mobo to allow nvme-pci booting a long time ago, like at least 2 years or so? maybe more? I recall it basically going off without a hitch with whatever the patched .CAP file I found, and the box ran absolutely flawlessly from then until earlier tonight when I did something stupid. I wish I could remember where I got the modded bios because I can’t seem to find it again - perhaps wherever I got it isn’t around anymore. Extensive searching led me here though, so I have hope.

As I said above I did something absentminded and dumb - I opened up this Z87-K intending to add a video card, and completely spaced out on the fact that the machine had been happily booting from an M2 - pci adapter card in the yellow x16 slot for like 3 years from the M2-pci card in the other x16 (the yellow in this case) slot that I just took out like an idiot. It’s a machine in a rack mount case, and a wee hours of the AM bleary eyed glance around the interior led me to believe that the SATA cables running up into the front of the chassis must be for the boot SATA drive buried in there. They weren’t. :frowning:

Obviously the machine didn’t boot and dropped into the bios util. OH Duh…this little card right here in my lap is what it boots from, I exclaimed while slapping my tired forehead. Pulled the other video card, put back in the nvme adapter, started it up.

nothing. dropped back into the bios. at this point it all comes flooding back to me: "I should see ‘PATA’ as a boot option in here somewhere - it probably blew it out when it tried to start and couldn’t find the card."

There’s no trace of a PATA device as a boot option. It’s as if the BIOS has returned to the previously un-modded state, and has no idea what this NVME card is now that it had been happily and very zippily running off of for like years now.

Okay…search search search, and I end up here. And somewhat overjoyed to land here, because this is like the only search result that leads to someone talking about the actual Z87-K…not the ‘deluxe’ or the ‘pro’ or the ‘C’ or some other flavor. But THE motherboard in question.

Unfortunately, in trying to use ez-flash to load the Z87 file here, I get the security error.

So my question is this, and it comes in two parts: part 1) is there an updated / different version of this patched file that does not trip this security failure? and part 2) if not, does that mean I absolutely must follow the whole “get a freedos version and make a bootable usb stick with a bunch of other tools loaded, and go thru the process all while trying to extrapolate what i’m doing from a guide written for a different manufacturer’s mobo?”

One thing that’s tripped me up, and it may be a side effect of dealing with much newer asus bios tools that seem to feature prominently the ability to back up your current bios before reading in a new one, or even have two versions loaded and switch back and forth or “fail back” between them. The whole “ez-flash 2” experience doesn’t seem to feature such an ability or at least make it easy on you…

If you read all this I truly appreciate it, and hope it’s a quick and easy thing to nudge me the right direction here. I really need this box back up and running as soon as I can possibly get it there - it will soon become a slow moving work disaster for me! :stuck_out_tongue:

Happy New Year!


(edit: Asus Z87-K mobo, was using a modded 1402 but now seems to have lost it’s mod, and the “ME Version” lists

@wmldwilly Try the headless rom file attached which had a link in post #4 of this thread.

jiraiya78 had some success with this link to bypass security


Give that a go and see if you have better luck getting out of the bios woods

POST #1 edited with updated UEFI/BIOS dated Oct. 10 2020


Z87KHL.rar (4.51 MB)

so to make sure I understand - that “headless” file isn’t readable by the bios flash utility, and the only route to installing that is via the other 11-step recipe with freedos and the AMI direct flashing tool and all the rest? (it sounds painful already…)

I’m feeling pretty sad I didn’t tuck away a usb stick with that other mod I found somewhere some time back that “just worked” … where’s that “shoot myself in the foot” emoji? :stuck_out_tongue:



…and what a weird mystery. somehow the bios has “failed back” to it’s can’t-boot-from-nvme-pci-card state, but i can still enter the shell and see/browse the directories of the drive. it’s the only drive in the machine at the moment, and in the interim i’m tossing a sata drive in and installing an OS just to get the machine up again and will take it from there. Ugh.

@wmldwilly Just carefully follow the steps in the link provided in post #17 and that should keep you out of harms way…

Wishing you much success!