[Offer] ASUS Z87 PRO v2103 complete mod

Thanks for your help guys! I have the NVMe M.2 SSD running in the 2nd PCIe x16 slot at PCIe 3.0 x4 with approx. 3.900 MByte/s and the RTX 3090 now running with PCIe x8 instead of x16 which makes no real life difference. Glad my 9 years old system is still running super silent, with low power consumption, fast drive speed and I can run every game, do video editing and everything else.

This UEFI mod is greatly appreciated! Even the latest CPU microcode updates, that’s cool!

1 Like

Hello @hancor,
many thanks for your efforts!! If you send me a PayPal address I will spend you.
I updated my Z87-Pro 2103 using your offer, everything went fine, and now I can boot flawlessly from a Samsung 980 Pro.
Hint to others trying this: You should disconnect ALL Add-On cards including GPUs and reset BIOS settings before updating via flashback!


Delighted your mobo is upgraded and updated… :innocent: :sunglasses:

Email: [email protected]

1 Like

Hi @hancor Thanks for this modded version. Now I can use my 970 Evo without any troubles. But now, I have a trouble with the bluetooth in my motherboard. The bluetooth drivers are updated and all looks so nice. But the bluetooth doesnt work. Before flashing your modded bios, I could use the bluetooth without problem. Do you think you can give me some suggestion to solve this problem? Thank you so much

I can help you. I have the same mobo. You must use driver version Atheros Bluetooth, do not use Atheros Bluetooth
pnputil -add-driver qca_btusb.inf /install
or with GUI

1 Like

Oh man, THANK YOU SO MUCH!!! Solved!!!

@Michael_Code gets the software driver credit.

Enjoy your “new old” computer.


@hancor. any problem with Login to forum.
Couldn’t answer right away. Now I’m using driver from 06/13/2017
In addition, the EFI Shell is built into the BIOS.

thx for the update :innocent:

I didn’t make it earlier - I downloaded the file from the original forum, it was closed a few days later - but I found now the win-raid’s second life here.

So thanks for this mod @hancor - it’s been working flawlessly for over a year and a half (with i5 4670K @4.4GHz, XMP 2400 and KC2500 as boot drive) :happy:

I recently found an unused i74790K OEM for $125 on sale, so soon my PC will have even more life (I’ll try targeting to 4.8-5.0GHz for this chip)
Thank you a lot!

1 Like

Lately I have experienced some weird issues with this modded BIOS. After my PC restarts it doesn’t recognize the NVMe M.2 SSD at all. If I go to BIOS (I haven’t changed anything there) it will show my SATA drives but the Windows boot manager (which sits on the NVMe drive only) and the drive itself are nowhere to be found as a boot option.

SOMETIMES it just helps to switch CSM on and off or simply restart the PC again and suddenly it shows up again (either I go into BIOS and it is back there as a boot drive or I don’t enter BIOS and Windows boots up normally).

When switching CSM setting or restarting doesn’t help, I shut my computer down and turn off the power. I then press the start button to get rid of any remaining cutoff current and turn on the power again. After that I just start my PC again and my device is recognized - as if nothing ever happened.


Any idea what could be causing this? I have a Samsung SSD 980 Pro and it’s working fine - just like my other drives. Windows 11 is also working normally.

By default, with this kind of mod and its not only in your mb model, when the system is set to UEFI boot, these old mbs do not show any NVMe disks in bios, it is explained in Fernando’s NVMe guide (for tests, ONLY with CSM ON, a PATA disk will be show).
A not good sign at all, is the the mb switching itself to CSM (Legacy) by herself, possible causes, the bios ic is dying and loads defaults, cmos battery is below 1.7v and cant keeps the settings stored or the mb itself has issues at hw level.

The mod itself, usually doesn’t do what you mentioned in your case, else the forum would be flooded with such reports of the same instability.

You misunderstood. BIOS isn’t changing CSM setting by itself. I changed it to get it work again. MB works fine so far. Battery has been replaced a few years ago, it’s keeping all settings.

My mistake, anyway a performance NVMe system should be working with in a FULL UEFI environment and not CSM ON, this means the system was cloned or was installed using CSM…or something was changed manually in boot area, if primary was installed as UEFI, BAD choice.
There are no reports regarding the mod, using both methods for installation.

Hmmm, I don’t remember how I installed it. I am sure though I did not clone it. I believe a guide said CSM only needs to be on for the first start and can be turned off after Windows has created its boot partition, so I switched CSM off after that. And many, many times Windows just booted normally. Just lately it randomly does not show up as a boot device or as a device the system knows at all.

As far as I know boot sectors are being processed after UEFI BIOS has loaded all devices already. So it being recognized by the system and sometimes not (and having worked for years with no HW changes and no broken Windows either), can’t have to do with some possibly somehow unstable boot sector, or can it? Any way to fix that without a clean install?

No…wrong, for testing only, go read it again.

Step 3 - Flashing of the modded BIOS:

**Additional Notes:** (open/hide by a click)

Verification of the successful BIOS Modding/Flashing:

  • Don’t forget to reset the BIOS settings, which had been altered for this test.

It should only be used with CSM ON, if the system doesnt have, for example a compatible EFI GPU card, for a full UEFI enviroment.

EDIT: I understand that the system was running fine with CSM ON/OFF, already told you, its not from the mod for sure, if its correctly doesnt/flashed, have to point out any possible hw issues outside this… yourself agree that this system was always ok and running with it, correct? so…

Wait, I had this NVMe SSD working for years, the flashed BIOS worked great. It booted with either CSM off and on. It never made any difference.

So what exactly do you think is the issue?

I just want to say thank you for trying to help me. Yes, it was always ok and still is once it has booted. Standby also works flawless, it powers a RTX 3090 without any issues, too. Just can’t use Resizeable Bar because the MB doesn’t support it.

I’d try to reseat the NVMe disk in its slot and the Riser card, doesn’t sound like bios to me, NVMe recognition doesn’t have NVRAM settings afaik and even if they wouldn’t change back and forth, same for bit- errors in bios region.

You mentioned the CMOS battery already, but maybe worth a try to check voltage again.

I opened up my case and I could notice that one of my SATA drives’ SATA port wasn’t properly connected. I remember it was a little tricky without cable extensions to get multiple drives across the case connected. So after several years the cable finally became a little loose.

System is up and running. I still find it strange that this (a loose SATA cable) would lead to my NVMe drive not being recognized by the system if it only restarts - powering off and on again instead would get the system to recognize it again. Kinda interesting!

Will update if any issue will arrive but I think that’s it!

@ lfb6: It sits there tightly as before. There’s no riser card. But “reseating” applied to the loose SATA port cable of one my other SATA SSDs. xD Thanks for the headsup!