[Offer] ASUS Z87 PRO v2103 complete mod

As requested by "DreamerTM"; your dream has come true.

ROM/EFI IRS RAID for SATA ------> v14.8.2.2397
ROM/EFI VBIOS v5.0.1036 ------> v5.5.1034
ROM/EFI Realtek LAN v2.020 ------> v2.053
ROM/EFI Intel Gigabit UNDI ------> v0.0.29
OROM Intel Boot Agent Cl ------> v0.1.16
CPU microcode 0306C 19 -------> 28 (Thx WinRaiders!)

JackRackham.png


The "Cutting Edge" of bios modding

LAST MODDED July 11, 2020

Made with UEFI Tool v0.27 & UBU v1.79_4
Methodology shown in post #16

NVMe mod to run UEFI NVMe SSDs using module NvmExpressDxe.ffs dated 04/18/2018 which is 21Kb in size.
All the rest is pretty standard ROM/EFI updates.

Enjoy your new NVMe capable modded bios with MDS/Meltdown/Spectre microcode updates.

BTW microcode v 28 fixes Microarchitectural Data Sampling (or MDS) side-channel vulnerabilities in Intel CPUs in addition to Spectre/Meltdown vulnerabilties.

As usual make a back up of your current bios and drives!

Cheers

Z87P_manual_NVMe_mod.rar (4.76 MB)

1 Like

Dear @hancor Thanks for the BIOS firmware. I flashed it over BIOS Flashback. Everything was done successfully. The system was installed and booted without problems.
One question. Ashampoo® Specter Meltdown CPU Checker gives an error when checking. My processor is vulnerable (i7-4770K). So it should be?

spectre.jpg

Try the InSpectre program found here:

https://www.grc.com/inspectre.htm via Gibson Research


You’ll find that your bios/uefi update is Spectre/Meltdown mitigated.

Also the most recent microcode is v27 which also mitigates against the Microarchitectural Data Sampling (MDS) vulnerability.

Here is what I get with Inspectre:

inspectre.png



In any case, delighted that your bios update went without issues.


Cheers

1 Like

Hi @hancor ,

Nice work, but can You mod bios for Z87-PRO(V EDITION)? Will be nice.

https://www.asus.com/us/supportonly/Z87-…/HelpDesk_BIOS/

Thank You.




You can pick up your baby here: [OFFER] Z87-PRO (V EDITION) v2103_complete mod

1 Like

Hi @hancor
Sorry for hijacking this thread, but I been trying to get my nvme m2 disc to work by following these steps but no luck. I have migrated my os to the new disc and I can see it as a new disk and (maybe wrong!?) assigned it with new drive letter. But it dont show up in the bios as a bootable (or otherwise) disc.
I dont know if its possible to use it as a bootable disc at all?
I have a Asus Z87 Pro mobo, flashed with your 2103 version, disc is Intel SSD 660p 1tb NVMe 3.0 x4 and a Adapter DeLOCK PCIe -> M.2 PCIe 3.0.
What can I do to make it work or is it domed?
Thanks for any info!

@perolalars

The NVMe SSD is bootable, but listed within the BIOS as “Windows Boot Manager”, this is where you do a CLEAN install of windows, without any other drives attached.

If you are not seeing the “Windows Boot Manager” in the boot tab of your BIOS/UEFI then you probably need to set the following:

NVME full functionality is achieved when CSM (Compatibility Support Module) is set to DISABLED in the boot tab, reboot, and then check the boot tab again.

If you have any other drives in the MBR (Master Boot Record ) format, you’ll need to convert them ALL to GPT (GUI Partition Table ) format, otherwise the UEFI will not “see” them.

Do your clean install of Windows 10 (the GPT version) to the “Windows Boot Manager” which is your NVMe SSD drive. If you check the link below at post #356, you’ll see what you are looking for in the UEFI boot tab (click on picture to expand) and why MBR and GPT drives don’t play nice together.

[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS (24)


Good luck and enjoy!

Cheers



MBR and GPT do not play well in a mixed evironment.

@hancor
Thanks a million!! Will try your advice and hope that I succeed! I owe you a beer! Or 2 :slight_smile:

A friend of mine has this motherboard and it shows microcode v 25 in the bios…Is MC 27 any better for overclocking and temps,or is it just better to protect the cpu from vulnerability’s.Has anyone tested this modded bios out with regards to temps and overclocking compared to older microcodes…



@NIK1

I’ve tried on microcode v24, v25, and v27. v24, v25 do indeed have a performance penalty in the 5-10% region. v27 microcode is the more mature mitigation to Spectre, Meltdown, and MDS vulnerabilities; which from my own testing on Asus Z87-Deluxe resulted in a performance hit on the order of 0.5% - 1.0% which was a much better result.

On my Z87-Deluxe I was able to hit 4.7GHz on two cores and 4.6Ghz on the remaining cores with v27 microcode. Heat and temps not an issue.

Cheers

Hi, I successfully flashed BIOS on my motherboard. I Installed windows, it’s booting fine but I have problem with sleep mode. Windows in not waking up from sleep mode at all. Do you have any ideas why it’s not working?

Also there is another problem. I can’t see NVMe in boot options. System is booting without problems but there is not NVMe option on list.

Thanks for any help :slight_smile:

@zibiksior



The NVMe module is there as in this detection capture:



In the meantime, I’ve updated the EFI ROM modules as follows:



and microcode update to version 28




Try flashing the updated file and report back, on the NVMe issue make sure CSM (Compatibility Support Mode) in the bios is disabled and all your drives are configured GPT (Gui Partition Table)


Cheers

Z87P.zip (5.26 MB)

1 Like

Hi, @hancor thank you for the response. Sorry for the false alarm but sleep problem is cause by my GTX 660 GPU… Previously my father was using this computer and I wasn’t aware of this problem :frowning:

Anyway thanks for updated bios. I flashed it already and everything works fine :slight_smile:

NVMe disk is visible as boot device. I had to disable my HDD as boot devices and now NVMe is visible as only boot device. After that I have to reformat my HDD’s as GPT.

Cheers

@hancor : When i update to the modded bios, of the ram work at 1333 and i when i try to configure it to work at 2400 Mh (throught Manual setting or XMP) it change nothing. When i go back to official bios - 2400 mhz works again.

I looked at neighboring topics (z87 bios modded) and many have the same problem. Could you fix it?

Hi for all!!!

Tell me please what is the right way to flash the attached modded BIOS?
I’ve tried a lot of different ways and faced with a security/lock problem.

Help please. :slight_smile:

Okay redid the NVMe mod using the small *.ffs version as follows:

First post in this thread contains the updated modded BIOS/UEFI Last modded June 15, 2020

Original UBU detect:

Z87_PRO_detect_v2103.png




UBU EFI ROM stock UBU microcode stock v19

Z87_PRO_EFI_ROM_stock_v2103.png

Z87_PRO_microcode_stock_v2103.png




UBU EFI ROM update mods UBU microcode update v28

Z87_PRO_EFI_ROM_update_v2103.png

Z87_PRO_microcode_v28_update_v2103.png




NVMe small module insertion before NVMe small module insertion after

z87_PRO_insert_NVMe_small_15_06_2020.png

z87_PRO_NVMe_small_saved_15_06_2020.png

@hancor

Alas, RAM does not work either at a frequency of 2133 or at a frequency of 2400.
Only 1333. XMP is set in the BIOS, but it does not work.

It’s a shame :frowning:

Regards


This post is written about the manual update mode. You, of course, clearly know how and what to do. But maybe so?

Hello @hanсor

I have the same problem in your moded BIOS. It works only at a frequency of 1333 and does not switch to any frequency.

Tell me, could you update the BIOS without NVMe? I check if the frequency above 1333 will work.

@begemot For your pleasure no NVMe mod in the attached file

Z87P_no_NVMe.rar (4.75 MB)

If that works for them @hancor , then just do NVME insert other way (other tool instead)