[Offer] ASUS Z87 PRO v2103 complete mod

@Lost_N_BIOS @begemot @lemoff @DreamerTM @Matimati123 @perolalars @NIK1 @zibiksior @ssdas @Skorpiuz @lsevald


Went back and used MMTool version 4.50.0.23 and did a manual insert of NVMe module.

See if that helps.

Cheers


EDIT: Okay now confirmed by begemot the modded files works with different memory settings
File now updated in post #1

Z87P_manual_NVMe_mod.rar (4.76 MB)

@hancor - Did you do the first one with UEFITool, or UBU? If UBU, hard to say which was used, you may need to make 2 for them to test, both manual one MMTool and one UEFITool 25.0

@Lost_N_BIOS

First one I did on UEFI Tool 0.25 way back when, and then again with UBU, so some of the bios are getting a little cranky.

On post #21 I went back to the old MMTool 4.50.0.23

Balance of the mods done on UBU v1.79.4 with Python 3.7.8 for the microcodes.

Cheers

Ohh, well that does not help I guess, since I don’t know which one they are complaining does not work with memory speed/NVME
Memory speed issue may not be due to NVME insert, are you/they sure? It may be due to microcode update issue, padding added/removed or FIT, or other edits in DXE volume add/remove padding.

Maybe best for you to test, if you have this board, or make them test stock BIOS and only NVME insert MMTool and UEFITool by itself, see which works, and which is OK or not with memory speeds.
Then that would rule out NVME insert as issue, then rest can be checked later after UBU edit on top of that.
Sorry, I am not trying to add to the mess pile here, was only trying to help

Python is not used to edit microcodes, only to check and show you them, it’s MC Extractor. Actual microcode edit/replace is still done with MMTool or UEFIReplace

@hancor

I checked the BIOS modded from post #21
XMP worked, microcode 28

NVMe has not yet tested.

Thank you so much for supporting the old Asus motherboards. I hope very much that you will continue to support :wink:

@begemot

Okay good the memory is doing what it should.

Let us know how the NVMe mod works out…!

@lemoff @DreamerTM @Matimati123 @perolalars @NIK1 @zibiksior @ssdas @Skorpiuz @lsevald

FIXED memory issue Z87 Pro bios

@hancor
Any chance you can add the updated network drivers?

The 2014 ASUS z87 pro bios has the following;

3 - Network
EFI Intel PRO1000 UNDI - 5.4.19
OROM Intel Boot Agent GE - 1.5.43
EFI Realtek UNDI Driver - 2.020


yours unfortunately has older versions.

edit, I think I just misread - seems your version actually replace the pro1000 with gigabit - hence the confusion with versions. :smiley:

@broglah

Yes, network EFI/ROMs all updated as set out in corrected first post

@hancor
I’ve flashed with your provided modified bios update, but unfortunately nvme doesn’t appear to be showing in the bios, it shows in windows and I created a gpt partition, just doesn’t show in boot options in the bios.

I also tried disabling CSM however my GPU doesn’t work without it & so the bios auto enables it on boot.

@broglah

Okay the problem is not the bios, it is your graphics card…as in probably "ancient".
NVMe requires using the .efi extensions rather than the older .rom extensions.
A newer graphics card will rectify this, should you be willing to buy an NVMe ssd and adapter to extend the life of your computer platform.

If you did get graphics card, NVMe ssd, and NVMe adapter, naturally they could all migrate to a newer platform
when you choose to do a full computer upgrade.

Cheers

@hancor the GPU isn’t that old, it’s an R9 Fury X (OK it’s pretty old haha)

Seems I might be in luck
https://community.amd.com/community/gami…o-uefi-firmware

I’ll give it a whirl and report back :slight_smile:

Thank you for the explanation too, much appreciated.

@broglah

Ok, that looks like it may get you into the UEFI woods and on to NVMe bliss… :slight_smile:


Cheers

@hancor

Ok flashed the firmware onto my GPU and disabled CSM, now the only option that displays for boot is (UEFI USB Disk 3.0)

Can’t see any sata devices in boot options nor the nvme drive.

Additionally loaded up USB with Windows 10 and attempted to install OS to the SSD, installer complains about bios missing drivers for the drive and showing that it would therefore not be bootable.

What am I missing?

@broglah

What NVMe PCIe M.2 SSD drive and which adapter are you using?

Make sure your adapter supports NVMe M.2 PCIe SSDs and that you mounted it in the correct slot (ie not the SATA SSD slot like some adapters).

Further, when doing the first install on the NVMe drive, ensure all your drives are uninstalled and converted to GPT.

Notably any MBR (Master Boot Record {limited to 2TB}) drives need to be converted to GPT (Gui Partition Table) drives as the UEFI environment does’nt recognize MBR drives. MBR and GPT drives CANNOT COEXIST in the same boot environment!

To summarize:

1. Convert and back up all MBR drives to GPT drives. Unhook all your SATA drives on the first NVMe install.
2. Ensure you have an NVMe PCIe M.2 compliant adapter and that your NVMe PCIe M.2 SSD is in the correct slot to support NVMe booting.

All the hair pulling has been done for you see my posts from this thread:

See post #356 on what you should find with pic:

[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS (24)

Try that, let us know how it goes…

Cheers

@hancor

I finally got it working after removing all the sata drives, just installed a fresh version of Windows 10 and all is good.

Just need to enable hot add now for the sata drives and get them converted.

Thanks very much for your help and support, drop me a PM with your email as I would like to reward you with a monetary thank you for some coffee/beers.

I’ll drop a donation to the site as a whole too, thanks again :slight_smile:

Delighted your NVMe booting rig is up and running!

I hope it gives you many years of service yet!

Overclock on my i7-4770K regularly runs two cores at 4.7Ghz with the other two at 4.8Ghz.

Enjoy your “new speedy” rig.


Cheers

Hans

Which SSD would you recommend: Intel 760 or Samsung 970? Maybe some other variant?

And also PCI-E M.2 adapter.

@begemot

I’ve had very good success with the now “old” Samsung 950 Pro in 512GB version; but they are harder to find and the new Samsung 970 Pro 1TB are speedier and I’ve “RAIDed” them in my new rig; but test piloted in my Asus Z87-Deluxe with good results. The PRO versions tend to be more expensive; but have better write life cycles. These might be appropriate if one is doing video/photo editing projects, etc.

For the snappiest results, for more pedestrian use cases, the Samsung 970 EVO Plus (1TB or 2TB depending on your budget) has some of the best read and writes in the PCIe 3.0 specification area. The EVO runs about $237USD compared to Intel’s 760p which runs about $271USD @ 1TB sizes.

As for adapter, this usually depends on your area, as these are now fairly easy to source.

When I was doing this five years ago I used the Addonics the M.2 PCIe SSD Adapter X110 part number AD2M2X-PX4.
I don’t think they make this anymore though; they have a new one but its expensive. At the time this was $38.00USD the early adopter/adapter price!!

https://www.addonics.com/products/ad2m2nvmpx8.php $155.00 does dual NMVe RAID0; but this looks overkill.

https://www.addonics.com/products/adm2nvmpx4.php about $19.00

Or here is one on amazon which does M.2 and SATA for $17.00

https://www.amazon.com/Adapter-advanced-…ps%2C200&sr=8-6

There are a few out there for the under $10.00 mark but your mileage may vary.

Cheers

@hancor

https://aliexpress.ru/item/4000449046219.html
https://aliexpress.ru/item/32974085672.html

Adapter yes, easy to find.