[OFFER] ASUS Z87-WS_BIOS_UEFI_v2004_complete mods


Sorry I have written a typo, my MB is Z87-WS. The Z97 chipset has PCIe booting. Please excuse my idiotic mistake. So if u look up current BIOS version for Asus Z87-WS. It should be ver2004.

@ deejaytnk

Attention to detail is a virtue, you would not try this with open heart or brain surgery[oh2]

The “close enough gang” practice with horseshoes and hand grenades

You now know the drill!

EFI/ROM updates as in pic below:

Asus Z87WS_EFI_ROM_update.png

Microcode updates in pic as below:

Asus Z87WS_microcode_update_v28.png

NVMe functionality via ------> NVMe mod to run UEFI NVMe SSDs using module NvmExpressDxe_4.ffs dated 04/18/2018 inserted after CSMCORE for this Aptio IV UEFI/BIOS via
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

Made with UEFITool 0.28 and UBU_1_77

Enjoy your NVMe capable drive!

Backup your drives and old bios BEFORE flashing…

BTW microcode v28 is the latest mitigation to Microarchitectural Data Sampling (or MDS) side-channel vulnerabilities in Intel CPUs in addition to Spectre/Meltdown vulnerabilties.

Use USB BIOS Flashback procedure outlined in your manual p. 2-11

Latest edit: May 7, 2020

Z87WS.rar (4.98 MB)

@deejaytnk @Lost_N_BIOS

update to v28 microcode, and EFI/ROM updates as indicated in first post.

@hancor - I am still on your modded bios (originally installed on June 2019) v2004 for my Asus Z87-WS. I have been running Windows 10 (Version 1809) ever since. I tried to update to Build to 1903 back in Q42019, but had stability problems. Just recently I successfully got the system to run Version 21H2 *** So Sad Win10 is the end of the road OS for Z87, NO Win11 support ***. However this system is solely used to have Acronis to backup files. Somehow Acronis profiles (prior from Build 1809) to clone an image of a NVME drive to a HDD => prompts a drive communication error and does not start when click to do so. I get the same error even after creating new cloning profiles. Have you encounter situations the same or similar to this scenario. Please advise, thanks.

PS - @hancor, you pinged me back in May 2020 to => update to v28 microcode, and EFI/ROM updates as indicated in first post.

I have not done that, would that resolve my Version 21H2 problem?

What do you expect from a mod to resolve the issues between a windows os build and a private backup software? Have you tried to see forums related to, MS or Acromis?
Thats simple my friend, put back the original ASUS bios on the system and see the results…
I have 3 Z77 systems running 21H1/2/3 all W11… none of them have specific issues… strange old machines humm

EDIT: Sry my friend, have no intention to offend upon your knowledge…i live a little more ahead of you then, ill correct it MS now calls it MOMENTO… cheers

@meatwar - The whole purpose of this thread is making the Z87 chipset capable of reading nvme drives installed on the PCIe slots. @hancor helped non-coding members of this community to achieve that by modding the bios. Acronis was handling data transfers between my nvme drive (on PCIe) and HDD (on SATA) on Win10 v1809. If I have to stay at this version to keep this I guess I have to, otherwise I am reaching out to @hancor if he has a solution because his published working Win10 version is 2004 on Page 1 of the thread.