[Offer] Gigabyte GA-970A-DS3P rev. 1.0 NVMe MOD


"Installed this…" this is not a driver. This is a bios flash file.
For use with Q-Flash utility only on the exact motherboard/revision model only.

I installed this and now have no video output? Can anyone help?

Yeah thats what i did formatted a usb went too q flash on the bios. I have the 970a ds3p rev 1

Im getting some sort of video output but now the pc gets as far as the bios then reboots and is stuck in some sort of boot loop after taking the battery out and booting on one ram stick at the moment

What was the bios version on the motherboard before flash this bios mod?

@Ryanjohnson Since it’s dual bios, could you try to power off your system first, then press and hold power + reset for 11 seconds (pc will turn on, then off for some moment, let it be), then release it after 11 secs, and power on your motherboard again. it might prompt the file on backup bios to flash the main bios, since sometimes on older motherbord the backup bios is not updated, left at stock. you might need to set some of your setting first after the recovery is done.

Also, after everything fine, try to update the bios to the latest from gigabyte website, make sure the revision in your board is correct/matched with the page (there is rev 1.0 and 2.x), after update success, go to bios gain, and use Q-Flash to dump your bios, by simply enter the q flash menu, and save bios to drive (make sure usb drive is still on the usb port even after bios update). then send it here.

Yes that worked! Thankyou! Ill try updating first then its defo rev 1.0 it says it on the mobo

By that do you mean pull my bios file?

yes, dump/pull the bios file using "Save Bios To Drive" in Qflash, name it anything you want with .bin in the end, then send it here.

Also another tips, if you updated your bios to the latest, and want the backup bios to be updated too, spam alt + f10. just make sure you updated the bios from the official page, then do the alt+f10 after you updated the bios (dont change any settings, just let it be stock fresh after you flash the update), wait it, and the pc will turn off if it completed, just make sure dont do alt+f10 IF you have a modded bios or something, since that backup bios is the only one that have stock fresh flashed bios from your main bios region. do this if you want to update the backup bios with the all fresh update from your Main bios :D.

Okay ill give that a go. Problem now is I’ve put all my ram sticks back in the mobo and now it wont boot anything i dont get whats happened


wont let me upload the file as a .bin

archive it into .zip or .rar, and make sure its not past 8MB

okay yea that worked

bios.zip (2.65 MB)

Here you go @Ryanjohnson , just flash it via q-flash, since it’s the motherboard own stock original bios. Better read readme.txt first :smiley:

970ADS3PNVMe.rar (5.27 MB)

thankyou. ill give it a go.

dont suppose you know why i can only run one ram stick now do you?

Sorry, but if the motherboard is already restored with overwriting the maain bios with the stock bios on backup bios, and it still didnt work, must something to do within the imc, the motherboard, or the ram itself. try to clean the ram contacts first, and blow the ram socket so there is no dust there. also try to enable all the interleaving options to enabled, in the advanced memory section. Other than that, it’s beyond my knowledge :"

okay ill try enabling them. strange as it was working fine before with 16gb ram can only run 4 now

i have done the q flash with those files. didnt break the pc this time but on the boot options i still only see the hdd and disk drive.

i have got the nvme drive installed too the pci 4 slot via a adaptor and windows can see it as a usable ssd

If you want to make it bootable, you need to disable your bios CSM Support, making it all UEFI only. Make sure sata is set on AHCI, Boot options is on Windows 8 WHQL, CSM Support on Never, save and exit, and proceed to install windows, just make sure the bootable is made using rufus, and set at GPT - UEFI (non bios). It will work since my friend that even use an OEM H61 samsung board is able to do this using my mod.


thanks for the help but im not going too bother. the pc is usless now