[OFFER] Gigabyte GA-X58A-UD5 rev.1 mod BIOS

The latest available BIOS version for this type and revision of motherboard is F8b.

F8a is the latest on the Gigabyte website, but F8b is the latest version available which some people acquired by asking Gigabyte directly. Unfortunately most of the links on other forums for it are now unavailable. I took that as a base version and used Phoenix48’s modded BIOS for the GA-X58A-UD9 found in this forum as a guide.

In the end I made the following modifications:

1. Updated Intel RST RAID for SATA - v10.6.0.1091 (RAIDRST5.BIN) ==> now Intel RST RAID ROM v11.2.0.1527 with TRIM in RAID 0 support (recommended on this forum due to benchmarks, use with driver version v11.2.0.1006 for performance, more information here)

2. Updated JMicron JMB36x RAID ROM v1.07.06 (jmb10706.bin) ==> JMicron JMB36x RAID ROM v1.08.01

3. Updated Realtek PCIe GBE Family Controller Series v2.39 (rtegrom.lom) ==> Realtek PCIe GBE Family Controller Series v2.66 (PXE + RPL ROM)

4. Updated Q-Flash Utility v2.23 (SBF.BIN) ==> Q-Flash Utility v2.24 (thanks Phoenix48)

5. Updated Marvell AHCI/RAID ROM and firmware:
- Updated Autoload to version v2.0.0.061D
- Updated OROM to version v1.0.0.1038 with deviceID 9123 (recommended ID by lordkag here)
- Updated firmware to version v2.3.0.1007

These are all packed into M9123FW.BIN in the BIOS with specific offsets and formats. To update your system, set the SATA3 firmware selection in the BIOS to FORCED. During boot it will update the system chip with the image in the BIOS and then do a reboot, then set it back to ONCHIP. (GRAID.BIN in the BIOS needs to be left alone as it seems to be a dummy module that enables the Marvell RAID configuration to work from the BIOS - I wrote about my experience about this here)

6. Updated to the latest available microcode versions and fixed the microcode entries in the BIOS (NCPUCODE.BIN), no more duplicated entries etc. (also thanks Phoenix48) All latest versions as of 2020-02-14.


Modded version: GA-X58A-UD5 rev.1 F8b - modded BIOS - last updated on 2020-02-14
Original version: GA-X58A-UD5 rev.1 F8b - original BIOS

I recommend updating from a DOS boot USB with the FLASHSPI.EXE Gigabyte distributes with the official BIOS downloads. Use switches /C /D /E to Clear DMI data, Clear CMOS data and load defaults. An example would be: FLASHSPI.EXE BIOSFILE.F8B /C /D /E

You can also update the firmware on the USB 3.0 controller chip from Windows if you want to, see here.

Thanks to all on this forum who made it possible for me to make this mod.

Hi, Thanks for creating this bios! Long live the x58. Just a question before I update. Do the latest microcode updates include patches for the Spectre / Meltdown flaws? If so. how was the performance hit since updating?


Thank you for the mod and all the valuable information.

Would there make any sense to also update the Intel AHCI ROM from 1.20E to v2.00H ?

Or this is not possible ?

Thank you for your reply

You cant. I have done this before and i bricked the motherboard.
Also i tried all the versions and after updating, setting the BIOS to AHCI will fail to detect any hard drives.

I really couldn’t tell you because I changed to a new CPU when I updated the BIOS so I can’t do a before-and-after comparison. In day-to-day activity I haven’t noticed any performance problems.

As far as I know operating systems load the most up to date microcodes available anyway during startup and use that, so the ones in the BIOS are only used before the OS starts.
The BIOS contains microcodes for the following commercially available CPUIDs: 106A4, 106A5, 206C2.
Intel released a list in 2018 detailing which processors will receive a microcode update to fix the vulnerabilities (available here).

106A4 - did not receive a microcode update, the processors were too old and difficult to fix in the microcode. These include Intel Core i7-920,930 CPUs.
106A5 and 206C2 - did receive an updated microcode with some fixes but only if it is based on the Nehalem-EP or Westmere-EP architecture. Notice that for example the Intel Core i7-970 is CPUID 206C2 but it is marked red in the list so it did not receive a mitigation in the microcode.

If you run the InSpectre tool (available here) it says that there will be a performance hit for enabling the mitigations.

You will have to make a judgement call to enable or disable the mitigations in your operating system. If you require absolute performance, disable it, if you need maximum security and could take a performance hit enable them. As far as I know Meltdown and Spectre vulnerabilities in general allow malicious processes to read the protected memory of other processes therefore potentially leaking sensitive information. So the main risk these vulnerabilities present is the theft of private data, but to do that a malicious process has to run on your system targeting a specific process for private information. To this day I still have not heard about any widespread use of these vulnerabilities in malware in the wild or anybody affected by the theft of data due to malware using these vulnerabilities. Scams are easier to steal private data.

In my opinion hosting providers and server owners had to be the most concerned about this issue. So call me crazy but the benefits of enabling these mitigations vs. the performance hit of preventing the CPU to do speculative execution seems too high price to pay for a simple home user. That’s just my opinion.

In the topic about those OROMs it says the 2.00H seems to not contain the DeviceIDs that the earlier version contains. So as boombastik said it probably would not work.
Even if it did there is no evidence that it would provide any benefit at all, since it was never released publicly, it could be a test version which is slower. I didn’t mess with it.

@boombastik - Did you add your device ID when you tested 2.00h

@Lost_N_BIOS Yes i worked with @Modfreakz .
I tested 2.00h and all the versions with added id.
The required modification of the Intel AHCI ROM module seems to be difficult. Furthermore the original AHCI Option ROM is located above a sensitive module, with the consequence, that the update cannot easily been done by using CBROM32_198 and the usual command. (original by Fernado)

Also i tried all version 1 AHCI.

With these my motherboard made boot loop every 3 sec.
I short circuit the main bios to make it to be flashed by the backup one and now i dont even remember the pins.
The version 2.00h worked but didnt recognize any hdd.
My motherboard was the GA-EX58-UD5 a similar model like this.

@boombastik - Mod AHCI rom is simple, adding ID is only two bytes? But yes, for the insertion, on some BIOS you have to do special way to be safe and avoid breaking the BIOS, yes, that part can be difficult to do unless you are familiar with doing it.
For such mod, I would use 115 or 155 most likely, but I can’t say for sure, I’d have to do the mod before I could see which is best or what I’d use etc. Yes, for sure, I can say now without looking that I would not use 195/196/198/199

If done correctly, BIOS would not brick, but AHCI would fail if the rom was not working.

At least with 2.00h it was initialized by the bios because i could see the version in startup but it didn’t read and hdd even dvd-rom.
I searched for the mods but i didnt have any of them.

@boombastik - Sounds like it was all correct then, no brick, and rom loading at startup.
Probably just not compatible with that board or chipset, if you had the ID in correctly (ie - @ 22-23h >> 22 3B)

@modfreakz was expert back then he modded the bios. Also the brick was with older versions from 1.x achi era because i had a folder with many versions newer from 1.20h.
Also i found this in evga forums for an x58 motherboard evga:

There is also an AHCI option rom, is there any chance i can update this as well?

Are you talking about the Intel AHCI Option ROM 1.20E? If so, we have tried to integrate this into our BIOS before, but never with 100% success. Unfortunately, the EVGA X58 BIOS uses a Phoenix AHCI ROM, which is unique to Award-based legacy (non-UEFI) BIOSes. That being said, it is possible to replace it with the one from Intel, but after doing so, setting the BIOS to AHCI instead of IDE or RAID will then fail to detect any hard drives or optical drives. The workaround is to simply set the BIOS to RAID. This will still let you use single or multiple hard drives as stand-alones (not in a RAID array). Doing this will basically not invoke the AHCI ROM at all, which shaves off a couple of seconds of boot time.
I am currently using a modified version of my BIOS posted here with the addition of the latest available Intel AHCI ROM 1.20E0027 as well as the latest Realtek PXE ROM 2.48. If anyone is interested in trying this, let me know and I’ll upload a version for all boards as a separate download.

@boombastik - Then I’m sure he probably put the device ID in there properly

Stuff you quoted does not apply to the Gigabyte X58 BIOS, that’s only relevant to EVGA Phoenix BIOS.
As for 1.20E, I never had any issues with 1.20E, can’t remember if I tested any to be OK above that or not. 1.20E is about as fast as anyone could hope to get anyway, so really no need for “Something better/faster”

Sorry to revive this long ago dead post, but I recently have fun with this modded bios and mobo and found that the tRFC timming on the M.I.T. (Motherboard Intelligent Tweaker) BIOS menu only accept values form 0 to 255 (coded on 1 Byte). In specs (Jedec Standard SPD Data Table), it’s written that tRFC is a 2 Byte coded value. Also, some DDR3 RAM modules have tRFC > 255.

Is there a (more or less) simple way to patch the BIOS in order to set a tRFC value > 255 ?


hello everyone.

i own a Beautiful x57a ud7 rev.1… it has worked flawlessly for over 12 years with a i7 950 and 12GB mushkin redline 1600 cl6

this week i finally got my hands on a i7 990x for a penny and its time i give this board a upgrade.

new cpu 990x
new ram 24gb 2400
new nvme m.2

back in the day i modded this bios myself but is totally outdated now and i’m kinda rusty on biosmodding, so i’m asking for your help getting a new modbios with updated versions of microcode, roms and firmware before i install the new cpu.

Theres a linked mod here post#15: Help microcode update for Gigabyte GA-X58A UD7 Rev 1.0 bios F9d or official F9a

Then use CBROM155, guide here: [Guide] How to update the CPU microcodes on a non-UEFI Award/Phoenix BIOS

to update latest mcodes from here: https://github.com/platomav/CPUMicrocodes/tree/master/Intel

so i tried do my BiosMod… updated intelraid_rom, marvell_rom, jmicron_rom and lan_rom but still didn’t updated microcode successfully :frowning:

can someone check it out?

X58AUD7.zip (974 KB)

HEX edit the mcodes, starting at 0x1D37DF to 0x1E23DF.
8 mcodes present.
Use MC extractor for offset guidance

A guide here: [Guide] How to update the CPU microcodes on a non-UEFI Award/Phoenix BIOS

i did it! hex did the trick, thanks a lot