[OFFER] MAXIMUS VI FORMULA BIOS 1603 modded for NVMe boot drive and EFI updates

ROM/EFI IRS RAID for SATA ------> v14.8.2.2397
ROM/EFI VBIOS v5.0.1036 ------> v5.5.1034
ROM/EFI Realtek LAN v2.020 ------> v2.053
ROM/EFI Intel Gigabit UNDI ------> v0.0.29
OROM Intel Boot Agent Cl ------> v0.1.16

Asus_Maximus_VI_Formula_v1603_EFI_ROM.png



CPU microcode 0306C 19 -------> 28 (Thx WinRaiders!)

Jolly Roger.png



Asus_Maximus_VI_Formula_v1603_microcode.png



The "Cutting Edge" of bios modding

Made with UEFI Tool v0.28 & UBU v1.79_4 latest edit Aug 5, 2020, use the manual insert file below

NVMe mod to run UEFI NVMe SSDs using module NvmExpressDxe_4.ffs dated 04/18/2018 manual insert via MMTool v4.50.0.23
All the rest is pretty standard ROM/EFI updates.

Enjoy your new NVMe capable modded bios with MDS/Meltdown/Spectre microcode updates.

BTW microcode v 28 fixes Microarchitectural Data Sampling (or MDS) side-channel vulnerabilities in Intel CPUs in addition to Spectre/Meltdown vulnerabilties.

As usual make a back up of your current bios and drives!

M6F.zip (5.27 MB)

M6F_manual_NVMe_mod.rar (4.8 MB)

was looking for this for months! I previously tried adding support for nvme but added the wrong module.
how does the updated microcode stack up against regular in terms of performance? I read that the fixes included with newer hardware took a big hit in performance numbers?

everything works fine after a bit of tweaking thanks!

The v24, and v25 microcodes do take about 5-10% performance hits.

The more mature v27 microcode is in the range of 0.5% - 1.0% performance hit, so you’re better off with the latter.


Cheers

Asus Max VI Formula MB modded via Flashback with the M6F.CAP bios but still no SSD in neither BIOS nor Win8.1.

IOCrest SI-PEX40110 NVMe M.2 PCIe riser card with Samsung EVO 970 Plus M.2 M-key 1TB SSD. PCIe slot is config’d in BIOS for GEN3 but is shown as “Empty”.

PCIe slot Device
X16_1 NVidia GForce GTX980
X16/X8_2 PCIe M.2 NVMe riser card (SI-PEX40110)
X4_3 ASUS Raidr Express SSD (uses Marvell console)

Attempts to load Samsung driver in OS fail due to device not being recognized. Riser card documentation is quite “limited” but it does have a green LED illuminated when the system is powered ON. Mfr states that the card is known to work for exactly what I’m attempting. What is interesting is that I want it to be bootable but even before the BIOS update it failed to show in both BIOS and OS. Perhaps the card’s little green LED isn’t revealing the whole story.

Hope you can shed some light on this for me…

@tocguy

Updated file M6F_manual_NVMe_mod found in post#1

To get UEFI loading the “Windows Boot Manager” in the booting tab set CSM (Compatibility Support Mode) to DISABLED.
Unhook all your other existing drives with only the NMVe adapter and SSD drive to do the first install.
If you have any MBR type drives, you’ll have to convert them to GPT (Gui Partition Table) drives and hook them up later when you’ve completed the first Win10 install. MBR drives won’t be recognized in a UEFI environment; thus the GPT conversion requirement.

What you should see is something akin to the following link at post #356

[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS (24)

All the hair pulling has been done for you about 5 years ago…

Ensure your graphics card is ..efi compliant otherwise your UEFI environment won’t load either…which should be a given using the GTX980.

I note that you’ve got some other drives in your third slot there, so that may be gumming up the process.

As always back up your important files before flashing!

Lastly, ensure you are using the correct Windows ISO which supports UEFI. Check the Rufus FAQs on this issue.

Cheers and much success!

Hello Hans,

Thank you for replying to this old thread. My system has been using UEFI for a very long time. To get the SSD on the PCIe card recognized I tried alternate PCIe slots, disabled CSM and Fastboot, ALL other drives physically disconnected, UEFI first ROM selection, but it still was missing from BIOS. After testing it in a X58 (non UEFI) system the card didn’t appear in Disk Mgr there either. So, returned the suspect card and am awaiting a card from different mfr’r.

In preparation for round 2, I’m reading something about needing to clear the Secure Boot keys but admit that it’s unclear to me just what that might have to do with the SSD card failing to appear at all in both BIOS and Win8.1. These guides have a great deal of detail and I find it a bit too easy to get lost following the bunny trails. I think the card is supposed to appear in Disk Mgr despite a BIOS having not been modded with NVMe. In such a case it is supposed to function as a data-only (not bootable) drive.

My Asus RAIDr Express (SATA SSD Raid) is getting a bit old and I’d like to replace it with the EVO (non-raid).

Anyway, thanks for the updated BIOS and for modding it for NVMe use in the first place!

Namaste

@tocguy on the X58, what was the OS? If it was Win8-Win10 then it should show up, if it was Win7 you need to install 2 hotfixes first before the OS can see the NVME

Secure Boot keys DO NOT need cleared for any reason to run NVME. NVME will not appear in BIOS of any NVME mod BIOS, only you will see "Windows Boot Manager" AFTER windows install to RAW then windows will make it GPT partitions.

Hello @Lost_N_BIOS ,

Thx for stepping in to assist me.

The X58 and the Z87 systems both run Win8.1x64.

I’ve been running my Z87 based Asus Maximus VI Formula UEFI system for eons and is the system in which I’m trying to install the EVO. This system’s OS is run from an ASUS “RAIDr Express” SSD raid device (SATA SSD Raid module uses PCIe 2.0 x2), is GPT partitioned and boots via UEFI as expected. Also, to be thorough it too was disconnected/removed in my testing to see just what, if anything, showed up differently in BIOS. NaDa.


Would you break down the above statement for me? My plan was to employ disk cloning to transfer the OS from the RAIDr to the EVO. In this scenario, I already see “Windows Boot Manager” due to the existing OS on the RAIDr. Obviously, I’m missing an important aspect of the process and would appreciate more insight or a link to find pertinent process guidance.

Thx

If your new adapter is on the way; check that you’ve mounted the NVMe SSD in the correct slot as well.
Notably, some PCIe 3.0 NVMe adapters have a number of SATA and NVMe slots in the M.2 form factor.
My own adapter has one NVMe slot and two SATA slots.
We’ve had one or two make this error, by not checking the slots closely in the race to NVMe booting bliss…

I hope that helps!

Cheers

Hello @hancor ,

This MB offers only 1 native M.2 and it is indeed SATA. It’s limited to 2242 size, X1 bandwidth and sacrifices a 6GB SATA connection when employed.

The new NVMe PCIe riser card arrived. It was immediately recognized in BIOS as PATA SS. So, previous board was indeed DOA. Device Mangler also recognizes it in both the Storage Controller and Disk categories. Likewise for Disk Mgr. All good there.

My new wrinkle is cloning the OS. My Acronis True Image 2014 backup app reboots to Linux to perform the actual cloning so then the EVO is not recognized. I’ll figure this out…eventually.

Thx again for the assistance. Much obliged.

Hello all of you, and thanks for letting me in your thread. I have my old maximus vi formula that need a bifurcation, so have installed a riser card ASUS Hyper M.2 with Samsung evo970 plus…
I have tried for some time to figure out hov to mod the bios with no luck. Just to be sure can you conform that it will work and tell what read /write speed do you get. I would expect more then sata-speed. I made the maximus viii impact run full speed on U2 to m.2 with adaptor cable. so it wood be nice if you can confirm what speeds you achieved and that riser card did you use. I maybe a little slow but better be safe then sorry.

Hi again and wait I have to get my hands down first.
Yesterday I succeeded in upgrading My sons Gaming PC asus maximus VI formula with some help from your directions in ths forum…:wink:
Although it was build in 2013 as new it has been upgraded several times. But now it was time trying booting on PCIe 3.0 x 4 (2.nd x16 lane) Nvme ssd installed in Asus Hiper M.2 card V2
With flashback from USB & ROG connect utility I succeeded updating bios to make NVMe M.2 visible in UEFI bios boot manager. Thereafter it succeeded installing iso widows image on M.2 by selecting windows
Boot manager selected boot priority M.2…:wink:
after restart it booted up and off cause needed some updates but that’s just fine. Later in the evening I handed the pc back to my son to test. Wow it is very fast responding and runs approx 6 times faster then before.
Right now I’m just a happy father, that enjoy the big improvement on my sons behalf due to this modded motherboard even 6 time faster then before due to bottleneck in regular SATA SSD’s…:wink:

Many thanks, You are doing a great job here…:wink:

@CBangs
This a very old thread without any input since August 2020 until your new request. This makes it rather unlikely, that you will get a reply.
Tip: You will increase the chances to get a reply from a user, who owns an ASUS Maximus VI Formula and has flashed the modded BIOS, by directly addressing them.
This way these Forium members will get notified about your new request.

@CBangs @Fernando

Q: Will the slot support bifurcation?
A: Z87 chipset will not support bifurcation. You need at least one of the “workstation” motherboards from this era to have a hope of it working.

Enjoy your new speedy BIOS/UEFI!

Cheers

Hans

Hi @Fernando and many thanks to you As well for leading me to the answer of my questions.
And sorry for not following the forum rules due to new in the forum.
As i told @hancar I knew the bios Mod would give approx. 6 x improvement and it really feels great to blow some extra life in a rather old system.
I is like having Porche only using up to 4th. gear and finely jumping to 6th. gear for the first time…:wink:

Thanks