[OFFER] MAXIMUS VI FORMULA BIOS 1603 modded for NVMe boot drive and EFI updates

Interesting model… does ASUS know that you have a “special” M6F…

Modified bios files will be blocked by security measures, a well know dilema in the mod community, using standard flash methods.

This will NOT happen when using USB BFB feature… so now you know how to proceed.

Guide for ASUS mainboards

1 Like

@MeatWar @Biggerguy

Updated & reworked file includes NVMeDxe5.Ffs file as of Dec 9, 2023.
Also ROM EFI network updates.
Updated file found in Post #1
Lastly Post #1 tells you the update method is by Asus Bios Flash Back

Cheers :beers:



Thank you. But my Maximus VI Formula uses the M6F.cap bios. How can I use that .rar file?

That’s because its a compressed file, which you need to decompress.
Try using the program WinRAR to unzip the file.
WinRAR archiver, a powerful tool to process RAR and ZIP files (rarlab.com)
Soon you will get to actually flashing…

Thank you again.

Fernando helped me years ago with installing a modded bios in Maximus IV Extreme and all these years it has worked perfectly.

Now I have this NOS (new old stock) Maximus VI formula and Im lost.

I downloaded the rar file and extracted it.


Are what was extracted.

I am not sure if my board actually has the Flashback utility outside of Windows, because the buttons in back are for CMOS reset and the other is for ROG connect.

Still I unplugged every drive, disabled CSM, inserted my USB drive in the plug directly under the ROG connect button. While the computer was off but plugged in, I pressed the button for a few seconds, released, and it blinked slowly, then more rapidly. Once it stopped and the LED on the USB drive shut off, I rebooted.

After all that I do not see the boot drive in the bios.

Please help.

Read steps 3 and 4… and all Additional Notes from step 3
[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

Hans buddy… i know what those files are… im also a Mac user :rofl:

1 Like

@MeatWar @Biggerguy

Here’s what you should see from the unzipped file:

Standard methods to update bios are found at pages 3-56 to 3-61 of your manual.

See post #13 which outlines the following:

With flashback from USB & ROG connect utility I succeeded updating bios to make NVMe M.2 visible in UEFI bios boot manager. Thereafter it succeeded installing iso widows image on M.2 by selecting windows
Boot manager selected boot priority M.2…:wink:
after restart it booted up and off cause needed some updates but that’s just fine.”

Edit: If you RTFM at page 2-15 you would find the following:

Good luck! :face_with_monocle: :innocent:


Edit #2 Under BOOT TAB Secure Boot setting in your BIOS set the following:
OS Type [Windows UEFI Mode] save & reboot

Recheck that your M.2 drive is correctly mounted & your adapter card is properly seated in the PCIe slot.

Thank you again. I followed all your instructions yet I still do not see the M.2. (or boot drive) I tried inserting the adapter into a different slot and that made no difference. This M.2 and adapter was working and installed in my previous board.

This is what I see:


Next lets ask what M.2 PCIe X4 adapter model you are using & also which M.2 SSD type, model, capacity?


Thank you for the fast reply. Well I believe I discovered the problem.

Using a cable adapter I tried to use the native M.2 adapter with this NVME. It did not work obviously. Apparently that also destroyed the M.2.

I took it out of the adapter and saw this :confused:

1 Like


Most likely a dead SSD, so you’ll have to go out an get new one! :disguised_face: :face_with_monocle: :pirate_flag:

Cheers :beers:

Would the M.2 NVME drive work in the M.2 NGFF slot of the mPCIE Module II once the bios is modified? Would it be a good choice if it did? Or stick with using a PCIE adapter card?

I want the best speed and performance but if I am not mistaken using the PCIE card will slow down the lane for my GPU from x16 to x8.

On the other hand, the mPCIE Module shares a SATA connection, such that if one uses an SSD there, you cannot use the #5 SATA connection since it will be disabled.


Above is your mobo PCIe slot diagram. One could run the M.2 through one of the PCIe X1 2.0 slots, but you just cripple the speed.

The logical slot would be PCIe 3.0 x4_3 slot, as one maximizes speed of the boot device, without crippling overall performance.

I’m going to assume you’re not running an Asus NVidia RTX 4090 Gaming OC card with a 42" PG42UQ monitor at native 4K resolution like myself. :sparkler: :fireworks: :partying_face: Running any 1080p or 1440p monitor over a PCIe X8 slot should be plenty with any PCIe NVidia graphics card 3080 & up or AMD 7000 series. Given one can run most of these at 120Hz, 144Hz, 165Hz & 240Hz it will be more than adequate for gaming, video, audio tasks. Even in Hackintosh land you’ll be plenty good for a while.

BTW what is the exact mPCIE Module II adapter gear you are proposing/using?

Cheers :beers:


1 Like

Thanks for the response Hans.

My GPU is an RTX 3070.

The mPCIE Module II is one of the OEM components of this board. It supplies Bluetooth connectivity on one side and the other side has a slot designed to fit a 42mm M.2 NGFF.


Given that the board would 1/2 the speed on mPCIe Combo II as it runs on PCIe version 2.0, the PCIe 3.0 slot #6 would be the way to go.

IE get a M.2 NVMe PCIe X4 adapter card as it will run appromimately 3400 MB/s - 3600 MB/s with the modern SSDs.

Cheers :beers:


1 Like

I think the mini PCIE 2 is just the Bluetooth/wifi side. The M.2 side uses SATA 3.

It’s a strange little device.

I do know that before I did the bios flash, I inserted the nvme via an extension ribbon, and my ssd got fried, I dont know if that was due to hardware or software. My new one arrived today, I don’t know if I should risk it again.

Asus info:

mPCIe Combo II

with 802.11ac/Bluetooth 4.0

Extra connections with M.2 (NGFF) support

The next evolution of the mPCIe Combo card gives you even better expandability with the latest standards in connectivity and easy install. You get mini PCI Express 2.0 plus USB 2.0 with an included dual-band 2.4GHz/5GHz Wi-Fi 802.11ac and Bluetooth 4.0 module, powered by ASUS-exclusive Wi-Fi GO! Remote and Wi-Fi Engine, which maximize performance for better experiences. It’s an instant upgrade to the fastest wireless right on your desktop. All without having to sacrifice a PCI Express slot!

The compact but versatile mPCIe Combo II further future-proofs your build with M.2 (NGFF, Next Generation Form Factor) connectivity for SSDs. M.2 is a fast and power-efficient standard that aims to replace mPCIe and mSATA, designed to optimize SSD performance. mPCIe Combo II works with your high speed M.2 SSDs and makes the most of their potential, helping you reduce load times to run your OS and games even faster.


I only saw a confirmation (Kingston) of an PCIe NVMe disk on the Asus mPCIe Combo IV (Z97).
Till today i never bumped into any confirmation for any other the mPCIe Combo card older than the IV.
I would not risk it and would follow Hans advice on last PCI slot.


Ditto @MeatWar @Biggerguy

Of course the combo PCIe 2.0 slot was only intended for wifi gear & and not a full blown M.2 NVMe drive which will run at 1700 MB/s to 1800 MB/s; essentially half speed.

IE get a proper M.2 NVMe PCIe 3.0/4.0 X4 adapter card as it will run appromimately 3400 MB/s - 3600 MB/s with the modern SSDs.

A little Christmas cheer & advice :beers:
Frohe Weihnachten! :santa:

Hans Rupprecht

1 Like

Hello again. I have a new problem which may or may not be due to the modded bios. The CPU temperatures are inaccurate. In the bios it shows a temperature of -65C. In Ai Suite III it also shows negative values. I downloaded HWMonitor and can see the temperature of the individual cores (i7- 4790K) as accurately fluctuating (around +23C), but under the Asus section its not negative but doesn’t seem to be very accurate either since under stress some individual cores go up to +64C degrees, while the Asus reading shows the CPU temp at never going past +57C.

The problem with all this is of course the fans wont spin up to mitigate the heat because it thinks the CPU is below freezing. While running CPUID stress test, the temps as read by the motherboard go as high as -10, still below zero freezing…which is not physically possible.

Any ideas? I might try reinstalling the BIOS, maybe something didnt install properly? Or do I have a defective board?

I remember this in my old Intel 7 Series motherboards mods… can’t recall specifically the issue but, the mods had to be re-done… i do remember that there was something touched “too much” :boom: with AMIBCP, but can’t be sure, wait for another user opinion.

1 Like