[OFFER] MAXIMUS VI GENE BIOS 1603 modded for NVMe boot drive and EFI updates

Thanks for the update, system boots normally and everything seems fine, i’m using a 2.5" SSD as a boot drive now cause I moved the M.2 nvme drive to another system. Thanks again for your help :slight_smile:

Thanks, it works :slight_smile:


Delighted that it is working for you!


I no longer own this board sorry but the previous mod was still working flawlessly


Thank you for the information. Is the attached MG6.CAP file already modded? I do see the NvmExpressDxe file in MMTool but I am still having difficulty recognizing or booting from the NVME after seemingly flawless BIOS flashes.

…backstory: I have a Sabrent Rocket NVME PCIe M.2 2280 SSD installed in the second PCIEx16 lane on my Asus Gene VI mobo. My initial BIOS mod and Windows installation via the instructions went well and I was running on the SSD with expected speeds. However, before restarting/booting from only the NVME SSD, the PC BSODed and now I cannot get the BIOS to to recognize or boot from the NVME. Do I need a Samsung SSD or is the Sabrent okay? Any help is much appreciated!


Most up to date modded file is found in post #16 of this thread.

Remember to set CSM(Compatibility Support Module) to DISABLED in your BOOT TAB.

Also unhook ALL your other drives, when doing the first OS install.
Further, when you rehook up your other drives you may have to convert them all from MBR drives to GPT (Gui Partition Table) otherwise they won’t be recognized.

To see why MBR and GPT drives don’t play nice together, and what you should see with “Windows Boot Manager” see post #356 in the link below!
All the hair pulling has been done for you…

[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS (24)

I’ve used the Samsung NVMe SSDs 950 Pro without issue now for well over five years installed in an Asus Z87-Deluxe.

I’d recheck your drives to ensure you’ve converted them all properly to GPT otherwise you won’t be booting off the NVMe drive.

If all else fails, reflash and do a clean install!

Let us know how it goes…



Yep CSM is disabled (I also tried it with CSM enabled according to Fernando’s guide). No other drives were/are attached (never reinstalled them). The initial install was GPT according to the guide. I have tried re-flashing but the NVME is still not detected. Furthermore I cannot reinstall windows onto the NVME (drive is not detected during install), nor can I see the NVME drive using the command tool diskpart (via the windows install boot drive). The system boots fine if I reinstall my SATA SSD. What am I missing?


you may have a bad NVMe drive…time for warranty replacement?

Thank you very much for your contribution, it really helped me a lot, I can now boot my PC from the nvme disk, can I share it obviously respecting its copyright?

1 Like


Latest update in post #16 with NVMeDxe5.Ffs insert and network ROM EFI updates.

LATEST EDIT: Dec 20, 2023

Cheers :beers:
Frohe Weihnachten! :santa: :innocent:

1 Like

Gracias amigo, desde México ¡feliz navidad y extraordinario año 2024! gracias por tu ayuda a revivir nuestras motherboards antiguas, ahora trabaja súper rápido y pues tiene más años de vida, un abrazo.
Edit by Fernando: English please!