[OFFER] Modded BIOS file of Asrock H77 Pro4/MVP Motherboard to support NVMe drives

Hello, I have modded the BIOS of Asrock H77 Pro4/MVP to successfully boot from NVMe hard drives. It works like a charm. The BIOS file is the latest, but beta version 1.80 for this board. I am uploading it here, in case someone needs it:

asrock H77Pr04MVP 1.80 Modded BIOS.rar (4.18 MB)

Thank you for your work, but the instant flash is not finding the file on my USB drive. Any suggestions?

@Ullms - After extraction, rename to exact stock name.extension if it’s not already. If it is, can you see stock BIOS on your USB? If not, try another USB, USB 2.0 is usually best for this, formatted to FAT32, BIOS files NOT in folder.

Tried the renaming but still didn’t find it. And yes a stock bios file does work with the USB drive.

@Ullms - Can you see .txt after text files names, so you can see file extension names? If not, you need to enable this in folder options, in view tab, uncheck “hide extensions for known file types”
If you do not have this enabled, then you will not be able to change the actual (Non) extension name. If you need me to do for you let me know.

The attached file does not even have an extension, and it has a space in name, both bad for Instant Flash. Please fix this @astral_projection - thanks

File should be named >> H77P4MV1.80

That is exactly what I named the file H77P4MV1.80. yes I can see the extensions.

Then it should be visible, try another USB stick, or another USB Slot in rear. If you want me to make you a fresh mod to test I can, but it’s not ideal to do in another users mod BIOS thread, lets wait for him to reply so he can check the file he’s uploaded here to confirm it’s OK.
Or send me a PM if you can’t get it and he doesn’t reply back soon, I will make you fresh mod BIOS.

I’ll try another USB stick, and I did tried from the back port as well. No go. The BIOS does detect the USB stick and scans it for the BIOS file but doesn’t find it. It does detect any stock file I put on the root of the USB stick. It must be something wrong with the file.

@Ullms - Should always be from back port, but I guess maybe sometimes front one will work. Since you can see stock BIOS, then you should see mod BIOS too, so sounds like USB and USB Port being used is OK
OK yes, maybe something wrong with file? I will send you PM Then, if that works, we’ll let astral_projection know BIOS is broken here

Hello, I just changed then ame of the BIOS inside the uploaded file, but as you mentioned it doesn’t work, I tried to put it on a flash drive just to check, but I didn’t work for me now either, I am not sure what is wrong, but I modded the BIOS file a few month ago and didn’t have any problems updating it, so decided to share it in case someone needs it. Sorry it didn’t work, I guess you should try to do it yourself following the guide

@astral_projection - Thanks for confirmation of issue with the file on your end too. I already send him new mod BIOS, once he says all OK I will send to you as well, in case you need later
I’ll leave this thread here for now, if you want me to delete once we are done let me know. Or you can make new mod BIOS and attach at post one, after you test and confirm it’s OK and working