[Offer] Modded BIOSes for all ASUS Z68+P67 MBs (NVMe+Microcodes)

Thank you so much for this! The P8Z68-M Pro bios worked perfectly for me!

2 posts were merged into an existing topic: ASUS P8Z68-V-PRO version 3603

I’ve a P8Z68-V motherboard bios ver. 3603 (latest available), with CPU Core i5-2500K averclocked to 4,4 Ghz ,which has been working without problems for at least 10 years. I’ve bought a PCI-e NVME adapter and installed some time a go a Crucial NVME SSD used only to storage purpose.
I’d like to install modded bios to allow booting from NVME but I fear the risk of not being able to make the motherboard work.
Someone has already tested an upgrade with modded bios with this motherboard?

hello guys, did anyone test it on a sabertooth p67? That is my motherboard, it is updated to the latest version of the official bios, now it is working with an SSD disk and it is incredible, but I really want to install an NVMe :pleading_face: and I am afraid that my motherboard will die :pleading_face::pleading_face::pleading_face: I already downloaded the bios modified and also the original just in case, any advice can you give me? I have already read all the pros and cons, also as it should be done and the comments of everyone in this thread, the majority have positive comments and that leaves me calm :innocent: many thanks to whoever modified the bios for our beloved motherboards, and thanks for any advice you can give me :hugs::hugs::hugs:

Welcome to the Win-Raid Forum!

You can “install” (better: insert) the NVMe SSD and use it for storage purposes without having flashed any modded BIOS (provided, that you are running a Windows OS with a matching NVMe driver). This way you can avoid the risk of a bricked mainboard by flashing a modded BIOS.
The only disadvantage of it will be, that you will not be able to boot off an NVMe SSD.
Good luck!

Thank you for your opinion, but the idea is to start the operating system from the NVMe, it seems incredible to me that no one has tried with a sabertooth :thinking: I’m getting the courage to use the modified bios :face_with_hand_over_mouth: if I do I will tell everyone what resulted from the attempt I hope everything goes well :innocent:

My slogan: No risk, no fun!
Good luck!

1 Like

It worked and I succeeded with my NVME disk on my P8Z68-V LX!

Steps I took

  1. download nvmeP8Z68-V-LX-ASUS-4105.zip and flash it with Asus EZ flash. I didn’t update the Intel ME.
  2. Plug my M2 into a PCIE convert card and plug it into PCI 16x slot
  3. Power up the PC into old system, initialize the new M2 disk in GPT. Then use Aomei Partition assistant to do system transfer (from my Sata SSD to M2 disk)
  4. Power off the PC, unplug the Sata SSD to avoid confusion. Boot into bios. I saw a new boot option called "Windows Boot Manager (GLOWAY…). It was probably added by Aomei. Otherwise you should see something like “PATA SS:”. Anyway, choose the new one as your first boot device and voila. The system booted without problem.

The speed test is 1159MB/S read and 1400MB/S write. I think that’s as far as a PCI-e 2.0 x 16 can reach.

Thanks for all the contributors. You’re the best.

Your welcome, new users need “forum activity/reading” to gain trust level, after that the system will allow posting/attach files.
In Z68 only with an IvyBridge CPU can achieve PCIe 3.0x4 with the NVMe on 1rst x16 slot only.
Enjoy it.

Still a problem after some days of using: the default booting device cannot be persistently set to NVME disk.

When I boot my computer, it is halted at a black screen saying no mgr record is found, please reboot and choose another device. I went to bios and saw a boot option called “RTK”, like in “1”

OK, I set it to my NVME like in “2”

Press F10 to save and then the PC booted into my windows. I shutdown my PC, powered up again into bios to make sure it stays as shown in the second picture.

The problem is: after powering off my computer for a day and trying to boot again, the RTK comes back and the PC halts at the black screen.

So I either have to set the bios again, or better yet, hit F8 when booting to select the NVME disk every time. But I still think it’s a workaround and I really don’t know where the “RTK” options comes from, since I can’t seem to find any explanation on this.

How’s CMOS battery voltage, replace it if below 1,7v
Have you any clue of any device in your system with those RTK words?
You can try to manually redo the mod yourself instead of using shared file mods

EDIT: Well… i cant remember seeing in this forum a user with such boot entry…RTK

I was thinking the battery is low, yet other bios settings weren’t reset.
No other devices are bootable, so I don’t know where the RTK comes from.

Found the culprit: my USB WLAN card. The card is based on realtek WLAN chip (hence the RTK notion). And by default, it emulates a CD drive containing drivers for older windows system or Linux. And when it’s plugged, it was read by the computer bios as a boot device.
So for now I just unplug the card to boot normally, then connect it back after Windows loads.

This behavior happens only after flashing the modified bios. So maybe there is some connection.

The mod also finds that the RTK(L) device has a built in x64 EFI boot…

So tell me something… with the device unplugged there is no other EFI boot devices in bios boot manger, only the NVMe windows device, so when plugged you cant change this priority or you can but the bios doesn’t store the settings and returns to default RTK priority device, correct?

When the RTK card is unplugged, there’s still a “Pata SS:” shown as a boot device. But I think that’s what the hack does to make the bios recognized the NVME?

Anyway, the Pata SS: wouldn’t place it back to top once disabled and F10.

Usually if the PATA_SS is still visible, means that your NOT booting in PURE UEFI environment (CSM OFF), you’re using CSM ON or AUTO, as is stated in Fernando’s guide (for most of mboards behaviour) on step #3, Additional Notes, read it.

I do recommend a clean OS installation in a PURE UEFI environment, with ONLY the NVMe disk attached to the system, later plug in any additional disks, for the best system performance, when ever possible (requires also a EFI GPU compatible device).

1 Like

Installed modded BIOS an my P8Z68-V, Pcie card with NVME SSD istalled on secondary 16x Pcie slot, correctly boot SO and works at a quite decent speed ( about 1200 MB/s) but I’ve some issue when I make some changes in BIOS: often, when I choose to save changes and reboot (even pressin F10), nothing happens, all is freezed. I need to press reset button to make system to restart and changes seem to have been saved…

Hey do you still have this? I have a 2700k so need the first link. Thanks

1rst link of what… the links in the OP is not my posting.

EDIT: Nex time point the post number… or do you think i live just looking indefinitely to that post or its my only post on this forum???
The link is up.

Sorry I thought I quoted your post. New to this forum. I was looking for the modified nvme bios for the p8p67 ws revolution you posted to pCloud. I have a 2700k so the one with sandybridge still in it.