[OFFER] (MS-7917) MSI Z97 GAMING 5 v1.D0, 40671 µCU 0x22, 306C3 µCU 0x07, IRST 14

Hi, this is a modded BIOS with Haswell microcode 0x07 so you can run locked processors at max turbo bins even when Windows10 mcupdate_genuineintel.dll loads at OS start up. Set CPU ratio in BIOS to max multiplier, save configuration and exit and it will persist even when in Windows running the latest microcode. You gain the benefit of faster clocks on locked CPUs and also the speedups provided by fixed errata over time. KB4589212 is the microcode update for Windows 10 20H2 for the OS to load 0x28.

@Lost_N_BIOS please enable Above 4G Decoding on this BIOS. Thanks in advance.

E7917IMS_1D0.zip (5.89 MB)

@platinum4 - Thanks for quoting back my PM, please show me image of this BIOS Page >> Advanced >> PCI Subsystem Settings
Use F12 to screenshot to USB, then put that in max compressed zip, thanks


It’s this exact screenshot it hasn’t changed ever:

Thanks, what do you mean “it hasn’t changed ever”?
* Edit - Ahh, so I see, you need hidden advanced, this is the limited one. I will have to do full menu swap-in with another item, that can take hours sometimes, are you sure you need this setting visible, or can I just change it to enabled for you?

*Edit 2 - moving to correct subforum

@Lost_N_BIOS I am OK with not seeing anything visually but just making sure Above 4G Encoding is Enabled

OK, good, I can enable for you no problem!
Watch this space for edit

* Edit - @platinum4 - It was already enabled at both NVRAM locations, so may (read should) already be enabled after you flash stock BIOS and load optimized
But, you’d have to dump your live current NVRAM for me (BIOS region with FPT) if you wanted me to check that for sure, but in stock BIOS it’s set to enabled there
It’s disabled at setup and AMITSE/SetupData though, which I changed, but system uses NVRAM value so it should be enabled by default unless first save you make in BIOS disables it?

@Lost_N_BIOS when I inspected this (my BIOS that I wanted to use) with AMIBCP 4.55 I saw Above 4G Decoding Disabled by default. Based on my experience with Code 12 on the ASRock I did not try enabling and flashing.

@platinum4 - In the BIOS I posted at #6, it’s enabled by default everywhere now
Don’t rely on experience with other board, not all board/BIOS are the same, test it here and see what happens.


I am already mining with 6 GPUs on this board without a problem, given the problem I received with the ASRock enabled I think I will pass on doing that, these are not the results I had expected.

Outcome may not be same here.

@Lost_N_BIOS I flashed it and I lost the ability to see the BIOS screen but when I boot into Windows and view it on a remote session it shows up OK without any Code 12s; how can I get the BIOS to be viewable again?

@Lost_N_BIOS I was able to flash an older v1.C0 via AFUWinx64.exe /P /B /K and then I ran MSI LiveUpdate and flashed a stock BIOS. My problem was I flashed a BIOS I modded, not your BIOS. That one still provided a screen. I however lost my SLIC activation on your BIOS.

@Lost_N_BIOS are you changing more than 1 setting outside of Enabling these in PCI Subsystem?

@platinum4 - I only changed what I mentioned, nothing else would be changed. I did use stock BIOS though, so if you used some SLIC stuff, you will need to redo that, then if BIOS broken again it’s due to your SLIC edit.
Little confusing there about the screen!? My BIOS is fine, correct? Only some BIOS you edited you can’t see screen?

Hi, yes, I have this all resolved and the motherboard is working but it appears to be no different than before; I am unsure if there was going to be a difference but it allowed me to learn a bit and see. Thanks for doing this and in the future on an older board I may ask you once more. @Lost_N_BIOS

@platinum4 - Good to hear all is sorted out now! Sure, no problem about future edit, just let me know