[OFFER] MSi Z68A-GD65 (G3) Bios Mod (fully updated)

Well it’s (cmiiw)
UEFI GOP = the Graphics Output Protocol driver for the igpu
Realtek OROM and DXE = the ROM driver and DXE driver or realtek to be able to operate on uefi or legacy/csm
mCode = microcode, i put the best microcode for overclocking.

if you need the latest microcode i might be able to replace it, also the realtek orom and dxe is abit outdated, but it was on purpose because when i try to save any settings it just wont save, return to an old one and it worked like a charm, but if you want to experiment, i could replace the modules to the latest version 2.70 OROM and 2.066 UEFI, as per now i didn’t have the board as it is broken internally, due to age i guess, but yeah that were my discoveries back then.

1 Like


hello, thank you for your answers.

So my mb has always had a curious problem, it does not accept in any way to boot from hdd/ssd if it is set in ahci mode. It only works in ide. I had read at the time that it was a bug. Never fixed perhaps. Or is it my sample that doesn’t work.
Day before yesterday, I got the nvme adapter and plugged it into the pcie, and windows10 was unable to see the drive, I had a driver that I tried hard to update to see if it worked, but to no avail. I removed the adapter.
I was reading here on the forum that at the very least, it should see it as a non boot disk.

I saw that on the msi site, you requested the latest firmware available for the platform. I was thinking if I used that firmware version, modded with the nvme drivers, will I be able to boot the drive? starting with the drivers of the version I currently have installed, without downgrading.
I would like the safest possible procedure because I don’t want to break the motherboard.

I’m seeing a lot of videos talking about it, I’ve also seen videos where they use an alternative bootloader , clover.

What are your thoughts on that?


I vaguely remember that it was an issue to me too, but i used the latest bios (which i mod after) and latest beta bios, i could let it work on ahci mode… Seagate barracuda 1TB (old model from 2013 i use till today, formatted into GPT and did a clean install with my 850 Pro (both drives are gpt) ), and team mp34 i tested just before the board broke down.

You could maybe try to use either of both bios mod to see if it’s working or not.

But i want to ask you this, is your gpu UEFI compatible? I remember having a hard time to figure out which is which, but i am able to use full uefi and ahci mode on the board as far as i remember, or maybe auto? I kind of forget about it… Sorry :pray:

1 Like


my gpu is a 1060 extreme , i was wondering but after how long did your mb break down? wasn’t the beta bios to fault?

I would still like to use this PC as a mule :slight_smile: when I decide to buy another one. I am attached to it. At the moment it is also giving me problems with a new ssd from crucial, since I installed it it gives me continuous bsods.

As soon as I try to enable ahci, it won’t boot.

(both drives are gpt)

part of the problem is that if I format in that way, the system does not see the drives. Not even USB sticks.

My plan would be to use the latest beta bios, or perhaps the 25.8 I currently have, with nvme drivers and see if it finally recognises my m.2 drive

It was on 2022, probably 3-4 month after i post this, and no the beta bios is perfectly fine, in fact i ran the beta bios XD.

I suddenly remember that it happened due to the Marvell sata ports is in fact the problem (wont do AHCI). You could disable the Marvell sata port (i forgot which option is that, maybe Settings → Advanced → Integrated Peripherals → External SATA). the thing is, that marvell sata port causes it. When i disable those, i am able to launch AHCI and Full UEFI.

1 Like


your memory works fine, in fact the marvell ports give problems so much so that I have not connected any drives to it. Going through the logs with bluescreenview I found that it always points to the marvell drivers, I tried to find drivers every which way, but nothing, the problem remains.

If it is possible to disable it I will do so, to see if that solves part of the problem.

Maybe before modding the bios, I could try following a tutorial to try to boot the drive using clover.

Did the m.2 drive work for you before modifying the bios? Could you see it in Windows Explorer? Could you use it as a storage drive?

Yes it could, as both a boot drive and a storage drive, but it was pre formatted as gpt since i gpt everything for big storage. Tested the drive on my personal pc (it was B560M Pro) and it is normal, tested it on the Z68 and it could be seen, no special drivers installed, just PnP, but i forgot if it was put on the x16 slot or the slot underneath it. The thing is, i disable marvell, i enable ahci and i vaguely remember there is no csm/uefi option in the bios, so i install secure boot keys and enable secure boot to make sure it is pure uefi.

tl;dr: Yes it work, bios set to AHCI, Marvell disabled, Secure boot installed and enabled, drive at GPT.

1 Like


I have done

disabled the useless and harmful marvell

Now if I look at the options on the other ports it also gives me raid. Before it would write me 2 times ahci. I have bios 25.8, the one before the beta.

i forgot if it was put on the x16 slot or the slot underneath it.

it was definitely the x16 because the slot below is a normal pci, while the slots above are all covered by the vga

if i leave it in ide, and connect the m2 disk formatted ntfs, should windows see it?

I searched the entire bios but could find neither the option to disable secure boot nor the other for fast boot.

maybe try to set this:
Sata Mode: AHCI
External Sata 6GB/S: Disable, Save and exit, go to bios again and see if your drive is listed.

Proabably. Or maybe you could try to convert the m.2 disk as gpt, then format it as usual.

1 Like


no. it did not go well. installed the disc, and enabled ahci


restarted the machine and set everything in ide again, as soon as I entered windows everything crashed


bsod error


I removed the extra drive and restarted the machine.

It seems to be more complicated than expected.

You cant boot old OS installations after changing to AHCI…it can but it may be difficult to change it manually for an inexperienced user.
Do a clean OS install if your changing the mode to AHCI for HDD/SSD or NVMe boot, other than that stay as before in IDE mode.

You already bought the NVMe adapter so when changing the system to NVMe boot, you clearly going to do this. I do not advise any OS cloning.

EDIT: The BOSD are port driver issues and i dont know what driver you used, the system has to boot with the default MS OOB drivers for SATA, im sure you dont want to lose time on old OS…

Do please read careful the guide, when decided to migrate the system to NVMe boot.

1 Like



the first windows installation was done in ahci mode, and in the following days I started having a lot of problems and bsods. I know it is possible to convert partitions from windows, with some program or some command


Do you have your windows installer at GPT + NTFS or FAT32? Probably need that first

So, reset bios to default, then save and exit, go to bios again, enable AHCI mode, disable External sata 6gb/s, save and exit, and on windows installer after it boots, press shift + f10, type diskpart and enter, type list disk, enter, type sel disk x (x = number list the drive you want to install windows) and enter, type convert gpt and enter (this will reconfig the drive as gpt), and after it finishes, continue to install windows at the drive, and let it finish.

This is a clean install method, speaking in which the drive will be formatted and configured as gpt, and ntfs format again after it is done.

1 Like


the disks are mbr + ntfs none are gpt formatted, the system does not start with that type of formatting.

I should therefore reformat a disk in gpt, and then prepare a windows installation stick in gpt format. Before installing everything the ports should be set in ahci.

To convert the disk I can use EaseUS Partition Manager, without any data loss, so I wouldn’t even need to reinstall windows.


Do please read careful the guide, when decided to migrate the system to NVMe boot.

I am going to read it again. There’s probably some part I didn’t understand.


@Koekieezz @MeatWar

Hello everyone,

I am writing to seek your help again.

After what has been said in the past few days, I have set everything in ahci. In the bios and under windows. I have been using the system this way for a few days now to try it out.

In previous conversations you told me that if you connected the m2 drive, before modifying the bios, it was seen by the system as a storage disk. Is that correct, or have I misunderstood?

The problem arises when I connect the m2 disk with adapter to the pcie.The disk is not even seen by the system as a storage disk.
Windows does not start , it goes directly to bsod or it starts and after a few moments on the desktop bsod again.I can start it in safe mode, but the m2 drive does not appear in any way, not even in disk management.


these are the errors it gives me at bsod



I have searched in the bios to see if there are any options I can enable/disable, but I can’t find anything in particular.

intel rapid start tecnology disabled
intel smart connect technology disabled
AHCI intel sata enabled
External Sata 6GB/S disabled
SATA Controller not set to “RAID”

is it a motherboard problem? or windows again? does the disk m2 have to have some kind of special formatting? i left it as it came, so ntfs.

thank you for your help.

Is the windows clean install or not? Like did you done a clean install on the nvme only? So bios settings necesarry has been set as per what you said, windows installer on gpt (if you use rufus, before burning the iso set it to gpt), then install it on the m2 ssd after the ssd been converted to gpt? TL;DR: SSD formatted to gpt + windows installer on gpt? And you do sure your nvme is not faulty and/or the adapter not faulty? NVMe drives usually appears on Storage Controllers instead of IDE ATA/ATAPI Controllers list.

AFAIK Yes i did plug the nvme + the adapter, preformatted it to gpt before using it on that z68 of mine (was)

If you do need the driver (well it might not affects it at all since this is sata drivers), try this . Chipset driver use this, and ME driver use this.

Im pretty sure you do know how to install .inf drivers through Device Manager.

And please re check, if you did everything and every setting in the bios, after you save andexit enter the bios again and check wether the settings you’ve changed reverted/unchanged or changed, if it’s changed as per what you did set, then it should be ok, just do another save and exit.

If you do plan to clean install everything, make sure to re download the windows of your choice .iso, use the latest rufus and set the installation to UEFI + GPT (no CSM), burn it to your flash drive, when you boot to the windows install bootable you just made with rufus, Shift + F10, diskpart, list disk and sel disk x (x = your nvme in the list disk lists), clean all (this will nuke the entire ssd, usually clean is enough instead of clean all), wait a bit till it finishes, then convert gpt, wait till it finishes, and after it finishes proceed to install windows using custom option → choose the uninitialized nvme (not even formatted to ntfs, just gpt configured), install but dont forget to disconnect the internet, then go to windows, install the Chipset Driver → restart later, and ME Drivers (AHCI Drivers are optional) i gave, reboot, and you’re good to go to install any drivers, the point is after installing windows do not connect to internet untill chipset driver and ME drivers are installed and did a good reboot, so that windows update wont mess with your installation.

1 Like


hello, thank you for assisting me again.

After reading everything you’ve written I decided to give it a try and create a stick with clover. I’ve been running various tests for 2 days.

Here what happened

I managed to start the m2 disk via external bootloader.

Now that I know it is possible, I would like to ask for your help in preparing a ready-to-install bios so that I don’t have to use the bootloader.
Do you think it is possible to switch from the bios I currently have installed, 25.8, directly to the newer version without having to do many downgrades?

among other things, i would like to install the modded version on only one of the firmwares, so that in case, the other one can recover by itself if something goes wrong.

thanks for your help

The “downgrades” you mentioned is only necesarry IF you do want to update the 2nd bios chip, since the stock bios on that 2nd chip are usually sandy bridge bios, unless you do know that the 2nd bios is alrd ivy bridge and you do use ivy bridge, otherwise, you could just flash the same modded bios or the P93 (25.9B3) bios, didn’t i told you abt this before?

1 Like



is there any way to know what’s in the two bios? i couldn’t find anything in the user manual. Going to look in the bios the situation is this

I think I understand that with auto update disabled, the bios does not copy the different bios versions to each other, or perhaps it does not update if one is corrupted.

you could just flash the same modded bios or the P93 (25.9B3) bios

what’s different in the new bios? just bug fixes or new functions? by the way, I have searched all over the bios but cannot find an entry indicating secure boot, is this a problem?

thanks for your help

Yes there are minor bugfix

Sorry i dont quite understand what you’ve meant, did you mean how to know what’s inside/what bios ver is the 2nd bios? Well one way to find out is to purposely corrupt the main bios, not recommended unless you understand the procedure to update the 2nd bios, which i have posted above.

1 Like