[OFFER] Various Gigabyte Z170-HD3-DDR3 BIOSes with Coffee Lake support

@Semil24 No, there is no way to overclock baseclock above ~102.7 MHz on Kabylake or Coffeelake. If you actually do mean FCLK (System Agent Multiplier, it controls the speed in which data is passed from the processor to the graphics card), it is already at 1,000 MHz at boot on the F2x BIOS from Gigabyte and you generally want to lower it as you raise baseclock.

Thanks for clearing that up, and thank you for the Bios!

The bios You created will support an i3 8350k too? I guess the mobo can take that easier since it’s a 7 phase, and those seem to bee good to OC.

@Semil24 No, 8350k requires different microcode (CPUID 906EB).

Could You please give me a copy of a bios for the i3 8350k if You have it already made, I ended up with that cpu on a discount.

I modified the bios already provided by You, as I assumed it has already all the patches, I just changed the microcode to 906EB will that work like that?
If I understood correctly the i3 8350k does not even need pin blocking is that right?

@Semil24 Sure, here is the F23f BIOS with both 906EA and 906EB microcodes added, nothing has been removed so this BIOS will support;

506E3 Skylake
506E8 Kaby Lake ES
906E9 Kaby Lake
906EA Coffee Lake (U0 stepping) Requires pin mod
906EB Coffee Lake (B0 stepping) Does not require pin mod


This BIOS can be flashed with Q-flash, make sure that you do a complete flash (use the ‘intact’ option IIRC and not ‘Fast’) or the ME Region will not be downgraded.

Hi, @chinobino sorry to bother with my problems… So the i3 I ordered did not arrive, so I reverted to the plan on using a I5 8600k. But still dont have it. In the meantime I tried to flash the modded bios just to verify that it works and it works with skylake. Problem is I can not downgrade back to F2c bios for Bclk OC. Actually the old bios got flashed and it works, I removed the CMOS batt but it seems the Intel ME stayed the newer one so OC still not working…
Could You tell me how to downgrade?

@Semil24 You can use EFIFlash to downgrade ME.

You will need to copy it to a DOS bootable USB stick to use it.

I was using the FPT tool from a dos usb stick to flash the old bios. Was it not flashing both bios chips? I even tried to flash the bios with FPT, emmidietly turn off and copy the primary eeprom’s contents to the secondary with a CH341a programmer. But no luck.
I will try with EFIFlash thanks for the support!

I flashed now with EFIFlash and the same happened. The bios version is f2c but as soon as I go over 103mhz bclk no boot.

@Semil24 What version of ME FW is on the motherboard?

Have you overclocked your Skylake CPU using baseclock before?

If not, you will need to set the BIOS up correctly and disable some settings.

1. M.I.T. → Advanced Frequency Settings → Advanced CPU Core Settings;

CPU Clock Ratio - Set MANUALLY to the maximum supported by your CPU at default speed, not Turbo speed
Uncore Ratio - Set same as CPU multiplier
Intel Turbo Boost Technology - Disabled

CPU Enhanced Halt (C1E) - Disabled
C3 State Support - Disabled
C6/C7 State Support - Disabled
C8 State Support - Disabled
CPU Thermal Monitor - Disabled
CPU EIST Function - Disabled

2. M.I.T. → Advanced Voltage Settings → CPU Core Voltage Control

CPU VCore - 1.35 V

3. BIOS Features

Fast Boot - Disabled

4. Chipset → Internal Graphics - Disabled


5. M.I.T. → Advanced Frequency Settings

Set CPU Baseclock to 105 for testing then save and reboot

Wait for motherboard training it may take longer than usual, if it POSTs ok then you can try to set RAM XMP to Enabled, note that baseclock overclocking increases RAM frequency.

I actually was overclocking my i5 6500 ,it was running 4.3 ghz 1.27v.
How do I check the ME version?

@Semil24 If you look at this thread → Intel (Converged Security) Management Engine: Drivers, Firmware and Tools, there is a link for CSME System Tools v11 r39.

Run MEInfoWin64 (if using 64-bit Windows) from an elevated command prompt and it will tell you ‘FW Version’.

@chinobino I ran MEI says: FW 1914.12.0.1256

@Semil24 Post a screenshot please, that looks like the ME driver version and not the firmware version.

Ah sorry H

Here is a shot.


@Semil24 ME was downgraded successfully, you should be able to overclock via baseclock.

That is even stranger… I will have to look at the bios settings.
Thanks alot!