[OFFER] Z87 Asus MAXIMUS VI HERO compl. mod v1603

@junior @vladovmike @Rashad624 @dosmond @GrimmBeard @changf @Spekulatiuscreme @c3r3b3llum @DrPest @NeO29 @Bryaneff @oldschoolh @lemoff

EFI GOP Driver Haswell 5.0.1036 ----> 5.5.1034
EFI Intel Gigabit UNDI 5.4.19 ----> 0.0.29
OROM Intel Boot Agent GE 1.5.43 ----> 0.1.16
EFI Realtek UNDI 2.020 ----> 2.053
CPU 306C3 microcode 19 ----> 28 (latest Spectre/Meltdown microcode) Thx Sonix! Latest edit:July 16th, 2020

NVMe functionality via ------> NVMe mod to run UEFI NVMe SSDs using module NvmExpressDxe_4.ffs dated 04/18/2018 inserted after CSMCORE for this Aptio IV UEFI/BIOS

Enjoy your NVMe capable drive!

Backup your drives and old bios BEFORE flashing…




STOCK BIOS with EFI/ROM and microcode updates:



In the interest of completeness here are the before and after shots on the NMVe mod update:



M6H_manual_NVMe_mod.rar (4.73 MB)

Thank you so much, I really appreciate it! I can’t wait to flash it. You sir are a gentleman and scholar!

Wanted to follow up. Just had time to flash it and it’s running like a dream. You’ve breathed new life into this old board!

Thank you. :slight_smile:

BTW microcode v 27 fixes Microarchitectural Data Sampling (or MDS) side-channel vulnerabilities in Intel CPUs in addition to Spectre/Meltdown vulnerabilties.

Edited Bios/UEFI uploaded May 15, 2019

Добрый день! Прошивка дала возможность работы с NVME диском, но лишила возможности работы памяти DD3 на 2400 Мгц, выставляется только 1333. Похоже вы удалили XMP профили. Память Corsar 2400. Пришлось добавлять модуль самостоятельно в заводскую. Сейчас работает NVME и память на 2400.

Good day! The firmware made it possible to work with NVME disk, but made it impossible to work with DD3 memory at 2400 MHz, only 1333 is set. It looks like you deleted XMP profiles. Memory Corsar Vengeance 2400. I had to add the module myself to the factory one. Now works NVME and memory for 2400.

Thank you for the feedback. There was no editing of the memory profiles in my bios/uefi submitted. Sometimes a reflash and full CMOS battery reset is required.
The only modules updated are those listed above.

Never had any trouble/difficulties with the GSkill 2400 memory.

Module Part Number: F3-2400C10-8GTX x 4 units = 32GB total


Thank you so much for the bios, I just wanted to bring up an issue I noticed after flashing with this bios. With this bios my ram overclock no longer sticks after saving settings in the bios. It just leaves it at stock (1600mhz) but says target DRAM speed 1866. I verified that it works if I revert back to 1603, I was wondering is there anyway this can be fixed? Thanks !

I’m having issues updating my bios, in the Easyflash2 utility I get an error Security Verification Failed, and in easyupdate I get get blocks error. … and to be sure I double checked the name of my motherboard it’s correct…Asus MAXIMUS VI HERO

I actually found the solution to the bios flash issues on this exact forum. [Guide] How to flash a modded AMI UEFI BIOS I used the ezupdate method to allow the update and it updated successfully.

Glad you found a solution!

Is there anything special you have to do to make the NVME boot work? I got the bios to flash im not getting the error that the drive isnt compatible any more but when I go to install windows it still says I cant install on the drive because its not bootable in bios? I also confirmed the drive is not showing up in Bios but I can see it as a storage drive in windows and it shows up when I try to install windows fresh just wont let me install on it.


Yes, you have to set CSM (Compatibility Support Mode ) to Disabled

Further any and all drives should be backed up and converted from MBR (Master Boot Record) to GPT (Gui Partition Table).

Unhook all your drives with only the NVMe drive and supporting adapter card (ie adapter card supports NVMe drives) installed. Set CSM to disabled. Reboot and enter bios to find hard drive; where you will find "Windows Boot Manager" = this is your NVMe drive where you will install Windows normally.

Install Windows, update drivers and you should be "good to go"

Thank you this worked perfectly I was about to waste money on a new system windows is installing right now on my Samsung pm981!

Which slot should I place the adapter card into to get the NVME drive to work at full speed… and do I need to disable any pci-e slots if I do this? If so where do you do this in the bios? No dip switches on the board…

Hi OP. Thanks for the BIOS, but I faced the same RAM problem as some of the users above, my RAM 1866 XMP profile doesnt stick. POST screen shows 1866 but only runs at the RAM default 1333 in Windows.

I also faced another problem where the MBR drives connected to the 2 ASM1061 SATA ports cannot be read. CSM disabled, the MBR drives only for backup not for boot. Havent tried GPT drives.

Thought it might be problem with the modules used, I tried UBU the factory 1603 with all similar modules (still new to modding, took me so much time!!). So far 1866Mhz RAM and MBR drives on ASM ports works with the UBU mod BIOS. Weird…

Another side question, for the updated RST RAID OROM module 14.8.xx, is it normal to have only blank POST screen without member disk list and Ctrl-I prompt. RAID still working, and havent try Ctrl-I to enter console during POST. Searched the forum but not much about it is mentioned. (Edit: silly me, RAID settings supposed to be in UEFI hidden behind the second page instead of separate OROM when CSM disabled, so no Ctrl-I prompt which is working as intended no matter the module version.)

I think you can use the second PCIe 3.0 x16/x8 slot if u have graphics card in 1st one, but ur first PCIe for graphics will auto switch into x8 mode instead of x16 according to manual. Wont affect much on game graphics performance unless u using really high end graphics card like Titan or workstation card, according to some tech websites. Theoretical speed for the x8 slot is 8GB/s, if using x4 adapter then 4GB/s instead.

Thought of using the PCIe 2.0 x4 (will disable all 3 PCIe x1 slots, there is an option in BIOS) but speed maybe limited to 2GB/s or less which may bottleneck ur NVMe drive. 2GB/s is still blazing fast, though I would very much prefer to enjoy the full speed offered by the drive.

Hi guys,
I can’t seem to figure out the right BIOS settings anymore…i flashed the mod BIOS 2 days ago and installed windows 10 just fine.

Since i had to re-install windows, it won’t work anymore - see picture: https://abload.de/img/2019-09-2912.03.228ljge.jpg

also, when i disable CSM in BIOS, it will re-activate on next reboot, telling me that my graphics card isn’t UEFI compatible.

I can see the SSD in BIOS, however it is called “PATA SS:” instead of “Windows Boot Manager”. The Asus SSD secure erase is not able to detect the SSD.

→ This actually states that my video card’s BIOS isn’t UEFI compatible.

Still I managed to install Windows just 2 days ago…please help correct these BIOS settings.