P5K + SSD + Windows XP

Hi everyone

I decided to revive my old computer and among other things, add a ssd to it.

But when I try to install Windows Xp my disk isn’t recognized.
I’ve been trying a lot of different drivers slipstreamed with nLite.
I’ve also tried to edit them, trying to guess my sata controller id, for example:
VEN_8086&DEV_2920&CC_0106
VEN_8086&DEV_2921&CC_0106
VEN_8086&DEV_2922&CC_0106
VEN_8086&DEV_2923&CC_0106
VEN_8086&DEV_2926&CC_0106
VEN_8086&DEV_2929&CC_0106

But nothing seems to work.

I already modified my bios to be able to choose AHCI for sata ports, but it didn’t make a difference. On IDE or AHCI my disk isn’t recognized by Xp with any driver I’ve used.

I’ve also tried to use JMicron JMB363 port but it isn’t recognized too, even with the appropriate drivers slipstreamed. I’ve tried it on IDE and AHCI.

SSD drive is new and it is recognized in BIOS.

Can someone give me a help here? Moving to another operating system could be a easier option, but the whole point of this build is to make a Windows XP retro game machine using what’s left from my old computer.

Computer specs
SSD: Kingston A400 240GB
Graphic Card: 8800GT
Motherboard: Asus P5K - Chipset P35 - 4 SATA ports (2red and 2black) + 1 JMicron SATA
CPU: Q6600


Thank you

@s32n4 : Welcome to the Win-RAID Forum!
What sort (2,5" or M.2) is your Kingston SSD and where is it connected?
Have you already tried to install any modern Windows OS onto it? If yes, which are the real HardwareIDs of the related SATA AHCI Controller?
Regards
Dieter (alias Fernando)

Hi @Fernando

Thanks for your quick response.

It is a 2.5’’ disk and It’s connected to SATA port1 (red).
No, I’ve never installed any OS to this disk.

For what I’ve searched this board uses ICH9, and controller ID should be 2923, but I’ve tried all the Id’s I’ve listed with no success.

Regards

@s32n4 : You should integrate the “Universal 32bit Intel RST AHCI+RAID driver v11.2.0.1006 mod+signed by me” according to >this< guide. It will support the HardwareIDs of your on-board Intel SATA AHCI Controller.
By the way - all VendorIDs and DeviceIDs have 4 characters (numbers or letters), 5 of your 6 test DeviceIDs have 5 numbers. That doesn’t work at all.


You’re right, I’ve corrected them, sorry for that.


Ok I will try them.

Thanks

Hi @Fernando

I’ve followed the guide and I’m still not able to detect my drive with drivers “Universal 32bit Intel RST AHCI+RAID driver v11.2.0.1006 mod+signed by me”.

During this tries I’ve used different Win XP SP3 clean iso’s to exclude problems related to iso.

Also tried to play with F5 options mentioned by Joe1962 with following results:
ACPI - PC - Disk not found
Multiprocessor ACPI - Disk not found
Standard PC - BSOD (Bad pool Header)

@s32n4 :
The ACPI compatibility problem is much bigger than the Intel AHCI driver one. You may have to replace the original MS driver named acpi.sys by a modded variant. Since this is an off-topic problem and I generally do not touch the hex code of any MS driver, you should better ask someone else for help.

Can we consider at this point that this is a ACPI compatibility problem?
I only played with it because it was mentioned on the guide but I’ve no idea if it is a ACPI issue. Is it possible to have issues with ACPI with one disk and not having them with another one? Because I’ve used this board before with Xp and sata disks.

Thanks for your support

@s32n4

It seems rather unlikely for me, but I don’t know it for sure.
Back to the topic of this thread: It is very important for all users of my guide and for me to find out the reason for
a) “the file iaStor.sys is corrupt” message you got and
b) the inability of the XP/W2k Setup to detect the desired target disk drive, although you had integrated or loaded a matching Intel SATA AHCI driver.

Do you get 7B or A5 BSOD?


I require a computer for my civil engineers adelaide company. Please share your experience regarding the best specifications like Ram, processor, etc.

Try to integrate using nLite Generic_AHCI driver from my collection. You can also try ported IRST or RSTe driver, every MassStorage driver can be integrated into TXTmode.

1
 
https://www.mediafire.com/file/1rkvwx5gv37l3xc/PortedDrivers-WindowsXP%252BWindows2003_x86%252Bx64_v9.7z/file