P6T Deluxe v1 with Intel Raid

I’m trying to replace the v8 bios into P6T Deluxe v1 bios with Intel_RSTe_RAID-ROM_v12.7.0.1936 but i got black screen when it goes to load the rom upon boot.
Any ideas what i’m doing wrong ? I used MMTool and replaced the proper “Option Rom” with Intel_RSTe_RAID-ROM_v12.7.0.1936


@ XGate:
Welcome at Win-RAID Forum!

Please give some additional informations:
1. Which Intel RAID ROM version was in the original BIOS?
2. Do you have a RAID array? If yes, which sort of RAID array is it and with which Intel RAID ROM version did you build it?
3. How did you flash the BIOS (with which tool)?
4. Have you already done a CMOS clearing?
Furthermore I recommend to have a look into >this< BIOS modding success/failure table. There are some ASUS P6T users, who reported, that it was impossible to get any Intel RAID ROM version newer than v10.1.0.1008 working. The problem is the limited space for PCI ROM modules within the P6T BIOSes.


  1. Original is v8 which i updated to (It’s the only working for the moment, the above versions appear the blinking cursor like they never load or got replaced/exist inside the rom)
    2) Raid 10 builed with v8 working fine with v10
    3) Used the internal bios EZ-Flash tool (bios located on a usb drive)
    4) Yes

    What i also did and didn’t work.
    The bios contains 2 PCI Optional roms for the Marvell controllers (One for the Marvell Raid and on for the Marvell IDE)
    Since the v10 bios is 80kb and v12 is 120kb i needed to make space, so i delete the 2 Marvell Optional Roms in order
    to make space for the Intel Rom. The problem ? MMTools doesn’t deletes them!

    So that’s why i need your help. Somehow, even if you delete the 2 Marvell optional roms MMTools doesn’t actually deletes them!

    Attaching Latest P6T Deluxe bios and the latest Intel Raid OROM

    Thank you

The attachments!

biosandintelorom.zip (985 KB)

It is fine, that you got the v10.1.0.1008 OROM working. This verifies, what other users had reported: IThe Intel RAID ROM v10.1.0.1008 is the latest one, which works properly with ASUS P6T mainboad BIOS.

I repeated the procedure with your attached BIOS and got both Marvell OROMs deleted at first try.

I’ve also downgraded the OEM logo to 16 colors which gave me around 150kb more space so the new OROM will fit. The result still the same! blinking cursor! :frowning:
I don’t understand why the newest Intel Raid OROM will not load.

> I repeated the procedure with your attached BIOS and got both Marvell OROMs deleted at first try.

MMTool deleted them from the table but when you flash the bios with the deleted Marvell OROMS and do a CMOS reset the Marvell OROMs will load!
How this is possible since the Marvell OROMS are deleted ?

There may be enough space within the entire BIOS, but not within the BIOS section, which is reserved for the PCI ROM modules.

I just checked the original BIOS and the BIOS, where I had deleted both Marvell PCI OROM modules. There are definitively no Marvell PCI ROMs within the modded BIOS. That verifies, that the MMTool has done its job correctly.
You can easily verify my finding yourself by opening the original BIOS with a Hex Editor and searching for the Text String "Marvell" or "RAID1". You will find a lot of these words, which belong to the Marvell RAID ROM module.
Then do the same with the modded BIOS. You will not find these key words.

The only explanation for me is, that the old BIOS has not been completely erased while flashing the new BIOS file.
Maybe you forgot to set the previously active BIOS to "DEFAULT" settings before you flashed the modded BIOS. Both Marvell Controllers should be set to DISABLED before you flash a new BIOS file.

> There may be enough space within the entire BIOS, but not within the BIOS section, which is reserved for the PCI ROM modules.

Also i forgot to mention that the original Intel OROM within the bios is v8 which is around 45kb. If i replace the working so far v10.1 and clear the CMOS i’m getting the following error message at post:
No enough Space to copy PCI Option ROM [05:00:00] (although Intel’s Raid OROM v10 is working dispite the error)

So i guess that’s the problem because even if i delete the 2 Marvell OROMs still doesn’t make enought room for the BIOS Section because the latest Intel OROMS are 120kb compared to 80kb which is.

I google it and they telling to disable memory remapping in order to solve the issue but the P6T bios doesn’t have any visible or hidden option to disabled it. (it’s always enabled)

Do you have any idea how to resolve this ? Any hack on the internals or something ?

Thank you

AFAIK only ASUS will be able to solve the PCI ROM space problem within the BIOS of their X58 chipset mainboards by changing the internal BIOS structure. That is why I recommend to contact the ASUS support.
Nevertheless an Intel RST RAID ROM v10.1.0.1008 is already better than an MSM RAID ROM v8.0.0.1038, whis was within your original BIOS.

Darn, i’ve updated the OROM to v12 on my P5B Deluxe which it’s older board and it doesn’t work on P6T. I sent a e-mail to asus … Let’s see!