P8Z77-V LX with modded bios. Issue installing windows 10 on Intel 750 PCIe

Hello everyone,

Not sure if I’m missing something here. Thought I’d best throw this problem to the experts, I’ve taken some screens shots to help better explain what I’m working with and what I’ve tried.

I have a P8Z77-V LX motherboard and recently (blindly) decided to purchase an Intel 750 SSD unknowing of the problems which may lie ahead.

As the SSD arrived and my excitement grew I thought I best do a quick check and see if there is anything in the bios I need to check first (last minute I know). To my dismay I came to across a feature NVMe to which my motherboard doesn’t support. Thankfully I found this place so all is not lost :). After reading a few guides I decided that a modded bios was in order and that NVMeExpressDxE was required. But after a few attempts at flashing the modded bios It appeared the protection was to great on the Asus board so I turned to a CH341a bios chip programmer.

After popping the bios chip and finding the correct orientation along with tools / drivers to operate the CH341a, everything appeared to work. I returned the chip with modded bios (added NVMeExpressDxE) to my motherboard. It booted up and everything was looking fine. So finally I get to insert my new (used :D) Intel 750 SSD.

I place it in the black PCIe slot on the board (I don’t believe it matters which slot?) and boot it up. I’m greeted with windows 10, obviously the previous owner wasn’t to bothered about cleaning the drive. I take a quick peek on my computer just to check the drive size and there it is 377gb. I now decide to do a clean install of windows (having just recently purchased windows 10 enterprise in preperation). I create my windows 10 USB pen and reboot. Upon reaching the select your drive bit during installation I hit a wall.

I wasn’t sure what to do so I did a quick google and found my self following the instructions laid out by a youtuber to fix this issue. I cleaned the drive.

Now upon returning to the previous create partition screen I’m greeted with a different error

"Windows cannot be installed to this disk. Ensure that the disk’s controller is enabled". After scouring the net for fixes and trying several different bios settings to no avail I’m a bit stumped here. Here are some screens shots of the bios settings I have tried.

Sata Configuration


CSM Compatibility

Intel 750 PCIe menu

I have tried installing the Intel 750’s drivers which came on disk (It says these drivers are for windows 7 but I thought it was worth a shot) but they didn’t help.

Attached is the modded bios I used which is the original v2501 with NVMeExpressDxE.ffs and satadriver90.ffs added. Removed MAC and UUID.

Any help appreciated, thanks for reading!

backupNoMac.rar (3.9 MB)

1st: Better use the blue PCIe unless it is version 3.0 and the black one is a 2.0 only.
2nd: It is nothing about the Sata configuration in the bios unless it isn’t Sata. I would recommend to update also SAta raid and orom drivers in Bios to those of the latest p8z97 bios. Which is v13.0 or alike.
3r: You cannot install Windows 10 in uefi mode on an MBR Partion. Delete the partition and select the raw disk or - if there is data on the volume -create an efi system partition according to the guide i linked in previous posts.

Hi Jan771,

I moved the Intel 750 into the blue PCIe slot.

When you say:
"I would recommend to update also SAta raid and orom drivers in Bios to those of the latest p8z97 bios. Which is v13.0 or alike."

Are you referring to the “SataDriver” module? I replaced my existing SataDriver module with the one found in:

Intel EFI “RaidDriver” and “GopDriver” BIOS Modules
- Recommended for Intel 7-/8-/9-Series Chipsets (except X99 running in RSTe mode):
- >Intel RST(e) EFI “RaidDriver” v13.1.0.2126 GUID 90C8D394<
- satadriver90.ffs

Should I use / extract the “SataDriver” module from a p8z97 bios instead?

I tried to follow the instructions from your other post to create an EFI system partition within diskpart:

At first I received the error:
"MSR and EFI partitions are only supported on GPT disks."

So I run “convert GPT” which is successful. I follow though the instructions on the guide but as this is a clean install I have no existing partition to convert. I exit diskpart and refresh:

I have no primary partition so click “new”.

Still no joy, am I missing a module in my bios? can UBU help me here? am I not setting up Primary partition correctly?

Thanks for your help.

Found the issue. When I created the windows 10 bootable USB in Rufus I selected the wrong partition schema. It needed to be “GPT partition schema for UEFI”.


Would just like to say quick thanks to everyone at this forum, all the well presented information here has helped me greatly over the past week or two.

You now have created the efi system partition on your own and need only to create a further gpt data partition and to copy the windows 7 or 10 files on that disk.

If you want to install windows from dvd automatically, delete all partitions on that disk and let setup create efi system and recovery partition on Its own.
Unless your setup and boot meno showd up your 750 drive, d o n’t worry about your sata efi module in the bios.
Sent from mobile…

Did your GPT-USB Stick work meanwhile? Did you try to create a Windows 7 UEFI Boot-Stick? That should be feasable but is a bit more tricky as described in some forums IMAO.