Panasonic CF-191HYAX1M with Problems while Booting

I have a CF-191HYAX1M (MK6) which is giving me several different errors which I assume is all related to the same root issue. The errors are as follows:

- When I Boot the CF-19 up into Windows 10 OS. I get three errors that say:
“Access to the Panasonic Misc Driver was unsuccessful. Confirm whether the Panasonic Misc Driver is Available”
- When I try to update the BIOS using Panasonic’s Stock BIOS ‘biosup’ application I receive:
“Access to System Interface Driver – 0021 or 0040 was unsuccessful. Confirm whether the System Interface Driver – 0021 or 0040 is available. [Code=100]”
- When I attempt to update the Intel Management Engine (ME) Firmware I receive:
“Access to the System Interface Device – 0021 (Panasonic Misc Driver) was unsuccessful. Confirm whether the System Interface Device – 0021 (Panasonic Misc Driver) is available.”
- When trying to flash BIOS with AMI’s Aptio 4 AFUDOS.exe in DOS I receive the following error:
43 – Error: Problem erasing flash
- The BIOS also displays: Intel ME Firmware: N/A
- Device Manager has the System Interface Driver with an ! saying “This device cannot start (Code 10) {Not Implemented} The request operation is not implemented.” The Ethernet Adapter Driver is also having a similar issue, except "The requested operation was unsuccessful."

I’ve tried flashing the BIOS with another image from another Cf-19 MK6 receiving the same issue. Originally I flashed the BIOS to remove the BIOS password. Since I was unable to flash it using software, I used an EEPROM to flash it. I have multiple CF-19’s and only the ones with BIOS passwords that I’ve flashed are giving me this error. It’s almost definitely an issue with the flash, however I’ve tried taking a flash from one that was working and flashed it directly onto to one that wasn’t working and it did the same thing. I’d post a copy of the Flash but I’m a new member and can’t post links currently, however I plan to work on that…

The question is now, how do I get past this point. My end goal would be at least to have the pop ups not happen on Windows 10 start up, and maybe the device manager be cleared of any “!” devices.

Edit by Fernando: Thread title shortened

NOTE: I’m at home at the moment and my equipment is at the warehouse.
The problem is definitely the flash method.
I am just starting on removing the password from a few CF19MK6!!!
I used a “Donor” MK6 with WiFi and Bluetooth capable.
As some/most of the Military models have factory installed limitations.
Some time back we flashed some CF19MK8’s and the same thing happened.
System Interface Device - 0021 and/or 0019
Unable to update BIOS and other functions.
It can be fixed because we sent one out to a contact and they reflashed it correctly.
How, we have no idea yet.
He did need a clean unit with “0” hours for a donor .rom file.
I am in the process of finishing the CF31MK5 and plan on going to the CF19MK6 next.
I have a script that my techs use running W10.
It has most of the CF19, CF31, CF52 and CF53’s.
Takes about a minute to flash the BIOS retaining its original M# S# and hours.
I am getting the ROM ID mismatch at the moment and /x does not work because it is the GUID:
I should finish with it next week and move on to the CF19MK6.
I have around 200 locked.
I’ll try to keep in touch.
Best regards,

I figured out the issue, it was just the image I used. I found another good image and it worked fine, however now I’m at the point where I screwed myself because I totally didn’t think about MAC addressing when flashing these CF-19 MK6’s. and I deleted all the backups since they weren’t working right and I thought I had myself a working flash at the time. But when I load all the CF-19 MK6’s together using an image on a PXE Boot software like Acronis, the first one works fine, but the 2nd one hangs and acts sluggish and gives a lot of trouble connecting to our Imaging server.

I tried manually changing the MAC address by a single character on the last set of hex characters, and several other ways too, but any time I do that and try to use PXE boot, I get “No desired boot device” and the Ethernet isn’t an option in the boot override in BIOS, but LAN is enabled in BIOS. The Ethernet seems to work and give out the changed MAC Address in Windows though, and connect to the internet.

Also, how are you flashing those later generation Panasonics with software? When I try using AFUWINGUI/AFUDOS, I always, always get Error Code 43: Problem Erasing Flash, but you seem to be using the very same, and it works for you? Am I doing something wrong? Usually just flashing afudos .rom /P /N /B /X when it actually allows me to takes care of the non matching ROM ID’s.

I’ve been doing all of this using an EEPROM since I couldn’t get the flash to work using software, but I would be so appreciative if you could show me how to flash those later generation Panasonics with just panasonic’s software… in my experience, if it uses Aptio 5 or later, I might as well not even bother trying to flash it with software. Usually NVRAM option is grayed out on Aptio 5 as well, which I don’t understand as well.