[Partially-Solved-WIP But Still Need Help] with IvyBridge (i7-3840QM) on HP Probook 4530s

UPDATE# 02: So I have not given up and during the last few weeks, **I was able to break BIOS signature (dual) verification and now modification to any DXE volume does not cause any blinking LEDs. ** :slight_smile:

now the only things left to do are the following:

  1. Audio must be disabled in BIOS (to prevent Driver PNP Watchdog BSOD)
  2. only 2 USB (R.H.S) ports work, NEC/Renesas USB 3.1 do not work,
  3. Restart/Shutdown operations from OS don’t work, hardware does not restart/power off, continues to shutdown/restart for a very long time then results in BSOD and then the system resets (normal after a BSOD).
  4. The underlying Keyboard & touchpad (EFI?)driver is extremely slow like a tortoise. It’s extremely slow. You have to hard-press keys and then wait for the key to work after 3 seconds then delay 3 seconds then press another key and so on…

I need help identifying the Audio DXE Driver/module, Keyboard, and power monitor modules in 4530s and 4540s modules.

For the keyboard, I replaced (from the 4530s BIOS into the modified 4540s) KBC flash, EfiLowLevelKeyboard, and all Keyboard-related DXEs but they did not seem to have any effect… BIOS still works with the aforementioned issues.

So this leads me to think there is some other PEI module that is loaded during POST that eventually becomes responsible for keyboard or touch handling.

or maybe there is some kind of clock speed frequency thingy that is causing the sluggish behavior of the native keyboard and touchpad.

Any help or guidance will be appreciated.

UPDATE#01: I have made some more progress. One of the 4540s BIOSes works (with a few issues). (3.5 MB)

Let’s talk about what does not work first!

What does not work or is a bit tacky?

  1. Keyboard works when a key is hard-pressed for 3 seconds and subsequent key is pressed after a delay of 3-seconds. So its too slow for practical purposes
  2. Touchpad works but delays or hangs just like the keyboard…
  3. NEC/Renesas USB 3.1 and neighboring (only the left-hand-side) port does not work
  4. Power Management Unit does not work so battery charge detection does not work. I think the battery still charges though. but I am not sure at the moment.
  5. Battery charge indicator turns yellow and remains yellow whether the charger is connected or not connected
  6. Audio does not work as the Audio had to be disabled from BIOS to prevent the Driver PNP WatchDog error.
  7. Two 8GB RAM modules cause extremely slow boots (15+ minutes) and high CPU usage post-boot. I have 02 Crucial DDR3L 8GB modules that operates at 1.35 volts. I also have to have a 16GB single DDR3L module but i have not tried it yet but hope to try it soon-ish…
  8. Windows 11 Update seems to write some certificates/Secure Boot Stuff into my BIOS chip in the empty region which causes BIOS-POST-loop (no best way to describe it) which causes the laptop to continue in a cycle (of Turning ON, trying to get to BIOS and turning OFF and then repeating this process) without any Display on the scren and accessing BIOS is reaching Windows BOOT is not possible without a reflash using CH341 programmer. I have compared the BIOS by reading the image from BIOS chip using the CH341A programmer and comparing it with the last working backup (i take backup after changing BIOS settings to make sure which setting worked) This has happened 5 times. Seems to happen when the charger is connected and Windows restarts after updates. I have temporarily disabled Windows Updates to prevent this from happening.
  9. Shutdown and restart operations only shutdown/restart windows but not the underlying hardware - This means I have to hard-press the power button to turn OFF the laptop.

What is not tested?

  1. LAN connectivity
  2. SD Card Reader
  4. RAID untested.
  5. 16GB single DDR3L module

What works?

  1. UEFI Boot, CPU & Display (full HD 1920x1080) works, AMD Radeon 6490 works, Intel HD4000 works. I have a full HD screen and with corresponding LVDS for the HD screen I had imported a while back from AE/CH!na.

  2. 1TB SATA SSD (SATA controller works on both the main SSD/HDD and the Optical Drive/CDROM works too) with AHCI and SATA 6Gbps setting.

  3. Right-hand-side USB ports work! so I can attach a mouse and keyboard

  4. WIFI 6E works!

  5. BIOS settings saving works.

  6. 8GB single Crucial DDR3L works really good, boots up in a few seconds.

  7. Windows 11 Enterprise works

  8. Sleep works.


Next Goal:

  1. Replace Keyboard controller (KBC) EFI module with the one from 4530s so native keyboard could be usable and I dont have to attach external keyboard.
  2. Replace PMC EFI module with the one from 4530s so Battery charge can be detected
    and power off and restart operations from Windos can also turn off the hardware/laptop

OLD Stuff - History
I am trying to use an IvyBridge Processor i7-3840QM in “HP Probook 4530s” with partial success! and I need some help/advice/guidance.

I also happen to have an i7-2860QM but it runs too hot (despite my custom rig done to the heat sink for both the PCH IC, CPU, and graphics heat sink) and gives only a little performance edge (WIN11 install time: 3 hours, Boot time, 15 minutes, Post-boo CPU usage more than 50% on clean install). I would like to benefit from Intel HD4000 from Ivybridge and be able to use the low heat that i7-3840QM seems to generate (when I am able to get the display working, see details below)

The only way, the display would come up on Probook4530s with i7-3840QM is when I use a BIOS from HP Probook 4540s using an 8MB chip (W25Q64FVSIG).

However, there are some issues that I am trying to get resolved for which I need help and I have been browsing the forum for weeks to learn to mod bios and flash using a TL866II+ programmer. Please see the problem I am facing below and advise.

What works on Probook 4530s using “Ivybridge i7-3840QM” with a 4540s BIOS?:

  1. Display shows up, BIOS can be triggered using F10, F9 for Startup, Diagnostics work
  2. CPU & graphics chip are very cool (compared to when i7-2860QM was used)
  3. PCH is hot as it should be (less hot compared to when i7-2860QM was used)
  4. Sata3 SSD is detected by BIOS
  5. USB ports on the right-hand side (non-NEC/Renesas left-hand side ports) of the laptop seem to work & are detected
  6. CMOS clock can be set and is retained (on some 4540s BIOSes)
  7. Boot from Sata3 SSD works if UEFI (non-CSM) is preset in the BIOS
  8. Boot from Sata3 Optical Drive works but it is a little bit tacky…
  9. Boot from USB 2.0 ports on the right-hand side) work but only appropriate USB boot options are already set in BIOS.
  10. Keyboard navigation works (with problems)

What does not work/slow or tacky (when using “Ivybridge i7-3840QM” with a 4540s BIOS on Probook 4530s):

  1. Keyboard navigation/usage during Pre-BIOS loading and during BIOS is extremely slow (incompatible with Keyboard Controller 581E). I have to “long press” (with a delay of 3 seconds between every key press) any given key (F10, F9 Up key, down key ENTER key etc) to make the required operation work which takes a lot of time…
  2. CMOS clock can be saved but saving any other option does not seem to work
  3. In some 4540s BIOS(es) I have tried, it is possible to load BIOS again after saving the BIOS settings while in others, subsequent BIOS loading does not seem to work (no display). It appears, that boot settings are not saved at all. Setting the UEFI Native (CSM) option causes the no-display on the 4540s BIOS. Rest of the options dont seem to cause this issue.
  4. TouchPad/Mouse navigation does not seem to work with the 4340s/4540s BIOS. Touchpad buttons don’t work which normally works in 4530s BIOS. (Possibly due to the touchpad driver which should be replaced/imported from 4530s?) - I have unplugged it as I suspect this maybe the cause of the Driver PNP WatchDog error during win11 installation
  5. With some 4540s/4340s BIOS ROM, I was able to boot via DVD and attempt WIN11 installation but the setup encountered a “Diver PNP Watchdog” error with BSOD. I have found on the internet that it can happen due to broken hardware. A possible Reason is that the NEC/Renesas USB3.1 EFI driver is not there,… instead, the Intel USB3.1 driver is there in 4540s/4340s BIOS which probably clashes. There could be another broken driver such as the old SD Card reader built into the chipset., I am able to boot using the USB port on the right hand side as well as using the optical drive however, both in cases, I get the Driver PNP WatchDog error after initial wheels loading in WIN11 installer.
  6. With most 4540s/4340s, I was able to load Windows 11 (which was pre-installed on the SSD using i7-2860QM) but loading that seems to take hours, and WIN11 loading never finishes (possibly due to a driver conflict/mismatch).
  7. Attempting to install windows (using USB) can be attempted only in UEFI Hybrid Mode and then using F9 to choose EFI mode to select EFI boot file and start windows setup only to end up with Driver PNP WatchDog error. Switch AHCI to IDE in BIOS does not seem to make any difference. Furthermore, after being able to reproduce this error 2-3 times, subsequent boot attempts result in BIOS POST loop where only solution is to reflash the BIOS. Tried CMOSE reset by taking the CMOS battery and the main battery and power out for upto 30 seconds but the BIOS POST loop continued…

What I am hoping to achieve?

  1. Make IvyBridge i7-3840QM processor work from POST, Boot to proper system usage.
  2. Make Keyboard navigation during POST/Pre-BIOS stage (for F9, F10 trigger easier) and faster when changing BIOS options (change Keyboard Controller 581E to an older version from Probook 4530s’s BIOS?) & make Toucpad/mouse work in BIOS just like 4530s. Not a huge requirement if the keyboard could work in windows normally and would have issues only in BIOS…
  3. Ability to save and retain BIOS options (unsure about the cause and need help with it) Saving BIOS options work fine. Only the UEFI Native boot mode should never be selected/saved otherwise no-display occurs.
  4. Enable USD 3.1 device detection/boot and install Windows (Replace IntelUSDb 3.1 efi driver (from 4540s) to NEC/Renesas USB3.1 efi driver(4530s) ?). This works in 4530s BIOS with Sandybridge processor. This is not important at this point in time…
  5. UEFI (non-CSM) boot mode set as default in the BIOS. UEFI hybrid option is fine to use and boot the installer from USB.
  6. Ability to install Windows 10/Windows 11 by avoiding any “Driver PNP watchdog” BSOD/conflict (driver conflicts?) - This is critical issue at this stage!
  7. Make system usage possible using the i7-3840QM (low heat due to 22-nm), and better graphics (HD4000) and overall faster system usage. This already works, only Driver PNP WatchDog is the issue I need to bypass at this point.
  8. Possibly re-add the “Intel RST Raid driver” which was present in 4530s’s BIOS but has been removed from 4540s/4340s BIOS ( I couldn’t find it using UBU tool in 4540s/4340s BIOS) Not needed at this point in time.
  9. Remove WIFI whitelist as I plan to use another wireless Card. Not needed at this point in time…

What I have attempted so far?

  1. Flash 4340s/4540s BIOSes using BIOS dumps (found on other forums) and achieved keyboard/USB usage display and boot (but with problems as identified above) using TL866II+ programmer on a ZIP socket (SOI8 clip doesn’t seem to work for me for some reason) using an 8MB BIOS chip (winbond W25Q64FVSIG). I have a couple more lying around to experiment further
  2. Replace EfiLowLevelKeyboardDriver into 4540s BIOSes using UEFI tool while borrowing the one from 4530s (my original BIOS dump). This modified copy of the BIOS no longer seems to work and the display does not appear but since I am not an expert BIOS modder, there is a possibility, I am doing something wrong.
  3. Tried MMtools but most of them don’t recognize the HP Probook BIOS.
  4. Tried UBU tool but it does not recognize the chipset and it does not replace the keyboard driver which I would want to replace

Screenshots 4540s BIOS on HP Probook 4530s with an 8MB chip

What I am open to doing?

  1. I am open to experiment and learn in the process and make the above goals meet. However, I need assistance and would be more than happy to share the results of my experiences here for the benefit of all
  2. I need advice on what I am doing wrong with the EfiLowLevelKeyboardDriver replacement. Is it even the right thing to do? How can I change the Keyboard Controller version in 4540s BIOS to that of 4530s BIOS (in a bid to make keyboard navigation easier)?
  3. Coming from an SE background, I know my way around Winhex/Hxd, IDA Pro, and lately with UEFI tool (not an expert at all, just a tinkerer) but have the hardware, basic knowledge, patience, and willingness to try various options/changes or BIOS modes to make the 3840QM work on this laptop. So your help and guidance is very much appreciated.

4340s/4540s BIOSes that POST and display works with IvyBridge i7-3840QM
4340s_DUMP_1.zip (3.5 MB)
4540s_8.1.0.1248_1.5MB_PRD_RGN_Doesnt_work-after-saving-settings.zip (3.5 MB)
Probook_4540s_4MATIC_saves_Clock_Boots_Disk_Sata_But_No_NEC_Support.zip (3.5 MB)

[TESTED]My HP Probook 4530s original BIOS Dump With Serial/PRD using TL866II+
Probook_4530s_MX25L3206E@SOP8_Ser_CNU1440RP0_Prd_A1D17EA#ABV_oriignal_Dump_TL866IIplus.zip (2.3 MB)

FFS Extracted from the original HP Probook 4530s BIOS Dump
4530s_FFS_Keyboard_PCH_PCI_etc-20231022T211933Z-001.zip (256.1 KB)

I have been reading a lot of guides from @CodeRush @Fernando @Lost_N_BIOS Lost_N_BIOS @plutomaniac . I am hoping these or any other expert BIOS modder can advise and help.

please feel free to chip in, and share your expert advice and guidance.
Awaiting your expert advice and response.

I’ll give you my opinion since i read your post yesterday and no one answered it…
As you may already have noticed mcode or MEI 8 is not the issue here… what you’re trying to achieve, its bios deep code/DSDT APIC etc… and small(or big…) details like EC, hw routines
The tools related and confirmed working with AMI core bios, UEFItool apart from it, will not work as this is an INSYDE core bios. (OLD UBU can open the file)
You’re asking a “big…big” transformation with a lot of time required and a lot of work.
Its not the same as working in the same base bios image, rather than 2 different ones.
The users you pointed out, some are not their expertise, some are long gone from the forum and some don’t have time for this kind of “mod” if we can call it…
You’ll see more requests than “real” modders nowadays
Anyway, this is my opinion and not to discourage you on your endeavor.
Still, you should wait any other user pov, all the best and good luck.

@MeatWar Thanks for your advice and details.
I have made some more progress with my experiments.

At this point in time, I only want to have the SataController of the 4540s firmware replaced with the one present in 4530s. If that is done, I hope, I can install Windows 11 and bypass the “Driver PNP WatchDog” error

My understanding is that, with the current state, (Driver PNP WatchDog error) it should be possible to install any other OS such as Linux or maybe older version of Windows… but I hopeto be able install windows. So I am wondering if only the above mentioned change is possible…

@MeatWar Do you think, that single change, is possible?

That dependes on PCH of the motherboard and we know that there’s several variants of a chipset (Intel) … so as the function is HW ID related, you cant fool the system by adding/replacing EFI/Oprom.
It seems the 4530S uses H65 and the 4540S H76, i cant find no EFI driver or Oprom for SATA controllers on both bios, only the DEV_2228 Intel RAID Rom for SATA present in the 4530S bios, not present in the 4540S bios.

@MeatWar Thanks for yoru reply. I appreciate it very much.

Do you have any idea what could be the possible causes of BIOS not saving settings? Does this mean a bad flash or low quality chip or bad CMOS battery? I have installed a brand new cell so I can rule that out…

Another question is why Intel RAID for SATA is present in 4530s BIOS but not present in any of the 4540s ROMs?

Appreciate your help so far… Thanks

Every bios has its own Default NVram values and the the user set values, i guess here it conflicts when user settings doesn’t match some strings related to specific 4540S.

About the RAID rom, really dont know why exists on one and not on other…

As you can see in your post @ Badcaps forum… you didn’t get any more advances regarding this “mod” and theres quite a few “brains” also in that forum, im sorry but ill finish here also, good luck.