PC stuttering and wiped MAC address after flashing stock Z390-A PRO BIOS with FPT

Hello, I messed up my motherboard bios by flashing a stock bios file with Intel Flash Programming Tool which didn’t luckily brick the board, but the performance of my PC is now noticeably worse. What I mean by that is I have lower fps in games and the occasional stuttering in games and on the desktop. Apparently my MAC address also got wiped by FPT or by earlier bios flashes with afuwin or CH341a.

What I did was I just changed the file extension on the stock bios file called E7B98IMS.1D0 to E7B98IMS.bin and flashed it with FPTw64 -SAVEMAC -f “nameofbios”.bin. I am running Windows 64-bit Pro with the MSI Z390-A PRO motherboard and Intel i5-8600K cpu.

After further reading of the thread “Intel (Converged Security) Management Engine: Drivers, Firmware and Tools” I came upon a post that said not to flash a stock bios without configuring it in FIT first, but rather that you should dump a bios image via FPT and only then modify it and flash it with FPT.

I need help in how to configure a loaded stock bios image in FIT into a full SPI image that FPT can use. I also need help with correcting the MAC address in the bios file.

Edit by Fernando: Thread title corrected/specified to make sure what happened

I have the FPT dumps of the DESC, BIOS, ME and GBE regions in case they are needed.

Edit: I flashed the ME FW to the latest version with FWUpdLcl64.exe. It went just fine, but this didn’t fix the issue with the fps, stuttering and the incorrect MAC address. MEInfo and MEManuf report that the ME is working fine, no errors. I thought I could try loading the stock bios image into FIT along with the CSME and PMC binaries used to update the ME firmware, but I am not sure if this would work.

Since you have a working motherboard state, you just need to to update (Optional) the latest ME to version

Intel (Converged Security) Management Engine: Drivers, Firmware and Tools

So are you saying it didn’t configure anything incorrectly the way I did it or if it did it only affected ME and that can be fixed by updating the ME in FPT as per the instructions?

I am not trying to be rude, but I am not familiar with FPT and am new on the forum to begin with. Originally I found some posts that said you could downgrade the bios by flashing it with FPT with the command -SAVEMAC -f “biosname”.bin. Then I saw what plutomaniac and Lost N Bios had written about the tool and thought that that must’ve not been the way to go, and I’ve lost some data that wouldn’t be overwritten with tools such as AFU or M-Flash.

I really don’t think I am having placebo here, since now I have much lower fps in games than before, and gaming in general feels off. Why it’s important to me is, my motherboard is useless to me if there is something wrong with the bios that affects the PC performance, since I mainly use this PC for gaming.

We could say you got lucky…
If MAC is present, ME present in bios, ME driver installed and no issues reported from ME status in windows… dont see why not.
The SPI is, we can say its 2 different FW images, the main bios and the ME FW…the FPT tool can perform several operations to individual areas, you’re not going to touch the bios updating the ME FW.
There is also the ME tools package with tools for debugging the ME



EDIT: Your MAC address is the 12digit number on the motherboard label. Correct it

All right, actually I noticed before that apparently I have at some point wiped the MAC address, since it reads 88-88-88-88-87-88 in bios and with ipconfig /all. Somehow my ethernet is still working, so I thought it’s no big deal. I only found two stickers on the motherboard itself, one on the 24pin connector with the serial number and one on top of the SATA ports, which I assume is the MAC address, 12 characters long next to a bar code, starts with 00, consists of 10 digits and 2 letters. There was no sticker under the heatsink on the actual LAN port itself. I found a package with different versions of eeupdate and tried to update it with eeupdate for I219, but the program told me no compatible adapters found. Maybe the version was too old? Device manager tells me the adapter is Intel(R) Ethernet Connection (7) I219-V. I will see about updating the ME FW next then. Meanwhile I would appreciate if someone could link the proper version of eeupdate so I could change the MAC address, if it needs to be changed.

Thank you for the links MeatWar. I downloaded the preboot.zip but am not sure what to do with it. Also the other link to the discussion about eeupdate, the link for the Intel Network Connections Tools document isn’t available to me, I suppose you need some permissions to be able to download it there.

I installed the ProSet drivers for the network adapter. I ran the diagnostic tests on the software and saved pictures of what it showed. It says everything else passed except for connection status and cable link status.






Edit: I figured out that the preboot exe actually extracted some utility files to the root of C What I am not sure of is can I fix the MAC address with BootUtil? I read through the various commands the program has but didn’t see one that would allow me to manipulate the MAC, only the command -MACADDR=[MAC address string] used to select a network port specified by the given MAC address .@MeatWar I suppose you didn’t link the tools for no reason, but I need instructions on the commands i’m supposed to run on it.