PCI-IDE Card or PCI SATA Card for old Pentium 1 Chipset 430FX PC

I have a Pentium 166Mhz based HP Vectra 500 model 562 (D3742A) (Intel Triton 430FX chipset - BIOS Phoenix v.GJ.07.18)
I put a IDEtoCF adapter with two slot with a 4Gb CF card in each on the motherboard’s IDE connector.
It works flawlessly with DOS and Win98SE. Nevertheless, speed is not great (7.5Mb/s to 10Mb/s)
My BIOS limits hardisk size to 6449Mb, my 2x4Gb are full and I have some 7 CD games I would I like to play from HD. There is no BIOS update anymore;

I tried to install the PCI to SATA card (Ali M5283 chip). But I got a ressource conflict in BIOS even with all other PCI Cards (USB, Matrox Graphics) removed and integrated IDE controller disabled; and finally the PC hung.

Next I tried anAbit Hotrod 100, I bought last Friday.

With the Hotrod 100 card, the PC beeps on boot with no error message. I didn’t find the meaning of the beep (1 long, 2 short, silence, 1 short).

I can’t see any message displayed by the IDE Bios’ card. I am supposed to have an option to enter a RAID menu.

Booting from the internal IDE drive, however Win98SE detected the card and I’ve installed the lastest Highpoint 370’s drivers (found on NVidia’s site). I used a formatted CF Card with an IDE adapter plugged on the IDE port of the Hotrod 100 with success but only in Win98SE. There is no ressource conflict.
But with DOS, the card and the drive are not detected.

I also tried to use the IDE card with motherboard’s IDE controller disabled (and parallel, serial port, floppy controller disabled too, PCI USB Card removed) and the Abit Hotrod 100 does not to work on boot and with DOS. It’s only activated after Win98SE’s launch.

I think it’s BIOS issue but I can’t figure what it is. Some people told me about the BIOS doesn’t scan/launch Option ROM. But I have no such option to enable in BIOS. I can’t select boot order or bootable Add-in card.
The Phoenix BIOS does not offer a lot of settings to play with.

If someone can help, I will listen to your advice carefully. I have no clue !
I want to use the PCI/IDE card or a SATA Card in DOS Mode.

Thanks for reading.