Please help me trouble shoot my MSI X79a-gd45 NVME bios mod.

I used Mmtools 4.5 to insert the modules Nvme, NvmeSmm, and NvmeInt13 from this motherboard https://www.msi.com/Motherboard/support/X99S-GAMING-7 to the CSMCORE module of my motherboard https://www.msi.com/Motherboard/support/X79A-GD45-Plus. I flashed in the new bios, and I’m not sure it worked. I tried to upload the new bios, but it’s over 6mb, so I can’t. When I open up my modded bios the NVME modules were listed, but not under CSMCORE, I don’t know if that means anything. I don’t see it as a boot option in BIOS. I disconnect all of my other drives, formatted this one, and used a windows 10 usb to start installing the operating system. Durring the installation process it says it needs to restart, so it does and is in this endless loop. I tried restarting without the windows usb and the computer just booted into shell. I then resarted it again went to the boot menu and I didn’t see anything about the nvme drive or anything that said boot manager.

@walnut215 - Do not use those modules, this is the issue. Please read the guide again linked below, on how to mod the BIOS Use NvmExpressDxe_4.ffs or if you have to NvmExpressDxe_Small.ffs
NVME does not go under CMSCore, it goes to the end of that same volume only. There will not be any new boot option in BIOS, only you will see “Windows Boot Loader” as a boot device to move to the top of the boot disk order list, after you install windows.
Before that it will be PATA or PATA SS, this means mod BIOS successfully flashed in, but you do not boot to these.

You must do all steps at #4 of this guide in the “This is what you should do” section, after you flash in the mod BIOS - [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

If you need me to make you a mod BIOS let me know (Already made now, if you want, let me know and I will upload)

DISK should be RAW or At least Initialized as GPT, cannot be MBR

Thanks, I’m going to give it another go later tonight or tomorrow. I might take you up on the bios if I can’t get it.
------------------------

@Lost_N_BIOS , Thanks for your help. I was able to get it up and running.

----------------------

@Lost_N_BIOS

Everything was working fine, until it wasn’t. I reinstalled my old hard drive, that had been formatted. Windows was gone. As soon as I restarted windows started to try to diagnose my problem. I was able to get into BIOS and I could manually select the NVME drive. I did this multiple times and some how it stuck. I restarted bumped up my CPU multiplier, turned off c-state, and overpower protection. It booted. Then I restarted it and bumped up the multiplier again. Windows said it couldn’t start, so I tried to go back to BIOS to return every thing to defaults. Now I just get a black screen. When i hit delete to bring up the bios starting setup or something like that on the bottom left corner of the screen. It just stays there. I can get it to boot with the backup bios switch, but I’m hoping I didn’t screw up the first bios chip. Anyway, do you have any thoughts as to what’s going on?

@walnut215 - Nice to see you were able to get it sorted out yourself Good job

Remove your old hard drive, sounds like you maybe did not remove the bootloader on hidden partitions. You need to open that drive in a partition application, such as EaseUS partition tool, and then wipe out all partitions - https://www.easeus.com/partition-manager/epm-free.html
You can do this from an older XP system, or if you can get back into normal NVME windows, you can wipe it from there

Or yes, you may just need to move “Windows Boot Loader” on the NVME to top of the hard drive boot priority list.

If you did mess up the main BIOS somehow, it’s OK. Have mod BIOS ready on USB, Boot to backup BIOS, then when in BIOS go into M-Flash and once in there flip the switch back to the MAIN BIOS, then flash the BIOS again.

@Lost_N_BIOS everything worked out. Thanks.

@walnut215 - Great to hear all is well

@Lost_N_BIOS I was wondering if you’ve ever heard of anyone modding their bios to have an avx offset. My bios doesn’t have one, and given how I use my PC it would be helpful to have it.

@walnut215 - That is only possible if the BIOS has the setting in it, and they maybe unhide it or something. That or the crossflash/port BIOS from another board into their BIOS, which is rare and probably not something many people do all that often, especially not for simple BIOS settings.
Do you see someone mention MSI X79 board has it? If yes, which model, I will check it out for you and see if you can maybe crossflash.

@Lost_N_BIOS I know my board has some hidden settings. If I enter the click Bios 2 in windows there are additional power settings that I can’t access in regular bios, that I would like to. Using click bios in windows is not reliable even if I run it as an admin. There maybe even more settings completely hidden. How do you go about finding them?

I will look at other x79 boards. I’m also going to send Brian from techyescity (you tube channel) a message on facebook. He’s done a lot of videos on x79 and I know he has multiple mobos. His videos focus mostly on used parts. They are fun and informative, and if you have some free time might be worth a look.

Thanks

@Lost_N_BIOS I just wanted to give you an update. I was looking to get an AVX offset because some of my work loads are AVX dependent, while gaming is less AVX dependent. I was trying to find a collection of setting that would lead to increased fps in games, but still be stable under a linpack work load. I think it’s going to be more efficient to just create two bios profiles, one for gaming and one for work.

Have you heard of anyone having issues because they switch profiles often?

Thanks

@walnut215 -I happed to have the same motherboard as you would you be willing to share a copy of the modded bios you made?

@walnut215 - If the settings you want are in your BIOS, I can make them visible for you. Show me image of what you’re seeing in click BIOS in windows, then I will edit BIOS for you
If you want me to do this, link/upload the BIOS you want edited, unless you just want me to edit stock one, if stock let me know what version.

AVX Offset is not likely to be a BIOS setting, due to this is such an older model, AVX offset lowering was something introduced later on in more modern BIOS after AVX had been around for a while.
No, I’ve not heard of profile switching issues.

Hi, I also have this board and want your NVME modded UEFI file, do you even still have it?

@castrwilliam - What is your exact model?? Here is link to both NVME mod BIOS
X79A-GD45 (8D) - [Request] NVMe BIOS mod for MSI X79A-GD45 (8D)
X79A-GD45 - [Request] nvme bios mod for msi X79A-GD45

Do you have a nvme modded bios for x79a-gd45 plus (ms-7760)
https://us.msi.com/Motherboard/support/X79A-GD45-Plus
I am using stock bios v17.8

I also need a NVME mod BIOS for MSI X79A-GD45 PLUS (ms-7760) motherboard
I am using stock bios v17.9
If someone could make a modded bios file, or point me in the right direction where one is already made, it would be greatly appreciated.
Not sure if the mod BIOS for the X79A-GD45 (8D) or the X79A-GD45 will work.

thanks